Update to 3.9.0a4
Patches 340 and 341 got upstreamed and are no longer present.
This commit is contained in:
parent
088c30cb53
commit
1206bb9631
@ -1,4 +1,4 @@
|
||||
From d3b41a40387088ab6e32744b71405449361aa035 Mon Sep 17 00:00:00 2001
|
||||
From 85a385ad599f6232286497b3c67b215b3f388c21 Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
||||
Subject: [PATCH] 00001: Fixup distutils/unixccompiler.py to remove standard
|
||||
|
@ -1,4 +1,4 @@
|
||||
From bc29c675016279f6f6a6b4ed140a45710d9840d9 Mon Sep 17 00:00:00 2001
|
||||
From de23a0cc0e2471d12aa82813e4fb6cf937ad1a51 Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Wed, 13 Jan 2010 21:25:18 +0000
|
||||
Subject: [PATCH] 00102: Change the various install paths to use /usr/lib64/
|
||||
@ -154,7 +154,7 @@ index 41c4229919..543c88432a 100644
|
||||
'site-packages')
|
||||
self.assertEqual(dirs[0], wanted)
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index cfe42b4f21..d8766ec09d 100644
|
||||
index 3199a1aa02..8dc55c158f 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -143,7 +143,7 @@ LIBDIR= @libdir@
|
||||
@ -198,10 +198,10 @@ index 8632d1fe6d..09a818609e 100644
|
||||
return DECODE_LOCALE_ERR("EXEC_PREFIX macro", len);
|
||||
}
|
||||
diff --git a/configure b/configure
|
||||
index 85120e498d..a472d7fac3 100755
|
||||
index 846116e112..aaadb30ef9 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -15216,9 +15216,9 @@ fi
|
||||
@@ -15233,9 +15233,9 @@ fi
|
||||
|
||||
|
||||
if test x$PLATFORM_TRIPLET = x; then
|
||||
@ -214,10 +214,10 @@ index 85120e498d..a472d7fac3 100755
|
||||
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ab8e1b7d27..56e8f3e11e 100644
|
||||
index 840caf352d..ac4a44bdb8 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -4706,9 +4706,9 @@ fi
|
||||
@@ -4711,9 +4711,9 @@ fi
|
||||
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
||||
AC_SUBST(PY_ENABLE_SHARED)
|
||||
if test x$PLATFORM_TRIPLET = x; then
|
||||
@ -230,7 +230,7 @@ index ab8e1b7d27..56e8f3e11e 100644
|
||||
AC_SUBST(LIBPL)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 02f523c42d..559498d14b 100644
|
||||
index 51e67fe4a5..bafa0bf99a 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -649,7 +649,7 @@ class PyBuildExt(build_ext):
|
||||
@ -242,7 +242,7 @@ index 02f523c42d..559498d14b 100644
|
||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
||||
# only change this for cross builds for 3.3, issues on Mageia
|
||||
if CROSS_COMPILING:
|
||||
@@ -953,11 +953,11 @@ class PyBuildExt(build_ext):
|
||||
@@ -955,11 +955,11 @@ class PyBuildExt(build_ext):
|
||||
elif curses_library:
|
||||
readline_libs.append(curses_library)
|
||||
elif self.compiler.find_library_file(self.lib_dirs +
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 736a0814aef8ec3883dc9dec394001c7c66b4cc0 Mon Sep 17 00:00:00 2001
|
||||
From c58e1db077a3d7502640d2e5863e683b281fcf7b Mon Sep 17 00:00:00 2001
|
||||
From: David Malcolm <dmalcolm@redhat.com>
|
||||
Date: Mon, 18 Jan 2010 17:59:07 +0000
|
||||
Subject: [PATCH] 00111: Don't try to build a libpythonMAJOR.MINOR.a
|
||||
@ -21,7 +21,7 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
||||
1 file changed, 2 insertions(+), 19 deletions(-)
|
||||
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index d8766ec09d..af24a2fe2a 100644
|
||||
index 8dc55c158f..e1f021fbab 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -562,7 +562,7 @@ clinic: check-clean-src $(srcdir)/Modules/_blake2/blake2s_impl.c
|
||||
@ -55,7 +55,7 @@ index d8766ec09d..af24a2fe2a 100644
|
||||
$(LINKCC) $(PY_CORE_LDFLAGS) $(LINKFORSHARED) -o $@ Programs/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS)
|
||||
|
||||
############################################################################
|
||||
@@ -1562,17 +1556,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
@@ -1567,17 +1561,6 @@ libainstall: @DEF_MAKE_RULE@ python-config
|
||||
else true; \
|
||||
fi; \
|
||||
done
|
||||
|
@ -1,12 +1,12 @@
|
||||
From 234fb84eea72ba856d7add39b5faee5e54ceba61 Mon Sep 17 00:00:00 2001
|
||||
From 1e8c543d53d2aa0c92381c1e1995a58b57361bef Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Wed, 15 Aug 2018 15:36:29 +0200
|
||||
Subject: [PATCH] 00189: Instead of bundled wheels, use our RPM packaged wheels
|
||||
|
||||
We keep them in /usr/share/python-wheels
|
||||
---
|
||||
Lib/ensurepip/__init__.py | 31 ++++++++++++++++++++-----------
|
||||
1 file changed, 20 insertions(+), 11 deletions(-)
|
||||
Lib/ensurepip/__init__.py | 33 ++++++++++++++++++++++-----------
|
||||
1 file changed, 22 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/Lib/ensurepip/__init__.py b/Lib/ensurepip/__init__.py
|
||||
index 386ed6c25c..dae2ba22e4 100644
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 87ea0dc2466a5496946d90c2531ca38f9acb3ac7 Mon Sep 17 00:00:00 2001
|
||||
From 0d3595ce9f30425aaceaf02c9adb6faa044db18d Mon Sep 17 00:00:00 2001
|
||||
From: Michal Cyprian <m.cyprian@gmail.com>
|
||||
Date: Mon, 26 Jun 2017 16:32:56 +0200
|
||||
Subject: [PATCH] 00251: Change user install location
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 5201fc9ca191439c337c238542efb85b1f91ed57 Mon Sep 17 00:00:00 2001
|
||||
From 1da0d675508c66baafaca8cd811fb9ac7719c998 Mon Sep 17 00:00:00 2001
|
||||
From: Petr Viktorin <pviktori@redhat.com>
|
||||
Date: Mon, 28 Aug 2017 17:16:46 +0200
|
||||
Subject: [PATCH] 00274: Upstream uses Debian-style architecture naming, change
|
||||
@ -29,10 +29,10 @@ index ba37cf99e2..52a9ec6662 100755
|
||||
ppc64le | powerpc64little)
|
||||
basic_machine=powerpc64le-unknown
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 56e8f3e11e..a66d6ebcda 100644
|
||||
index ac4a44bdb8..504618db12 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -753,9 +753,9 @@ cat >> conftest.c <<EOF
|
||||
@@ -759,9 +759,9 @@ cat >> conftest.c <<EOF
|
||||
alpha-linux-gnu
|
||||
# elif defined(__ARM_EABI__) && defined(__ARM_PCS_VFP)
|
||||
# if defined(__ARMEL__)
|
||||
@ -44,7 +44,7 @@ index 56e8f3e11e..a66d6ebcda 100644
|
||||
# endif
|
||||
# elif defined(__ARM_EABI__) && !defined(__ARM_PCS_VFP)
|
||||
# if defined(__ARMEL__)
|
||||
@@ -795,7 +795,7 @@ cat >> conftest.c <<EOF
|
||||
@@ -801,7 +801,7 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64el-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
@ -53,7 +53,7 @@ index 56e8f3e11e..a66d6ebcda 100644
|
||||
# else
|
||||
# error unknown platform triplet
|
||||
# endif
|
||||
@@ -805,22 +805,22 @@ cat >> conftest.c <<EOF
|
||||
@@ -811,22 +811,22 @@ cat >> conftest.c <<EOF
|
||||
# elif _MIPS_SIM == _ABIN32
|
||||
mips64-linux-gnuabin32
|
||||
# elif _MIPS_SIM == _ABI64
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 846d6945a4e8cfe448bfb211e0898ad70984d450 Mon Sep 17 00:00:00 2001
|
||||
From 662a4a0ab64b6801a5051b042ddc21224b9cd34e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Thu, 11 Jul 2019 13:44:13 +0200
|
||||
Subject: [PATCH] 00328: Restore pyc to TIMESTAMP invalidation mode as default
|
||||
|
@ -1,25 +0,0 @@
|
||||
From e03f3216bbf99b64cfa27343d20534fb306ea2e5 Mon Sep 17 00:00:00 2001
|
||||
From: Dino Viehland <dinoviehland@gmail.com>
|
||||
Date: Mon, 27 Jan 2020 14:04:56 -0800
|
||||
Subject: [PATCH] 00340: Add test.test_import.data.unwritable package to
|
||||
makefile
|
||||
|
||||
---
|
||||
Makefile.pre.in | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
||||
index af24a2fe2a..aa20b65aac 100644
|
||||
--- a/Makefile.pre.in
|
||||
+++ b/Makefile.pre.in
|
||||
@@ -1330,6 +1330,7 @@ LIBSUBDIRS= tkinter tkinter/test tkinter/test/test_tkinter \
|
||||
test/test_import/data/circular_imports/subpkg \
|
||||
test/test_import/data/package \
|
||||
test/test_import/data/package2 \
|
||||
+ test/test_import/data/unwritable \
|
||||
importlib \
|
||||
importlib/metadata \
|
||||
test/test_importlib \
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,41 +0,0 @@
|
||||
From e457696601c6535f65105745998662398dbab064 Mon Sep 17 00:00:00 2001
|
||||
From: Victor Stinner <vstinner@python.org>
|
||||
Date: Wed, 29 Jan 2020 15:23:29 +0100
|
||||
Subject: [PATCH] 00341: bpo-39460: Fix test_zipfile.test_add_file_after_2107()
|
||||
|
||||
XFS filesystem is limited to 32-bit timestamp, but the utimensat()
|
||||
syscall doesn't fail. Moreover, there is a VFS bug which returns
|
||||
a cached timestamp which is different than the value on disk.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1795576
|
||||
https://bugs.python.org/issue39460#msg360952
|
||||
---
|
||||
Lib/test/test_zipfile.py | 12 ++++++++++++
|
||||
1 file changed, 12 insertions(+)
|
||||
|
||||
diff --git a/Lib/test/test_zipfile.py b/Lib/test/test_zipfile.py
|
||||
index 66f05ac1f3..4c20bfd7e2 100644
|
||||
--- a/Lib/test/test_zipfile.py
|
||||
+++ b/Lib/test/test_zipfile.py
|
||||
@@ -616,6 +616,18 @@ class StoredTestsWithSourceFile(AbstractTestsWithSourceFile,
|
||||
except OverflowError:
|
||||
self.skipTest('Host fs cannot set timestamp to required value.')
|
||||
|
||||
+ mtime_ns = os.stat(TESTFN).st_mtime_ns
|
||||
+ if mtime_ns != (4386268800 * 10**9):
|
||||
+ # XFS filesystem is limited to 32-bit timestamp, but the syscall
|
||||
+ # didn't fail. Moreover, there is a VFS bug which returns
|
||||
+ # a cached timestamp which is different than the value on disk.
|
||||
+ #
|
||||
+ # Test st_mtime_ns rather than st_mtime to avoid rounding issues.
|
||||
+ #
|
||||
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1795576
|
||||
+ # https://bugs.python.org/issue39460#msg360952
|
||||
+ self.skipTest(f"Linux VFS/XFS kernel bug detected: {mtime_ns=}")
|
||||
+
|
||||
with zipfile.ZipFile(TESTFN2, "w") as zipfp:
|
||||
self.assertRaises(struct.error, zipfp.write, TESTFN)
|
||||
|
||||
--
|
||||
2.24.1
|
||||
|
@ -14,10 +14,10 @@ URL: https://www.python.org/
|
||||
# WARNING When rebasing to a new Python version,
|
||||
# remember to update the python3-docs package as well
|
||||
%global general_version %{pybasever}.0
|
||||
%global prerel a3
|
||||
%global prerel a4
|
||||
%global upstream_version %{general_version}%{?prerel}
|
||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: Python
|
||||
|
||||
|
||||
@ -276,20 +276,6 @@ Patch274: 00274-fix-arch-names.patch
|
||||
# Ideally, we should talk to upstream and explain why we don't want this
|
||||
Patch328: 00328-pyc-timestamp-invalidation-mode.patch
|
||||
|
||||
# 00340 #
|
||||
# Add test.test_import.data.unwritable package to makefile
|
||||
# Fixed upstream: https://bugs.python.org/issue39459
|
||||
Patch340: 00340-makefile-missing-test.patch
|
||||
|
||||
# 00341 #
|
||||
# Fix test_zipfile.test_add_file_after_2107()
|
||||
# XFS filesystem is limited to 32-bit timestamp, but the utimensat()
|
||||
# syscall doesn't fail. Moreover, there is a VFS bug which returns
|
||||
# a cached timestamp which is different than the value on disk.
|
||||
# Workarounds https://bugzilla.redhat.com/show_bug.cgi?id=1795576
|
||||
# Workarounded upstream: https://bugs.python.org/issue39460
|
||||
Patch341: 00341-bpo-39460.patch
|
||||
|
||||
# (New patches go here ^^^)
|
||||
#
|
||||
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
|
||||
@ -637,8 +623,6 @@ rm Lib/ensurepip/_bundled/*.whl
|
||||
%patch251 -p1
|
||||
%patch274 -p1
|
||||
%patch328 -p1
|
||||
%patch340 -p1
|
||||
%patch341 -p1
|
||||
|
||||
|
||||
# Remove files that should be generated by the build
|
||||
@ -708,6 +692,9 @@ BuildPython() {
|
||||
# Since we changed directories, we need to tell %%configure where to look.
|
||||
%global _configure $topdir/configure
|
||||
|
||||
# A workaround for https://bugs.python.org/issue39761
|
||||
export DFLAGS=" "
|
||||
|
||||
%configure \
|
||||
--enable-ipv6 \
|
||||
--enable-shared \
|
||||
@ -1589,6 +1576,9 @@ CheckPython optimized
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Thu Feb 27 2020 Marcel Plch <mplch@redhat.com> - 3.9.0~a4-1
|
||||
- Update to Python 3.9.0a4
|
||||
|
||||
* Tue Feb 11 2020 Miro Hrončok <mhroncok@redhat.com> - 3.9.0~a3-2
|
||||
- Update the ensurepip module to work with setuptools >= 45
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (Python-3.9.0a3.tar.xz.asc) = e0a12043f9cd110b9315bec0109713868bc8b8d8e94c3859fc55cbefa0d8ae64236eee057bf65229e67b0668cb6a7cfb18f50bfcfd546b37501113630e53db72
|
||||
SHA512 (Python-3.9.0a3.tar.xz) = 79475a97503818b526ba4d810e34c9d30fec94ce9c1fa20ef147cbbf8185d310b1f1baa484872eb5f6fc4ce7a92a9d3401773e8fc8a7f610a6bf9173e7426fc7
|
||||
SHA512 (Python-3.9.0a4.tar.xz) = 8f7ca0a891fb7e7868dfe5f040e9ceb7ce14d036bc5d9eae1493570c5a9631832e796a1972590c444d2347c585b0c8216345375dd1476b4da7bd47e187591afc
|
||||
SHA512 (Python-3.9.0a4.tar.xz.asc) = 67f55246d3cbe46a71aae2328b36452cc9c33191bbcae13abb083e63a7eb923c4db63731add04456c9cb657bf5126137e7047e90de3afdc24dd082d194aa8837
|
||||
|
Loading…
Reference in New Issue
Block a user