add correct arch for ppc64/ppc64le to fix build failure, it should be
ppc64le-linux-gnu/ppc64-linux-gnu instead powerpc64le-linux-gnu/powerpc64-linux-gnu http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2900961
This commit is contained in:
parent
08374589d7
commit
0efd3d31cb
30
python3-powerppc-arch.patch
Normal file
30
python3-powerppc-arch.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -up Python-3.5.0/configure.ac.than Python-3.5.0/configure.ac
|
||||||
|
--- Python-3.5.0/configure.ac.than 2015-11-13 11:51:32.039560172 -0500
|
||||||
|
+++ Python-3.5.0/configure.ac 2015-11-13 11:52:11.670168157 -0500
|
||||||
|
@@ -804,9 +804,9 @@ cat >> conftest.c <<EOF
|
||||||
|
powerpc-linux-gnuspe
|
||||||
|
# elif defined(__powerpc64__)
|
||||||
|
# if defined(__LITTLE_ENDIAN__)
|
||||||
|
- powerpc64le-linux-gnu
|
||||||
|
+ ppc64le-linux-gnu
|
||||||
|
# else
|
||||||
|
- powerpc64-linux-gnu
|
||||||
|
+ ppc64-linux-gnu
|
||||||
|
# endif
|
||||||
|
# elif defined(__powerpc__)
|
||||||
|
powerpc-linux-gnu
|
||||||
|
diff -up Python-3.5.0/configure.than Python-3.5.0/configure
|
||||||
|
--- Python-3.5.0/configure.than 2015-11-13 12:13:19.039658399 -0500
|
||||||
|
+++ Python-3.5.0/configure 2015-11-13 12:13:35.199906857 -0500
|
||||||
|
@@ -5153,9 +5153,9 @@ cat >> conftest.c <<EOF
|
||||||
|
powerpc-linux-gnuspe
|
||||||
|
# elif defined(__powerpc64__)
|
||||||
|
# if defined(__LITTLE_ENDIAN__)
|
||||||
|
- powerpc64le-linux-gnu
|
||||||
|
+ ppc64le-linux-gnu
|
||||||
|
# else
|
||||||
|
- powerpc64-linux-gnu
|
||||||
|
+ ppc64-linux-gnu
|
||||||
|
# endif
|
||||||
|
# elif defined(__powerpc__)
|
||||||
|
powerpc-linux-gnu
|
11
python3.spec
11
python3.spec
@ -140,7 +140,7 @@
|
|||||||
Summary: Version 3 of the Python programming language aka Python 3000
|
Summary: Version 3 of the Python programming language aka Python 3000
|
||||||
Name: python3
|
Name: python3
|
||||||
Version: %{pybasever}.0
|
Version: %{pybasever}.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
|
|
||||||
@ -776,6 +776,10 @@ Patch207: 00207-hide-atomic-symbols.patch
|
|||||||
# above:
|
# above:
|
||||||
Patch5000: 05000-autotool-intermediates.patch
|
Patch5000: 05000-autotool-intermediates.patch
|
||||||
|
|
||||||
|
# add correct arch for ppc64/ppc64le
|
||||||
|
# it should be ppc64le-linux-gnu/ppc64-linux-gnu instead powerpc64le-linux-gnu/powerpc64-linux-gnu
|
||||||
|
Patch5001: python3-powerppc-arch.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
# ======================================================
|
# ======================================================
|
||||||
@ -1060,6 +1064,8 @@ sed --in-place \
|
|||||||
%patch5000 -p0 -b .autotool-intermediates
|
%patch5000 -p0 -b .autotool-intermediates
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%patch5001 -p1
|
||||||
|
|
||||||
# ======================================================
|
# ======================================================
|
||||||
# Configuring and building the code:
|
# Configuring and building the code:
|
||||||
# ======================================================
|
# ======================================================
|
||||||
@ -1943,6 +1949,9 @@ rm -fr %{buildroot}
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 13 2015 Than Ngo <than@redhat.com> 3.5.0-4
|
||||||
|
- add correct arch for ppc64/ppc64le to fix build failure
|
||||||
|
|
||||||
* Wed Nov 11 2015 Robert Kuska <rkuska@redhat.com> - 3.5.0-3
|
* Wed Nov 11 2015 Robert Kuska <rkuska@redhat.com> - 3.5.0-3
|
||||||
- Hide the private _Py_atomic_xxx symbols from public header
|
- Hide the private _Py_atomic_xxx symbols from public header
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user