Define HAVE_LONG_LONG as 1 for backwards compatibility.
This commit is contained in:
parent
1abbc727d4
commit
0da740b7bc
24
00253-fix-HAVE_LONG_LONG-compatibility.patch
Normal file
24
00253-fix-HAVE_LONG_LONG-compatibility.patch
Normal file
@ -0,0 +1,24 @@
|
||||
|
||||
# HG changeset patch
|
||||
# User Victor Stinner <victor.stinner@gmail.com>
|
||||
# Date 1483653533 -3600
|
||||
# Node ID fad67c66885f0bd9ebafe2a54f0fa12b5a8fe3bf
|
||||
# Parent 52d671684342cd2dcc804566d4c755634d3210a8
|
||||
Issue #27961: Define HAVE_LONG_LONG as 1.
|
||||
|
||||
Fix backward compatibility issue, HAVE_LONG_LONG was defined but empty, whereas
|
||||
it is defined as 1 in Python 3.5.
|
||||
|
||||
diff --git a/Include/pyport.h b/Include/pyport.h
|
||||
--- a/Include/pyport.h
|
||||
+++ b/Include/pyport.h
|
||||
@@ -39,7 +39,7 @@ Used in: Py_SAFE_DOWNCAST
|
||||
|
||||
// long long is required. Ensure HAVE_LONG_LONG is defined for compatibility.
|
||||
#ifndef HAVE_LONG_LONG
|
||||
-#define HAVE_LONG_LONG
|
||||
+#define HAVE_LONG_LONG 1
|
||||
#endif
|
||||
#ifndef PY_LONG_LONG
|
||||
#define PY_LONG_LONG long long
|
||||
|
11
python3.spec
11
python3.spec
@ -124,7 +124,7 @@
|
||||
Summary: Version 3 of the Python programming language aka Python 3000
|
||||
Name: python3
|
||||
Version: %{pybasever}.0
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: Python
|
||||
Group: Development/Languages
|
||||
|
||||
@ -408,6 +408,11 @@ Patch249: 00249-fix-out-of-tree-dtrace-builds.patch
|
||||
# http://bugs.python.org/issue29157
|
||||
Patch250: 00250-getentropy.patch
|
||||
|
||||
# 00253 #
|
||||
# Define HAVE_LONG_LONG as 1 instead of blank for backwards compatibility
|
||||
# Fixed upstream: https://hg.python.org/cpython/rev/fad67c66885f
|
||||
Patch253: fix-HAVE_LONG_LONG-compatibility.patch
|
||||
|
||||
# (New patches go here ^^^)
|
||||
#
|
||||
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
|
||||
@ -646,6 +651,7 @@ sed -r -i s/'_PIP_VERSION = "[0-9.]+"'/'_PIP_VERSION = "%{pip_version}"'/ Lib/en
|
||||
%patch243 -p1
|
||||
%patch249 -p1
|
||||
%patch250 -p1
|
||||
%patch253 -p1
|
||||
|
||||
# Currently (2010-01-15), http://docs.python.org/library is for 2.6, and there
|
||||
# are many differences between 2.6 and the Python 3 library.
|
||||
@ -1564,6 +1570,9 @@ rm -fr %{buildroot}
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Mon Jan 09 2017 Charalampos Stratakis <cstratak@redhat.com> - 3.6.0-4
|
||||
- Define HAVE_LONG_LONG as 1 for backwards compatibility
|
||||
|
||||
* Thu Jan 05 2017 Miro Hrončok <mhroncok@redhat.com> - 3.6.0-3
|
||||
- Don't blow up on EL7 kernel (random generator) (rhbz#1410175)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user