Update to 3.10.0b4
- patch 363 was a backport - bundled pip was updated to 21.1.3
This commit is contained in:
parent
943f8cc201
commit
08bde6d5c8
@ -1,36 +0,0 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
|
||||
Date: Fri, 18 Jun 2021 15:16:04 +0200
|
||||
Subject: [PATCH] 00363: Reset DeprecationWarning filters in
|
||||
test_importlib.test_entry_points_by_index
|
||||
|
||||
This avoids StopIteration error when running tests.
|
||||
|
||||
https://bugs.python.org/issue44451
|
||||
---
|
||||
Lib/test/test_importlib/test_metadata_api.py | 1 +
|
||||
.../NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst | 3 +++
|
||||
2 files changed, 4 insertions(+)
|
||||
create mode 100644 Misc/NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst
|
||||
|
||||
diff --git a/Lib/test/test_importlib/test_metadata_api.py b/Lib/test/test_importlib/test_metadata_api.py
|
||||
index 3506493463..2bfc44b18e 100644
|
||||
--- a/Lib/test/test_importlib/test_metadata_api.py
|
||||
+++ b/Lib/test/test_importlib/test_metadata_api.py
|
||||
@@ -139,6 +139,7 @@ def test_entry_points_by_index(self):
|
||||
"""
|
||||
eps = distribution('distinfo-pkg').entry_points
|
||||
with warnings.catch_warnings(record=True) as caught:
|
||||
+ warnings.filterwarnings("default", category=DeprecationWarning)
|
||||
eps[0]
|
||||
|
||||
# check warning
|
||||
diff --git a/Misc/NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst b/Misc/NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst
|
||||
new file mode 100644
|
||||
index 0000000000..0f635cfe18
|
||||
--- /dev/null
|
||||
+++ b/Misc/NEWS.d/next/Tests/2021-06-18-15-19-35.bpo-44451.aj5pqE.rst
|
||||
@@ -0,0 +1,3 @@
|
||||
+Reset ``DeprecationWarning`` filters in
|
||||
+``test.test_importlib.test_metadata_api.APITests.test_entry_points_by_index``
|
||||
+to avoid ``StopIteration`` error if ``DeprecationWarnings`` are ignored.
|
@ -14,7 +14,7 @@ URL: https://www.python.org/
|
||||
# WARNING When rebasing to a new Python version,
|
||||
# remember to update the python3-docs package as well
|
||||
%global general_version %{pybasever}.0
|
||||
%global prerel b3
|
||||
%global prerel b4
|
||||
%global upstream_version %{general_version}%{?prerel}
|
||||
Version: %{general_version}%{?prerel:~%{prerel}}
|
||||
Release: 1%{?dist}
|
||||
@ -68,7 +68,7 @@ License: Python
|
||||
# If the rpmwheels condition is disabled, we use the bundled wheel packages
|
||||
# from Python with the versions below.
|
||||
# This needs to be manually updated when we update Python.
|
||||
%global pip_version 21.1.1
|
||||
%global pip_version 21.1.3
|
||||
%global setuptools_version 56.0.0
|
||||
|
||||
# Expensive optimizations (mainly, profile-guided optimizations)
|
||||
@ -292,14 +292,6 @@ Patch251: 00251-change-user-install-location.patch
|
||||
# Ideally, we should talk to upstream and explain why we don't want this
|
||||
Patch328: 00328-pyc-timestamp-invalidation-mode.patch
|
||||
|
||||
# 00363 # bcb4a805ad54d3a810fb54582e67c5f5fe6d9773
|
||||
# Reset DeprecationWarning filters in test_importlib.test_entry_points_by_index
|
||||
#
|
||||
# This avoids StopIteration error when running tests.
|
||||
#
|
||||
# https://bugs.python.org/issue44451
|
||||
Patch363: 00363-reset-deprecationwarning-filters-in-test_importlib-test_entry_points_by_index.patch
|
||||
|
||||
# (New patches go here ^^^)
|
||||
#
|
||||
# When adding new patches to "python" and "python3" in Fedora, EL, etc.,
|
||||
@ -1586,6 +1578,9 @@ CheckPython optimized
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Sun Jul 11 2021 Miro Hrončok <mhroncok@redhat.com> - 3.10.0~b4-1
|
||||
- Update to 3.10.0b4
|
||||
|
||||
* Thu Jun 17 2021 Miro Hrončok <mhroncok@redhat.com> - 3.10.0~b3-1
|
||||
- Update to 3.10.0b3
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (Python-3.10.0b3.tar.xz) = ef0dc5eddb5f9702ab88faa2827455347caa81ab6c03192d6e37c968a40c53ab485d5c923905c511d19bc35e10129aa302f6733e0a7d296da8f725367dd1b258
|
||||
SHA512 (Python-3.10.0b3.tar.xz.asc) = 6b8d2caf753f0d92019e18d1441e323a44aff06ee8bdc272572a67359dc4bece833db56b9318c91962d39ee4d09bf701b548d71ae02c4b64f3c21f1c23ed1d36
|
||||
SHA512 (Python-3.10.0b4.tar.xz) = deb5ce510c381ce7fcdc7056754b3afccdbc4610cb77b85115859a5e636065584f517e0931a31f77723c09229b2fd751011b1cf16967c075f629018f0a7975a4
|
||||
SHA512 (Python-3.10.0b4.tar.xz.asc) = 55ef4265d9217f35e5f1da3b8b560f711c3f118230ff5fb7fe3ab5e189c22c331cecb9783465234ac0df8a1e075887b5fedfbc181cab6e571e5e2f8403d9720d
|
||||
|
Loading…
Reference in New Issue
Block a user