python3-cangjie/0001-build-Explicitly-set-the-include-path.patch
2015-06-19 12:04:01 +02:00

44 lines
1.6 KiB
Diff

From 5ba4e199a715cf5f935418d2bbf7f1930a24cb39 Mon Sep 17 00:00:00 2001
From: Mathieu Bridon <bochecha@daitauha.fr>
Date: Mon, 2 Mar 2015 13:34:16 +0800
Subject: [PATCH] build: Explicitly set the include path
This fixes build with Cython 0.22
https://bugs.gentoo.org/show_bug.cgi?id=541022
---
Makefile.am | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 6762b97..c0cc699 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,19 +47,19 @@ pkgpyexecdir = $(pyexecdir)/cangjie
src/cangjie/_core.c: src/cangjie/_core.pyx src/cangjie/_core.pxd
$(MKDIR_P) src/cangjie
- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/_core.pyx
+ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/_core.pyx
src/cangjie/errors.c: src/cangjie/errors.pyx src/cangjie/_core.pxd
$(MKDIR_P) src/cangjie
- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/errors.pyx
+ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/errors.pyx
src/cangjie/filters.c: src/cangjie/filters.pyx src/cangjie/_core.pxd
$(MKDIR_P) src/cangjie
- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/filters.pyx
+ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/filters.pyx
src/cangjie/versions.c: src/cangjie/versions.pyx src/cangjie/_core.pxd
$(MKDIR_P) src/cangjie
- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/versions.pyx
+ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/versions.pyx
# -- Testing -------------------------
TESTS = tests/run_tests
--
2.4.3