FTBFS: Use upstream patch to fix the build

This commit is contained in:
Mathieu Bridon 2015-06-19 12:04:01 +02:00
parent 405b9956c4
commit ece156aedb
2 changed files with 53 additions and 1 deletions

View File

@ -0,0 +1,43 @@
From 5ba4e199a715cf5f935418d2bbf7f1930a24cb39 Mon Sep 17 00:00:00 2001
From: Mathieu Bridon <bochecha@daitauha.fr>
Date: Mon, 2 Mar 2015 13:34:16 +0800
Subject: [PATCH] build: Explicitly set the include path
This fixes build with Cython 0.22
https://bugs.gentoo.org/show_bug.cgi?id=541022
---
Makefile.am | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 6762b97..c0cc699 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,19 +47,19 @@ pkgpyexecdir = $(pyexecdir)/cangjie
src/cangjie/_core.c: src/cangjie/_core.pyx src/cangjie/_core.pxd
$(MKDIR_P) src/cangjie
- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/_core.pyx
+ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/_core.pyx
src/cangjie/errors.c: src/cangjie/errors.pyx src/cangjie/_core.pxd
$(MKDIR_P) src/cangjie
- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/errors.pyx
+ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/errors.pyx
src/cangjie/filters.c: src/cangjie/filters.pyx src/cangjie/_core.pxd
$(MKDIR_P) src/cangjie
- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/filters.pyx
+ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/filters.pyx
src/cangjie/versions.c: src/cangjie/versions.pyx src/cangjie/_core.pxd
$(MKDIR_P) src/cangjie
- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/versions.pyx
+ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/versions.pyx
# -- Testing -------------------------
TESTS = tests/run_tests
--
2.4.3

View File

@ -3,11 +3,14 @@
Name: python3-%{module_name}
Summary: Python bindings to libcangjie
Version: 1.2
Release: 5%{?dist}
Release: 6%{?dist}
License: LGPLv3+
URL: http://cangjians.github.io/projects/pycangjie
Source0: http://cangjians.github.io/downloads/pycangjie/%{module_name}-%{version}.tar.xz
Patch0: 0001-build-Explicitly-set-the-include-path.patch
BuildRequires: autoconf automake libtool
BuildRequires: python3-Cython
BuildRequires: python3-devel
BuildRequires: libcangjie-devel >= 1.2
@ -20,8 +23,11 @@ input methods.
%prep
%setup -q -n %{module_name}-%{version}
%patch0 -p1
%build
autoreconf -i
%configure
make %{?_smp_mflags}
@ -42,6 +48,9 @@ make check
%changelog
* Fri Jun 19 2015 Mathieu Bridon <bochecha@daitauha.fr> - 1.2-6
- Use upstream patch to fix the FTBFS.
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild