43e7c42fba
- Refreshed patches: 0 (config), 7 (sqlite encoding), 16 (rpath in config), 55 (systemtap), 111 (no static lib), 112 (debug build), 113 (more configuration flags), 130 (add extension to python config), 134 (fix COUNT_ALLOCS in test_sys), 146 (haslib FIPS), 147 (add debug malloc stats), 153 (fix gdb test noise), 157 (uid, gid overflow - fixed upstream, just keeping few more downstream tests), 165 (crypt module salt backport), 175 (fix configure Wformat), 5000 (regenerated autotooling patch) - Dropped patches: 101 (lib64 regex; merged upstream), 171 (exception on missing /dev/urandom; merged upstream), 172 (poll for multiprocessing socket connection; merged upstream)
13 lines
565 B
Diff
13 lines
565 B
Diff
diff -up Python-2.7.3/configure.ac.fix-configure-Wformat Python-2.7.3/configure.ac
|
|
--- Python-2.7.3/configure.ac.fix-configure-Wformat 2013-03-25 15:15:18.473888383 -0400
|
|
+++ Python-2.7.3/configure.ac 2013-03-25 15:15:32.513887426 -0400
|
|
@@ -1200,7 +1200,7 @@ if test "$GCC" = "yes"
|
|
then
|
|
AC_MSG_CHECKING(whether gcc supports ParseTuple __format__)
|
|
save_CFLAGS=$CFLAGS
|
|
- CFLAGS="$CFLAGS -Werror"
|
|
+ CFLAGS="$CFLAGS -Werror -Wformat"
|
|
AC_COMPILE_IFELSE([
|
|
AC_LANG_PROGRAM([[void f(char*,...)__attribute((format(PyArg_ParseTuple, 1, 2)));]], [[]])
|
|
],[
|