7b42f48700
- Refreshed patches: 0 (config), 102 (lib64), 121 (add Modules to build path), 153 (gdb test noise) - Dropped patches: 126, 127 (big endian issues, both fixed upstream), 175 (configure -Wformat, fixed upstream) - Synced patch numbers with python3.spec.
14 lines
567 B
Diff
14 lines
567 B
Diff
--- Python-2.7.5/Lib/site.py.orig 2013-05-16 12:47:55.000000000 +0200
|
|
+++ Python-2.7.5/Lib/site.py 2013-05-16 12:56:20.089058109 +0200
|
|
@@ -529,6 +529,10 @@ def main():
|
|
|
|
abs__file__()
|
|
known_paths = removeduppaths()
|
|
+ from sysconfig import is_python_build
|
|
+ if is_python_build():
|
|
+ from _sysconfigdata import build_time_vars
|
|
+ sys.path.append(os.path.join(build_time_vars['abs_builddir'], 'Modules'))
|
|
if ENABLE_USER_SITE is None:
|
|
ENABLE_USER_SITE = check_enableusersite()
|
|
known_paths = addusersitepackages(known_paths)
|