43e7c42fba
- Refreshed patches: 0 (config), 7 (sqlite encoding), 16 (rpath in config), 55 (systemtap), 111 (no static lib), 112 (debug build), 113 (more configuration flags), 130 (add extension to python config), 134 (fix COUNT_ALLOCS in test_sys), 146 (haslib FIPS), 147 (add debug malloc stats), 153 (fix gdb test noise), 157 (uid, gid overflow - fixed upstream, just keeping few more downstream tests), 165 (crypt module salt backport), 175 (fix configure Wformat), 5000 (regenerated autotooling patch) - Dropped patches: 101 (lib64 regex; merged upstream), 171 (exception on missing /dev/urandom; merged upstream), 172 (poll for multiprocessing socket connection; merged upstream)
51 lines
1.7 KiB
Diff
51 lines
1.7 KiB
Diff
diff -up Python-2.6.5/configure.ac.more-configuration-flags Python-2.6.5/configure.ac
|
|
--- Python-2.6.5/configure.ac.more-configuration-flags 2010-05-24 18:51:25.410111792 -0400
|
|
+++ Python-2.6.5/configure.ac 2010-05-24 18:59:23.954986388 -0400
|
|
@@ -2515,6 +2515,30 @@ else AC_MSG_RESULT(no)
|
|
fi],
|
|
[AC_MSG_RESULT(no)])
|
|
|
|
+AC_MSG_CHECKING(for --with-count-allocs)
|
|
+AC_ARG_WITH(count-allocs,
|
|
+[ --with(out)count-allocs enable/disable per-type instance accounting], [
|
|
+if test "$withval" != no
|
|
+then
|
|
+ AC_DEFINE(COUNT_ALLOCS, 1,
|
|
+ [Define to keep records of the number of instances of each type])
|
|
+ AC_MSG_RESULT(yes)
|
|
+else AC_MSG_RESULT(no)
|
|
+fi],
|
|
+[AC_MSG_RESULT(no)])
|
|
+
|
|
+AC_MSG_CHECKING(for --with-call-profile)
|
|
+AC_ARG_WITH(call-profile,
|
|
+[ --with(out)-call-profile enable/disable statistics on function call invocation], [
|
|
+if test "$withval" != no
|
|
+then
|
|
+ AC_DEFINE(CALL_PROFILE, 1,
|
|
+ [Define to keep records on function call invocation])
|
|
+ AC_MSG_RESULT(yes)
|
|
+else AC_MSG_RESULT(no)
|
|
+fi],
|
|
+[AC_MSG_RESULT(no)])
|
|
+
|
|
# Check for Python-specific malloc support
|
|
AC_MSG_CHECKING(for --with-pymalloc)
|
|
AC_ARG_WITH(pymalloc,
|
|
diff -up Python-2.6.5/pyconfig.h.in.more-configuration-flags Python-2.6.5/pyconfig.h.in
|
|
--- Python-2.6.5/pyconfig.h.in.more-configuration-flags 2010-05-24 18:51:45.677988086 -0400
|
|
+++ Python-2.6.5/pyconfig.h.in 2010-05-24 19:00:44.163987730 -0400
|
|
@@ -1019,6 +1019,12 @@
|
|
/* Define to profile with the Pentium timestamp counter */
|
|
#undef WITH_TSC
|
|
|
|
+/* Define to keep records of the number of instances of each type */
|
|
+#undef COUNT_ALLOCS
|
|
+
|
|
+/* Define to keep records on function call invocation */
|
|
+#undef CALL_PROFILE
|
|
+
|
|
/* Define if you want pymalloc to be disabled when running under valgrind */
|
|
#undef WITH_VALGRIND
|
|
|