4b97eebe22
- 2.7.1, reworking patch 0 (config), patch 102 (lib64); drop upstream patch 56 (cfgparse), patch 110 (ctypes/SELinux/noexecmem), patch 119 (expat compat), patch 123 (2to3 on "from itertools import *") - fix test_abc's test_cache_leak in the debug build (patch 128) - drop _weakref.so from manifest (_weakref became a core module in r84230)
200 lines
9.2 KiB
Diff
200 lines
9.2 KiB
Diff
diff -up Python-2.7.1/Lib/distutils/command/install.py.lib64 Python-2.7.1/Lib/distutils/command/install.py
|
|
--- Python-2.7.1/Lib/distutils/command/install.py.lib64 2010-05-05 15:09:31.000000000 -0400
|
|
+++ Python-2.7.1/Lib/distutils/command/install.py 2010-12-23 15:51:19.422062062 -0500
|
|
@@ -42,14 +42,14 @@ else:
|
|
INSTALL_SCHEMES = {
|
|
'unix_prefix': {
|
|
'purelib': '$base/lib/python$py_version_short/site-packages',
|
|
- 'platlib': '$platbase/lib/python$py_version_short/site-packages',
|
|
+ 'platlib': '$platbase/lib64/python$py_version_short/site-packages',
|
|
'headers': '$base/include/python$py_version_short/$dist_name',
|
|
'scripts': '$base/bin',
|
|
'data' : '$base',
|
|
},
|
|
'unix_home': {
|
|
'purelib': '$base/lib/python',
|
|
- 'platlib': '$base/lib/python',
|
|
+ 'platlib': '$base/lib64/python',
|
|
'headers': '$base/include/python/$dist_name',
|
|
'scripts': '$base/bin',
|
|
'data' : '$base',
|
|
diff -up Python-2.7.1/Lib/distutils/sysconfig.py.lib64 Python-2.7.1/Lib/distutils/sysconfig.py
|
|
--- Python-2.7.1/Lib/distutils/sysconfig.py.lib64 2010-11-06 10:16:30.000000000 -0400
|
|
+++ Python-2.7.1/Lib/distutils/sysconfig.py 2010-12-23 15:51:19.423063652 -0500
|
|
@@ -114,8 +114,12 @@ def get_python_lib(plat_specific=0, stan
|
|
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
|
|
|
if os.name == "posix":
|
|
+ if plat_specific or standard_lib:
|
|
+ lib = "lib64"
|
|
+ else:
|
|
+ lib = "lib"
|
|
libpython = os.path.join(prefix,
|
|
- "lib", "python" + get_python_version())
|
|
+ lib, "python" + get_python_version())
|
|
if standard_lib:
|
|
return libpython
|
|
else:
|
|
diff -up Python-2.7.1/Lib/site.py.lib64 Python-2.7.1/Lib/site.py
|
|
--- Python-2.7.1/Lib/site.py.lib64 2010-10-12 18:53:51.000000000 -0400
|
|
+++ Python-2.7.1/Lib/site.py 2010-12-23 15:51:19.424063606 -0500
|
|
@@ -290,12 +290,16 @@ def getsitepackages():
|
|
if sys.platform in ('os2emx', 'riscos'):
|
|
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
|
|
elif os.sep == '/':
|
|
+ sitepackages.append(os.path.join(prefix, "lib64",
|
|
+ "python" + sys.version[:3],
|
|
+ "site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib",
|
|
"python" + sys.version[:3],
|
|
"site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib", "site-python"))
|
|
else:
|
|
sitepackages.append(prefix)
|
|
+ sitepackages.append(os.path.join(prefix, "lib64", "site-packages"))
|
|
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
|
if sys.platform == "darwin":
|
|
# for framework builds *only* we add the standard Apple
|
|
diff -up Python-2.7.1/Lib/test/test_site.py.lib64 Python-2.7.1/Lib/test/test_site.py
|
|
--- Python-2.7.1/Lib/test/test_site.py.lib64 2010-11-21 08:34:58.000000000 -0500
|
|
+++ Python-2.7.1/Lib/test/test_site.py 2010-12-23 15:55:19.782935931 -0500
|
|
@@ -169,17 +169,20 @@ class HelperFunctionsTests(unittest.Test
|
|
wanted = os.path.join('xoxo', 'Lib', 'site-packages')
|
|
self.assertEqual(dirs[0], wanted)
|
|
elif os.sep == '/':
|
|
- self.assertEqual(len(dirs), 2)
|
|
+ self.assertEquals(len(dirs), 3)
|
|
+ wanted = os.path.join('xoxo', 'lib64', 'python' + sys.version[:3],
|
|
+ 'site-packages')
|
|
+ self.assertEquals(dirs[0], wanted)
|
|
wanted = os.path.join('xoxo', 'lib', 'python' + sys.version[:3],
|
|
'site-packages')
|
|
- self.assertEqual(dirs[0], wanted)
|
|
+ self.assertEquals(dirs[1], wanted)
|
|
wanted = os.path.join('xoxo', 'lib', 'site-python')
|
|
- self.assertEqual(dirs[1], wanted)
|
|
+ self.assertEquals(dirs[2], wanted)
|
|
else:
|
|
- self.assertEqual(len(dirs), 2)
|
|
- self.assertEqual(dirs[0], 'xoxo')
|
|
- wanted = os.path.join('xoxo', 'lib', 'site-packages')
|
|
- self.assertEqual(dirs[1], wanted)
|
|
+ self.assertEquals(len(dirs), 2)
|
|
+ self.assertEquals(dirs[0], 'xoxo')
|
|
+ wanted = os.path.join('xoxo', 'lib64', 'site-packages')
|
|
+ self.assertEquals(dirs[1], wanted)
|
|
|
|
# let's try the specific Apple location
|
|
if (sys.platform == "darwin" and
|
|
diff -up Python-2.7.1/Makefile.pre.in.lib64 Python-2.7.1/Makefile.pre.in
|
|
--- Python-2.7.1/Makefile.pre.in.lib64 2010-12-23 15:51:19.407063264 -0500
|
|
+++ Python-2.7.1/Makefile.pre.in 2010-12-23 15:51:19.426063917 -0500
|
|
@@ -94,7 +94,7 @@ LIBDIR= @libdir@
|
|
MANDIR= @mandir@
|
|
INCLUDEDIR= @includedir@
|
|
CONFINCLUDEDIR= $(exec_prefix)/include
|
|
-SCRIPTDIR= $(prefix)/lib
|
|
+SCRIPTDIR= $(prefix)/lib64
|
|
|
|
# Detailed destination directories
|
|
BINLIBDEST= $(LIBDIR)/python$(VERSION)
|
|
diff -up Python-2.7.1/Modules/getpath.c.lib64 Python-2.7.1/Modules/getpath.c
|
|
--- Python-2.7.1/Modules/getpath.c.lib64 2010-10-07 19:37:08.000000000 -0400
|
|
+++ Python-2.7.1/Modules/getpath.c 2010-12-23 15:51:19.427063291 -0500
|
|
@@ -117,8 +117,8 @@
|
|
#endif
|
|
|
|
#ifndef PYTHONPATH
|
|
-#define PYTHONPATH PREFIX "/lib/python" VERSION ":" \
|
|
- EXEC_PREFIX "/lib/python" VERSION "/lib-dynload"
|
|
+#define PYTHONPATH PREFIX "/lib64/python" VERSION ":" \
|
|
+ EXEC_PREFIX "/lib64/python" VERSION "/lib-dynload"
|
|
#endif
|
|
|
|
#ifndef LANDMARK
|
|
@@ -129,7 +129,7 @@ static char prefix[MAXPATHLEN+1];
|
|
static char exec_prefix[MAXPATHLEN+1];
|
|
static char progpath[MAXPATHLEN+1];
|
|
static char *module_search_path = NULL;
|
|
-static char lib_python[] = "lib/python" VERSION;
|
|
+static char lib_python[] = "lib64/python" VERSION;
|
|
|
|
static void
|
|
reduce(char *dir)
|
|
@@ -528,7 +528,7 @@ calculate_path(void)
|
|
}
|
|
else
|
|
strncpy(zip_path, PREFIX, MAXPATHLEN);
|
|
- joinpath(zip_path, "lib/python00.zip");
|
|
+ joinpath(zip_path, "lib64/python00.zip");
|
|
bufsz = strlen(zip_path); /* Replace "00" with version */
|
|
zip_path[bufsz - 6] = VERSION[0];
|
|
zip_path[bufsz - 5] = VERSION[2];
|
|
@@ -538,7 +538,7 @@ calculate_path(void)
|
|
fprintf(stderr,
|
|
"Could not find platform dependent libraries <exec_prefix>\n");
|
|
strncpy(exec_prefix, EXEC_PREFIX, MAXPATHLEN);
|
|
- joinpath(exec_prefix, "lib/lib-dynload");
|
|
+ joinpath(exec_prefix, "lib64/lib-dynload");
|
|
}
|
|
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
|
|
|
diff -up Python-2.7.1/Modules/Setup.dist.lib64 Python-2.7.1/Modules/Setup.dist
|
|
--- Python-2.7.1/Modules/Setup.dist.lib64 2010-12-23 15:51:19.400104130 -0500
|
|
+++ Python-2.7.1/Modules/Setup.dist 2010-12-23 15:51:19.427063291 -0500
|
|
@@ -413,7 +413,7 @@ gdbm gdbmmodule.c -lgdbm
|
|
# and the subdirectory of PORT where you built it.
|
|
DBLIBVER=4.7
|
|
DBINC=/usr/include/db4
|
|
-DBLIB=/usr/lib
|
|
+DBLIB=/usr/lib64
|
|
_bsddb _bsddb.c -I$(DBINC) -L$(DBLIB) -ldb-$(DBLIBVER)
|
|
|
|
# Historical Berkeley DB 1.85
|
|
@@ -459,7 +459,7 @@ cPickle cPickle.c
|
|
# Andrew Kuchling's zlib module.
|
|
# This require zlib 1.1.3 (or later).
|
|
# See http://www.gzip.org/zlib/
|
|
-zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz
|
|
+zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib64 -lz
|
|
|
|
# Interface to the Expat XML parser
|
|
#
|
|
diff -up Python-2.7.1/setup.py.lib64 Python-2.7.1/setup.py
|
|
--- Python-2.7.1/setup.py.lib64 2010-10-31 12:40:21.000000000 -0400
|
|
+++ Python-2.7.1/setup.py 2010-12-23 15:51:19.428064129 -0500
|
|
@@ -347,7 +347,7 @@ class PyBuildExt(build_ext):
|
|
|
|
def detect_modules(self):
|
|
# Ensure that /usr/local is always used
|
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
|
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
|
|
|
# Add paths specified in the environment variables LDFLAGS and
|
|
@@ -654,11 +654,11 @@ class PyBuildExt(build_ext):
|
|
elif curses_library:
|
|
readline_libs.append(curses_library)
|
|
elif self.compiler.find_library_file(lib_dirs +
|
|
- ['/usr/lib/termcap'],
|
|
+ ['/usr/lib64/termcap'],
|
|
'termcap'):
|
|
readline_libs.append('termcap')
|
|
exts.append( Extension('readline', ['readline.c'],
|
|
- library_dirs=['/usr/lib/termcap'],
|
|
+ library_dirs=['/usr/lib64/termcap'],
|
|
extra_link_args=readline_extra_link_args,
|
|
libraries=readline_libs) )
|
|
else:
|
|
@@ -692,8 +692,8 @@ class PyBuildExt(build_ext):
|
|
if krb5_h:
|
|
ssl_incs += krb5_h
|
|
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
|
- ['/usr/local/ssl/lib',
|
|
- '/usr/contrib/ssl/lib/'
|
|
+ ['/usr/local/ssl/lib64',
|
|
+ '/usr/contrib/ssl/lib64/'
|
|
] )
|
|
|
|
if (ssl_incs is not None and
|