Update to 2.7.7
Refreshed patches: #16, #112, #138, #147, #157, #166, #173, #5000 Dropped patches: #190, #192, #194
This commit is contained in:
parent
81b61ec969
commit
ebcba88f1c
@ -65,4 +65,4 @@ diff -up Python-2.7.2/Lib/distutils/tests/test_build_ext.py.mark-tests-that-fail
|
||||
+ wanted = os.path.join(cmd.build_lib, 'UpdateManager', 'fdsend' + debug_ext + ext)
|
||||
self.assertEqual(ext_path, wanted)
|
||||
|
||||
def test_build_ext_path_cross_platform(self):
|
||||
@unittest.skipUnless(sys.platform == 'win32', 'these tests require Windows')
|
||||
|
@ -163,9 +163,9 @@ diff -up Python-2.7.2/Lib/test/test_sys.py.add-debug-malloc-stats Python-2.7.2/L
|
||||
+ sys._debugmallocstats(42)
|
||||
+
|
||||
+
|
||||
@test.test_support.cpython_only
|
||||
class SizeofTest(unittest.TestCase):
|
||||
|
||||
def setUp(self):
|
||||
|
||||
diff -up Python-2.7.2/Objects/classobject.c.add-debug-malloc-stats Python-2.7.2/Objects/classobject.c
|
||||
--- Python-2.7.2/Objects/classobject.c.add-debug-malloc-stats 2011-06-11 11:46:27.000000000 -0400
|
||||
+++ Python-2.7.2/Objects/classobject.c 2011-09-16 19:03:25.110821625 -0400
|
||||
|
@ -2,48 +2,48 @@ diff -up Python-2.7.3/Lib/test/test_os.py.uid-gid-overflows Python-2.7.3/Lib/tes
|
||||
--- Python-2.7.3/Lib/test/test_os.py.uid-gid-overflows 2012-04-09 19:07:32.000000000 -0400
|
||||
+++ Python-2.7.3/Lib/test/test_os.py 2012-06-26 14:51:36.000817929 -0400
|
||||
@@ -677,30 +677,36 @@ if sys.platform != 'win32':
|
||||
def test_setuid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setuid, 0)
|
||||
+ self.assertRaises(TypeError, os.setuid, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setuid, 1<<32)
|
||||
def test_setuid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setuid, 0)
|
||||
+ self.assertRaises(TypeError, os.setuid, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setuid, 1<<32)
|
||||
|
||||
if hasattr(os, 'setgid'):
|
||||
def test_setgid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setgid, 0)
|
||||
+ self.assertRaises(TypeError, os.setgid, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setgid, 1<<32)
|
||||
@unittest.skipUnless(hasattr(os, 'setgid'), 'test needs os.setgid()')
|
||||
def test_setgid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setgid, 0)
|
||||
+ self.assertRaises(TypeError, os.setgid, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setgid, 1<<32)
|
||||
|
||||
if hasattr(os, 'seteuid'):
|
||||
def test_seteuid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.seteuid, 0)
|
||||
+ self.assertRaises(TypeError, os.seteuid, 'not an int')
|
||||
self.assertRaises(OverflowError, os.seteuid, 1<<32)
|
||||
@unittest.skipUnless(hasattr(os, 'seteuid'), 'test needs os.seteuid()')
|
||||
def test_seteuid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.seteuid, 0)
|
||||
+ self.assertRaises(TypeError, os.seteuid, 'not an int')
|
||||
self.assertRaises(OverflowError, os.seteuid, 1<<32)
|
||||
|
||||
if hasattr(os, 'setegid'):
|
||||
def test_setegid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setegid, 0)
|
||||
+ self.assertRaises(TypeError, os.setegid, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setegid, 1<<32)
|
||||
@unittest.skipUnless(hasattr(os, 'setegid'), 'test needs os.setegid()')
|
||||
def test_setegid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setegid, 0)
|
||||
+ self.assertRaises(TypeError, os.setegid, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setegid, 1<<32)
|
||||
|
||||
if hasattr(os, 'setreuid'):
|
||||
def test_setreuid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setreuid, 0, 0)
|
||||
+ self.assertRaises(TypeError, os.setreuid, 'not an int', 0)
|
||||
+ self.assertRaises(TypeError, os.setreuid, 0, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setreuid, 1<<32, 0)
|
||||
self.assertRaises(OverflowError, os.setreuid, 0, 1<<32)
|
||||
@unittest.skipUnless(hasattr(os, 'setreuid'), 'test needs os.setreuid()')
|
||||
def test_setreuid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setreuid, 0, 0)
|
||||
+ self.assertRaises(TypeError, os.setreuid, 'not an int', 0)
|
||||
+ self.assertRaises(TypeError, os.setreuid, 0, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setreuid, 1<<32, 0)
|
||||
self.assertRaises(OverflowError, os.setreuid, 0, 1<<32)
|
||||
|
||||
@@ -715,6 +721,8 @@ if sys.platform != 'win32':
|
||||
def test_setregid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setregid, 0, 0)
|
||||
+ self.assertRaises(TypeError, os.setregid, 'not an int', 0)
|
||||
+ self.assertRaises(TypeError, os.setregid, 0, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setregid, 1<<32, 0)
|
||||
self.assertRaises(OverflowError, os.setregid, 0, 1<<32)
|
||||
def test_setregid(self):
|
||||
if os.getuid() != 0:
|
||||
self.assertRaises(os.error, os.setregid, 0, 0)
|
||||
+ self.assertRaises(TypeError, os.setregid, 'not an int', 0)
|
||||
+ self.assertRaises(TypeError, os.setregid, 0, 'not an int')
|
||||
self.assertRaises(OverflowError, os.setregid, 1<<32, 0)
|
||||
self.assertRaises(OverflowError, os.setregid, 0, 1<<32)
|
||||
|
||||
|
@ -111,14 +111,14 @@ diff -up Python-2.7.3/Tools/gdb/libpython.py.fix-fake-repr-in-gdb-hooks Python-2
|
||||
sys.stdout.write('#%i (unable to read python frame information)\n' % self.get_index())
|
||||
else:
|
||||
@@ -1303,7 +1309,11 @@ class PyList(gdb.Command):
|
||||
print 'Unable to read information on python frame'
|
||||
print('Unable to read information on python frame')
|
||||
return
|
||||
|
||||
- filename = pyop.filename()
|
||||
+ try:
|
||||
+ filename = pyop.filename()
|
||||
+ except CantReadFilename:
|
||||
+ print "Unable to extract filename from python frame"
|
||||
+ print("Unable to extract filename from python frame")
|
||||
+ return
|
||||
lineno = pyop.current_line_num()
|
||||
|
||||
|
@ -8,6 +8,7 @@ diff -up Python-2.7.3/Lib/test/test_support.py.rhbz913732 Python-2.7.3/Lib/test/
|
||||
- if hasattr(socket, 'SO_REUSEPORT'):
|
||||
+ if hasattr(socket, 'SO_REUSEPORT') \
|
||||
+ and 'WITHIN_PYTHON_RPM_BUILD' not in os.environ: # rhbz#913732
|
||||
if sock.getsockopt(socket.SOL_SOCKET, socket.SO_REUSEPORT) == 1:
|
||||
raise TestFailed("tests should never set the SO_REUSEPORT " \
|
||||
"socket option on TCP/IP sockets!")
|
||||
try:
|
||||
if sock.getsockopt(socket.SOL_SOCKET, socket.SO_REUSEPORT) == 1:
|
||||
raise TestFailed("tests should never set the SO_REUSEPORT " \
|
||||
"socket option on TCP/IP sockets!")
|
||||
|
@ -43,15 +43,6 @@ diff -up ./configure.autotool-intermediates ./configure
|
||||
--with-wctype-functions use wctype.h functions
|
||||
--with-fpectl enable SIGFPE catching
|
||||
--with-libm=STRING math library
|
||||
@@ -5171,7 +5181,7 @@ esac
|
||||
$as_echo_n "checking LIBRARY... " >&6; }
|
||||
if test -z "$LIBRARY"
|
||||
then
|
||||
- LIBRARY='libpython$(VERSION).a'
|
||||
+ LIBRARY='libpython$(VERSION)$(DEBUG_EXT).a'
|
||||
fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $LIBRARY" >&5
|
||||
$as_echo "$LIBRARY" >&6; }
|
||||
@@ -5343,8 +5353,8 @@ $as_echo "#define Py_ENABLE_SHARED 1" >>
|
||||
INSTSONAME="$LDLIBRARY".$SOVERSION
|
||||
;;
|
||||
@ -60,7 +51,7 @@ diff -up ./configure.autotool-intermediates ./configure
|
||||
- BLDLIBRARY='-L. -lpython$(VERSION)'
|
||||
+ LDLIBRARY='libpython$(VERSION)$(DEBUG_EXT).so'
|
||||
+ BLDLIBRARY='-L. -lpython$(VERSION)$(DEBUG_EXT)'
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
||||
case $ac_sys_system in
|
||||
FreeBSD*)
|
||||
@@ -5367,7 +5377,7 @@ $as_echo "#define Py_ENABLE_SHARED 1" >>
|
||||
@ -69,7 +60,7 @@ diff -up ./configure.autotool-intermediates ./configure
|
||||
LDLIBRARY='libpython$(VERSION).so'
|
||||
- BLDLIBRARY='-rpath $(LIBDIR) -L. -lpython$(VERSION)'
|
||||
+ BLDLIBRARY='-L. -lpython$(VERSION)'
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
||||
;;
|
||||
atheos*)
|
||||
@@ -5894,6 +5904,14 @@ $as_echo "no" >&6; }
|
||||
|
@ -7,6 +7,6 @@ diff -up Python-2.6/configure.ac.rpath Python-2.6/configure.ac
|
||||
LDLIBRARY='libpython$(VERSION).so'
|
||||
- BLDLIBRARY='-rpath $(LIBDIR) -L. -lpython$(VERSION)'
|
||||
+ BLDLIBRARY='-L. -lpython$(VERSION)'
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
||||
;;
|
||||
atheos*)
|
||||
|
@ -272,7 +272,7 @@ diff -up Python-2.7.6/configure.ac.debug-build Python-2.7.6/configure.ac
|
||||
- BLDLIBRARY='-L. -lpython$(VERSION)'
|
||||
+ LDLIBRARY='libpython$(VERSION)$(DEBUG_EXT).so'
|
||||
+ BLDLIBRARY='-L. -lpython$(VERSION)$(DEBUG_EXT)'
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
||||
case $ac_sys_system in
|
||||
FreeBSD*)
|
||||
@@ -1028,6 +1028,14 @@ else AC_MSG_RESULT(no); Py_DEBUG='false'
|
||||
|
24
python.spec
24
python.spec
@ -105,8 +105,8 @@
|
||||
Summary: An interpreted, interactive, object-oriented programming language
|
||||
Name: %{python}
|
||||
# Remember to also rebase python-docs when changing this:
|
||||
Version: 2.7.6
|
||||
Release: 9%{?dist}
|
||||
Version: 2.7.7
|
||||
Release: 1%{?dist}
|
||||
License: Python
|
||||
Group: Development/Languages
|
||||
Requires: %{python}-libs%{?_isa} = %{version}-%{release}
|
||||
@ -846,7 +846,8 @@ Patch189: 00189-gdb-py-bt-dont-raise-exception-from-eval.patch
|
||||
# Importing get_python_version in bdist_rpm
|
||||
# http://bugs.python.org/issue18045
|
||||
# rhbz#1029082
|
||||
Patch190: 00190-get_python_version.patch
|
||||
# FIXED UPSTREAM
|
||||
#Patch190: 00190-get_python_version.patch
|
||||
|
||||
# 00191 #
|
||||
#
|
||||
@ -857,7 +858,8 @@ Patch191: 00191-disable-NOOP.patch
|
||||
#
|
||||
# Fixing buffer overflow (upstream patch)
|
||||
# rhbz#1062375
|
||||
Patch192: 00192-buffer-overflow.patch
|
||||
# FIXED UPSTREAM
|
||||
#Patch192: 00192-buffer-overflow.patch
|
||||
|
||||
# 00193 #
|
||||
#
|
||||
@ -872,7 +874,8 @@ Patch193: 00193-enable-loading-sqlite-extensions.patch
|
||||
# Fix tests with SQLite >= 3.8.4
|
||||
# http://bugs.python.org/issue20901
|
||||
# http://hg.python.org/cpython/raw-rev/1763e27a182d
|
||||
Patch194: 00194-fix-tests-with-sqlite-3.8.4.patch
|
||||
# FIXED UPSTREAM
|
||||
#Patch194: 00194-fix-tests-with-sqlite-3.8.4.patch
|
||||
|
||||
|
||||
# (New patches go here ^^^)
|
||||
@ -1226,11 +1229,11 @@ mv Modules/cryptmodule.c Modules/_cryptmodule.c
|
||||
%patch185 -p1
|
||||
%patch187 -p1
|
||||
%patch189 -p1
|
||||
%patch190 -p1
|
||||
# 00190: upstream as of Python 2.7.7
|
||||
%patch191 -p1
|
||||
%patch192 -p1
|
||||
# 00192: upstream as of Python 2.7.7
|
||||
%patch193 -p1
|
||||
%patch194 -p1
|
||||
# 00194: upstream as of Python 2.7.7
|
||||
|
||||
|
||||
# This shouldn't be necesarry, but is right now (2.2a3)
|
||||
@ -2065,6 +2068,11 @@ rm -fr %{buildroot}
|
||||
# ======================================================
|
||||
|
||||
%changelog
|
||||
* Wed Jun 04 2014 Matej Stuchlik <mstuchli@redhat.com> - 2.7.7-1
|
||||
- Update to 2.7.7
|
||||
- Refreshed patches: #16, #112, #138, #147, #157, #166, #173, #5000
|
||||
- Dropped patches: #190, #192, #194
|
||||
|
||||
* Tue Jun 03 2014 Dan Horák <dan[at]danny.cz> - 2.7.6-9
|
||||
- update the arch list where valgrind exists - %%power64 includes also
|
||||
ppc64le which is not supported yet
|
||||
|
Loading…
Reference in New Issue
Block a user