2.7.3-35: fix gcc 4.8 incompatibility (rhbz#927358)

* Mon Mar 25 2013 David Malcolm <dmalcolm@redhat.com> - 2.7.3-35
- fix gcc 4.8 incompatibility (rhbz#927358); regenerate autotool intermediates
This commit is contained in:
David Malcolm 2013-03-25 15:40:44 -04:00
parent 1b2a274a94
commit bc9fa6b868
3 changed files with 41 additions and 6 deletions

View File

@ -0,0 +1,12 @@
diff -up Python-2.7.3/configure.in.fix-configure-Wformat Python-2.7.3/configure.in
--- Python-2.7.3/configure.in.fix-configure-Wformat 2013-03-25 15:15:18.473888383 -0400
+++ Python-2.7.3/configure.in 2013-03-25 15:15:32.513887426 -0400
@@ -1200,7 +1200,7 @@ if test "$GCC" = "yes"
then
AC_MSG_CHECKING(whether gcc supports ParseTuple __format__)
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
+ CFLAGS="$CFLAGS -Werror -Wformat"
AC_COMPILE_IFELSE([
AC_LANG_PROGRAM([[void f(char*,...)__attribute((format(PyArg_ParseTuple, 1, 2)));]], [[]])
],[

View File

@ -1,6 +1,6 @@
diff -up ./configure.autotool-intermediates ./configure
--- ./configure.autotool-intermediates 2012-04-11 18:35:27.009518662 -0400
+++ ./configure 2012-04-11 18:35:27.852508123 -0400
--- ./configure.autotool-intermediates 2013-03-25 15:25:30.438846538 -0400
+++ ./configure 2013-03-25 15:25:32.496846397 -0400
@@ -1,7 +1,7 @@
#! /bin/sh
# From configure.in Revision.
@ -668,6 +668,15 @@ diff -up ./configure.autotool-intermediates ./configure
$as_echo_n "(cached) " >&6
else
ac_save_cc="$CC"
@@ -5731,7 +5757,7 @@ then
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether gcc supports ParseTuple __format__" >&5
$as_echo_n "checking whether gcc supports ParseTuple __format__... " >&6; }
save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror"
+ CFLAGS="$CFLAGS -Werror -Wformat"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
@@ -5770,7 +5796,7 @@ fi
# options before we can check whether -Kpthread improves anything.
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether pthreads are available without options" >&5
@ -1338,7 +1347,7 @@ diff -up ./configure.autotool-intermediates ./configure
$as_echo "#define WITH_THREAD 1" >>confdefs.h
posix_threads=yes
@@ -8651,7 +8677,7 @@ if test "x$ac_cv_func_pthread_detach" =
@@ -8651,7 +8677,7 @@ if test "x$ac_cv_func_pthread_detach" =
else
ac_fn_c_check_header_mongrel "$LINENO" "atheos/threads.h" "ac_cv_header_atheos_threads_h" "$ac_includes_default"
@ -2690,8 +2699,8 @@ diff -up ./configure.autotool-intermediates ./configure
fi
;;
diff -up ./pyconfig.h.in.autotool-intermediates ./pyconfig.h.in
--- ./pyconfig.h.in.autotool-intermediates 2012-04-11 18:35:27.002518749 -0400
+++ ./pyconfig.h.in 2012-04-11 18:35:28.133504610 -0400
--- ./pyconfig.h.in.autotool-intermediates 2013-03-25 15:25:30.435846538 -0400
+++ ./pyconfig.h.in 2013-03-25 15:25:33.030846360 -0400
@@ -18,6 +18,12 @@
/* Define this if you have BeOS threads. */
#undef BEOS_THREADS

View File

@ -106,7 +106,7 @@ Summary: An interpreted, interactive, object-oriented programming language
Name: %{python}
# Remember to also rebase python-docs when changing this:
Version: 2.7.3
Release: 34%{?dist}
Release: 35%{?dist}
License: Python
Group: Development/Languages
Requires: %{python}-libs%{?_isa} = %{version}-%{release}
@ -819,6 +819,16 @@ Patch173: 00173-workaround-ENOPROTOOPT-in-bind_port.patch
# e.g. cmpi-bindings under systemd (rhbz#817554):
Patch174: 00174-fix-for-usr-move.patch
# 00175 #
# Fix for configure.ac mistakenly detecting
# checking whether gcc supports ParseTuple __format__... yes
# when it doesn't, when compiling with gcc 4.8
#
# Sent upstream as http://bugs.python.org/issue17547
# (rhbz#927358)
Patch175: 00175-fix-configure-Wformat.patch
# (New patches go here ^^^)
#
# When adding new patches to "python" and "python3" in Fedora 17 onwards,
@ -1160,6 +1170,7 @@ mv Modules/cryptmodule.c Modules/_cryptmodule.c
%patch172 -p1
%patch173 -p1
%patch174 -p1 -b .fix-for-usr-move
%patch175 -p1 -b .fix-configure-Wformat
# This shouldn't be necesarry, but is right now (2.2a3)
@ -1992,6 +2003,9 @@ rm -fr %{buildroot}
# ======================================================
%changelog
* Mon Mar 25 2013 David Malcolm <dmalcolm@redhat.com> - 2.7.3-35
- fix gcc 4.8 incompatibility (rhbz#927358); regenerate autotool intermediates
* Wed Mar 6 2013 David Malcolm <dmalcolm@redhat.com> - 2.7.3-34
- restrict scope of workaround for cmpi-bindings issue to avoid breaking
in-tree running of test_sys and test_subprocess (rhbz#817554)