Update to 2.7.14
- Refactored patches: 55, 112, 153 - Upstreamed patches: 250, 269, 270
This commit is contained in:
parent
57e494a406
commit
9db4c321af
@ -87,9 +87,9 @@ diff -up Python-2.7rc1/Makefile.pre.in.systemtap Python-2.7rc1/Makefile.pre.in
|
|||||||
@@ -1251,7 +1264,7 @@ Python/thread.o: @THREADHEADERS@
|
@@ -1251,7 +1264,7 @@ Python/thread.o: @THREADHEADERS@
|
||||||
.PHONY: frameworkinstall frameworkinstallframework frameworkinstallstructure
|
.PHONY: frameworkinstall frameworkinstallframework frameworkinstallstructure
|
||||||
.PHONY: frameworkinstallmaclib frameworkinstallapps frameworkinstallunixtools
|
.PHONY: frameworkinstallmaclib frameworkinstallapps frameworkinstallunixtools
|
||||||
.PHONY: frameworkaltinstallunixtools recheck autoconf clean clobber distclean
|
.PHONY: frameworkaltinstallunixtools recheck clean clobber distclean
|
||||||
-.PHONY: smelly funny patchcheck touch altmaninstall commoninstall
|
-.PHONY: smelly funny patchcheck altmaninstall commoninstall
|
||||||
+.PHONY: smelly funny patchcheck touch altmaninstall commoninstall buildinclude
|
+.PHONY: smelly funny patchcheck altmaninstall commoninstall buildinclude
|
||||||
.PHONY: gdbhooks
|
.PHONY: gdbhooks
|
||||||
|
|
||||||
# IF YOU PUT ANYTHING HERE IT WILL GO AWAY
|
# IF YOU PUT ANYTHING HERE IT WILL GO AWAY
|
||||||
|
@ -118,8 +118,8 @@ index 997a2fc..467e782 100644
|
|||||||
+PYTHON= python$(DEBUG_SUFFIX)$(EXE)
|
+PYTHON= python$(DEBUG_SUFFIX)$(EXE)
|
||||||
+BUILDPYTHON= python$(DEBUG_SUFFIX)$(BUILDEXE)
|
+BUILDPYTHON= python$(DEBUG_SUFFIX)$(BUILDEXE)
|
||||||
|
|
||||||
|
PYTHON_FOR_REGEN=@PYTHON_FOR_REGEN@
|
||||||
PYTHON_FOR_BUILD=@PYTHON_FOR_BUILD@
|
PYTHON_FOR_BUILD=@PYTHON_FOR_BUILD@
|
||||||
_PYTHON_HOST_PLATFORM=@_PYTHON_HOST_PLATFORM@
|
|
||||||
@@ -547,7 +553,7 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
@@ -547,7 +553,7 @@ sharedmods: $(BUILDPYTHON) pybuilddir.txt Modules/_math.o
|
||||||
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
|
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
|
||||||
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
|
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
|
||||||
@ -194,8 +194,8 @@ index 997a2fc..467e782 100644
|
|||||||
# pkgconfig directory
|
# pkgconfig directory
|
||||||
LIBPC= $(LIBDIR)/pkgconfig
|
LIBPC= $(LIBDIR)/pkgconfig
|
||||||
|
|
||||||
-libainstall: all python-config
|
-libainstall: @DEF_MAKE_RULE@ python-config
|
||||||
+libainstall: all python$(DEBUG_SUFFIX)-config
|
+libainstall: @DEF_MAKE_RULE@ python$(DEBUG_SUFFIX)-config
|
||||||
@for i in $(LIBDIR) $(LIBP) $(LIBPL) $(LIBPC); \
|
@for i in $(LIBDIR) $(LIBP) $(LIBPL) $(LIBPC); \
|
||||||
do \
|
do \
|
||||||
if test ! -d $(DESTDIR)$$i; then \
|
if test ! -d $(DESTDIR)$$i; then \
|
||||||
|
@ -1,13 +1,13 @@
|
|||||||
--- Lib/test/test_gdb.py.old 2012-04-11 21:04:01.367073855 -0400
|
--- Lib/test/test_gdb.py.old 2012-04-11 21:04:01.367073855 -0400
|
||||||
+++ Lib/test/test_gdb.py 2012-04-12 08:52:58.320288761 -0400
|
+++ Lib/test/test_gdb.py 2012-04-12 08:52:58.320288761 -0400
|
||||||
@@ -144,6 +153,10 @@
|
@@ -211,6 +211,10 @@
|
||||||
'Missing separate debuginfo for ',
|
# ignore all warnings
|
||||||
'Try: zypper install -C ',
|
'warning: ',
|
||||||
)
|
)
|
||||||
+ ignore_patterns += ('warning: Unable to open',
|
+ ignore_patterns += ('warning: Unable to open',
|
||||||
+ 'Missing separate debuginfo for',
|
+ 'Missing separate debuginfo for',
|
||||||
+ 'Try: yum --disablerepo=',
|
+ 'Try: yum --disablerepo=',
|
||||||
+ 'Undefined set print command')
|
+ 'Undefined set print command')
|
||||||
for line in errlines:
|
for line in errlines:
|
||||||
if not line.startswith(ignore_patterns):
|
if not line:
|
||||||
unexpected_errlines.append(line)
|
continue
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
diff --git a/Python/random.c b/Python/random.c
|
|
||||||
index 2f83b5d..4cae217 100644
|
|
||||||
--- a/Python/random.c
|
|
||||||
+++ b/Python/random.c
|
|
||||||
@@ -97,8 +97,15 @@ win32_urandom(unsigned char *buffer, Py_ssize_t size, int raise)
|
|
||||||
}
|
|
||||||
|
|
||||||
/* Issue #25003: Don't use getentropy() on Solaris (available since
|
|
||||||
- * Solaris 11.3), it is blocking whereas os.urandom() should not block. */
|
|
||||||
-#elif defined(HAVE_GETENTROPY) && !defined(sun)
|
|
||||||
+ Solaris 11.3), it is blocking whereas os.urandom() should not block.
|
|
||||||
+
|
|
||||||
+ Issue #29188: Don't use getentropy() on Linux since the glibc 2.24
|
|
||||||
+ implements it with the getrandom() syscall which can fail with ENOSYS,
|
|
||||||
+ and this error is not supported in py_getentropy() and getrandom() is called
|
|
||||||
+ with flags=0 which blocks until system urandom is initialized, which is not
|
|
||||||
+ the desired behaviour to seed the Python hash secret nor for os.urandom():
|
|
||||||
+ see the PEP 524 which was only implemented in Python 3.6. */
|
|
||||||
+#elif defined(HAVE_GETENTROPY) && !defined(sun) && !defined(linux)
|
|
||||||
#define PY_GETENTROPY 1
|
|
||||||
|
|
||||||
/* Fill buffer with size pseudo-random bytes generated by getentropy().
|
|
@ -1,63 +0,0 @@
|
|||||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
||||||
index 9e4be0a..a58b59c 100644
|
|
||||||
--- a/Makefile.pre.in
|
|
||||||
+++ b/Makefile.pre.in
|
|
||||||
@@ -863,12 +863,12 @@ $(LIBRARY_OBJS) $(MODOBJS) Modules/python.o: $(PYTHON_HEADERS)
|
|
||||||
TESTOPTS= -l $(EXTRATESTOPTS)
|
|
||||||
TESTPROG= $(srcdir)/Lib/test/regrtest.py
|
|
||||||
TESTPYTHON= $(RUNSHARED) ./$(BUILDPYTHON) -Wd -3 -E -tt $(TESTPYTHONOPTS)
|
|
||||||
-test: all platform
|
|
||||||
+test: @DEF_MAKE_RULE@ platform
|
|
||||||
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
|
||||||
-$(TESTPYTHON) $(TESTPROG) $(TESTOPTS)
|
|
||||||
$(TESTPYTHON) $(TESTPROG) $(TESTOPTS)
|
|
||||||
|
|
||||||
-testall: all platform
|
|
||||||
+testall: @DEF_MAKE_RULE@ platform
|
|
||||||
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
|
||||||
$(TESTPYTHON) $(srcdir)/Lib/compileall.py
|
|
||||||
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
|
||||||
@@ -877,7 +877,7 @@ testall: all platform
|
|
||||||
|
|
||||||
# Run the unitests for both architectures in a Universal build on OSX
|
|
||||||
# Must be run on an Intel box.
|
|
||||||
-testuniversal: all platform
|
|
||||||
+testuniversal: @DEF_MAKE_RULE@ platform
|
|
||||||
if [ `arch` != 'i386' ];then \
|
|
||||||
echo "This can only be used on OSX/i386" ;\
|
|
||||||
exit 1 ;\
|
|
||||||
@@ -900,14 +900,14 @@ QUICKTESTOPTS= $(TESTOPTS) -x test_subprocess test_io test_lib2to3 \
|
|
||||||
test_multibytecodec test_urllib2_localnet test_itertools \
|
|
||||||
test_multiprocessing test_mailbox test_socket test_poll \
|
|
||||||
test_select test_zipfile
|
|
||||||
-quicktest: all platform
|
|
||||||
+quicktest: @DEF_MAKE_RULE@ platform
|
|
||||||
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
|
||||||
-$(TESTPYTHON) $(TESTPROG) $(QUICKTESTOPTS)
|
|
||||||
$(TESTPYTHON) $(TESTPROG) $(QUICKTESTOPTS)
|
|
||||||
|
|
||||||
MEMTESTOPTS= $(QUICKTESTOPTS) -x test_dl test___all__ test_fork1 \
|
|
||||||
test_longexp
|
|
||||||
-memtest: all platform
|
|
||||||
+memtest: @DEF_MAKE_RULE@ platform
|
|
||||||
-rm -f $(srcdir)/Lib/test/*.py[co]
|
|
||||||
-$(TESTPYTHON) $(TESTPROG) $(MEMTESTOPTS)
|
|
||||||
$(TESTPYTHON) $(TESTPROG) $(MEMTESTOPTS)
|
|
||||||
@@ -1198,7 +1198,7 @@ LIBPL= $(LIBP)/config$(DEBUG_SUFFIX)
|
|
||||||
# pkgconfig directory
|
|
||||||
LIBPC= $(LIBDIR)/pkgconfig
|
|
||||||
|
|
||||||
-libainstall: all python$(DEBUG_SUFFIX)-config
|
|
||||||
+libainstall: @DEF_MAKE_RULE@ python$(DEBUG_SUFFIX)-config
|
|
||||||
@for i in $(LIBDIR) $(LIBP) $(LIBPL) $(LIBPC); \
|
|
||||||
do \
|
|
||||||
if test ! -d $(DESTDIR)$$i; then \
|
|
||||||
@@ -1425,7 +1425,7 @@ distclean: clobber
|
|
||||||
-exec rm -f {} ';'
|
|
||||||
|
|
||||||
# Check for smelly exported symbols (not starting with Py/_Py)
|
|
||||||
-smelly: all
|
|
||||||
+smelly: @DEF_MAKE_RULE@
|
|
||||||
nm -p $(LIBRARY) | \
|
|
||||||
sed -n "/ [TDB] /s/.* //p" | grep -v "^_*Py" | sort -u; \
|
|
||||||
|
|
@ -1,16 +0,0 @@
|
|||||||
diff --git a/Lib/test/test_ssl.py b/Lib/test/test_ssl.py
|
|
||||||
index d203cdd..c128dae 100644
|
|
||||||
--- a/Lib/test/test_ssl.py
|
|
||||||
+++ b/Lib/test/test_ssl.py
|
|
||||||
@@ -3256,8 +3256,9 @@ if _have_threads:
|
|
||||||
except ssl.SSLError as e:
|
|
||||||
stats = e
|
|
||||||
|
|
||||||
- if expected is None and IS_OPENSSL_1_1:
|
|
||||||
- # OpenSSL 1.1.0 raises handshake error
|
|
||||||
+ if (expected is None and IS_OPENSSL_1_1
|
|
||||||
+ and ssl.OPENSSL_VERSION_INFO < (1, 1, 0, 6)):
|
|
||||||
+ # OpenSSL 1.1.0 to 1.1.0e raises handshake error
|
|
||||||
self.assertIsInstance(stats, ssl.SSLError)
|
|
||||||
else:
|
|
||||||
msg = "failed trying %s (s) and %s (c).\n" \
|
|
30
python2.spec
30
python2.spec
@ -111,8 +111,8 @@
|
|||||||
Summary: An interpreted, interactive, object-oriented programming language
|
Summary: An interpreted, interactive, object-oriented programming language
|
||||||
Name: %{python}
|
Name: %{python}
|
||||||
# Remember to also rebase python-docs when changing this:
|
# Remember to also rebase python-docs when changing this:
|
||||||
Version: 2.7.13
|
Version: 2.7.14
|
||||||
Release: 18%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Requires: %{python}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{python}-libs%{?_isa} = %{version}-%{release}
|
||||||
@ -746,25 +746,6 @@ Patch193: 00193-enable-loading-sqlite-extensions.patch
|
|||||||
# 00198 #
|
# 00198 #
|
||||||
Patch198: 00198-add-rewheel-module.patch
|
Patch198: 00198-add-rewheel-module.patch
|
||||||
|
|
||||||
# 00250 #
|
|
||||||
# After glibc-2.24.90, Python failed to start on EL7 kernel
|
|
||||||
# rhbz#1410175: https://bugzilla.redhat.com/show_bug.cgi?id=1410175
|
|
||||||
# http://bugs.python.org/issue29157
|
|
||||||
# Fixed upstream: https://hg.python.org/cpython/rev/13a39142c047
|
|
||||||
Patch250: 00250-getentropy.patch
|
|
||||||
|
|
||||||
# 00269 #
|
|
||||||
# Fix python's recompilation with common build commands when using
|
|
||||||
# profile guided optimizations.
|
|
||||||
# Fixed upstream: http://bugs.python.org/issue29243
|
|
||||||
Patch269: 00269-fix-multiple-compilations-issue-with-pgo-builds.patch
|
|
||||||
|
|
||||||
# 00270 #
|
|
||||||
# Fix test_alpn_protocols from test_ssl as openssl > 1.1.0f
|
|
||||||
# changed the behaviour of the ALPN hook.
|
|
||||||
# Fixed upstream: http://bugs.python.org/issue30714
|
|
||||||
Patch270: 00270-fix-ssl-alpn-hook-test.patch
|
|
||||||
|
|
||||||
# (New patches go here ^^^)
|
# (New patches go here ^^^)
|
||||||
#
|
#
|
||||||
# When adding new patches to "python2" and "python3" in Fedora, EL, etc.,
|
# When adding new patches to "python2" and "python3" in Fedora, EL, etc.,
|
||||||
@ -1076,10 +1057,6 @@ mv Modules/cryptmodule.c Modules/_cryptmodule.c
|
|||||||
%patch198 -p1
|
%patch198 -p1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch250 -p1
|
|
||||||
%patch269 -p1
|
|
||||||
%patch270 -p1
|
|
||||||
|
|
||||||
%if 0%{?_module_build}
|
%if 0%{?_module_build}
|
||||||
%patch4000 -p1
|
%patch4000 -p1
|
||||||
%endif
|
%endif
|
||||||
@ -1958,6 +1935,9 @@ rm -fr %{buildroot}
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 09 2017 Iryna Shcherbina <ishcherb@redhat.com> - 2.7.14-1
|
||||||
|
- Update to version 2.7.14
|
||||||
|
|
||||||
* Thu Aug 31 2017 Tomas Orsava <torsava@redhat.com> - 2.7.13-18
|
* Thu Aug 31 2017 Tomas Orsava <torsava@redhat.com> - 2.7.13-18
|
||||||
- Switch some macros into bconds to facilitate modularity
|
- Switch some macros into bconds to facilitate modularity
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (Python-2.7.13.tar.xz) = f37c9a28ce129d01e63c84d7db627a06402854578f62d17927334ea21ede318e04bbf66e890e3f47c85333e6b19f6e5581fb3f3e27efd24be27017d1b6529c4b
|
SHA512 (Python-2.7.14.tar.xz) = 78310b0be6388ffa15f29a80afb9ab3c03a572cb094e9da00cfe391afadb51696e41f592eb658d6a31a2f422fdac8a55214a382cbb8cfb43d4a127d5b35ea7f9
|
||||||
|
Loading…
x
Reference in New Issue
Block a user