Update to 2.7.11
This commit is contained in:
parent
3b6fac0339
commit
7af76a54f4
@ -97,14 +97,15 @@ diff -up Python-2.7.3/Tools/gdb/libpython.py.fix-fake-repr-in-gdb-hooks Python-2
|
|||||||
pyop_value.write_repr(out, visited)
|
pyop_value.write_repr(out, visited)
|
||||||
|
|
||||||
@@ -1252,8 +1255,11 @@ class Frame(object):
|
@@ -1252,8 +1255,11 @@ class Frame(object):
|
||||||
if pyop:
|
write_unicode(sys.stdout, '#%i %s\n' % (self.get_index(), line))
|
||||||
sys.stdout.write('#%i %s\n' % (self.get_index(), pyop.get_truncated_repr(MAX_OUTPUT_LEN)))
|
|
||||||
if not pyop.is_optimized_out():
|
if not pyop.is_optimized_out():
|
||||||
- line = pyop.current_line()
|
- line = pyop.current_line()
|
||||||
- sys.stdout.write(' %s\n' % line.strip())
|
- if line is not None:
|
||||||
|
- sys.stdout.write(' %s\n' % line.strip())
|
||||||
+ try:
|
+ try:
|
||||||
+ line = pyop.current_line()
|
+ line = pyop.current_line()
|
||||||
+ sys.stdout.write(' %s\n' % line.strip())
|
+ if line is not None:
|
||||||
|
+ sys.stdout.write(' %s\n' % line.strip())
|
||||||
+ except CantReadFilename:
|
+ except CantReadFilename:
|
||||||
+ sys.stdout.write(' %s\n' % '(unable to read filename)')
|
+ sys.stdout.write(' %s\n' % '(unable to read filename)')
|
||||||
else:
|
else:
|
||||||
|
@ -24,8 +24,8 @@ index cb49c4a..c9795a5 100644
|
|||||||
if not gotit:
|
if not gotit:
|
||||||
if __debug__:
|
if __debug__:
|
||||||
@@ -599,7 +602,7 @@ class _Event(_Verbose):
|
@@ -599,7 +602,7 @@ class _Event(_Verbose):
|
||||||
finally:
|
with self.__cond:
|
||||||
self.__cond.release()
|
self.__flag = False
|
||||||
|
|
||||||
- def wait(self, timeout=None):
|
- def wait(self, timeout=None):
|
||||||
+ def wait(self, timeout=None, balancing=True):
|
+ def wait(self, timeout=None, balancing=True):
|
||||||
@ -33,14 +33,14 @@ index cb49c4a..c9795a5 100644
|
|||||||
|
|
||||||
If the internal flag is true on entry, return immediately. Otherwise,
|
If the internal flag is true on entry, return immediately. Otherwise,
|
||||||
@@ -617,7 +620,7 @@ class _Event(_Verbose):
|
@@ -617,7 +620,7 @@ class _Event(_Verbose):
|
||||||
self.__cond.acquire()
|
"""
|
||||||
try:
|
with self.__cond:
|
||||||
if not self.__flag:
|
if not self.__flag:
|
||||||
- self.__cond.wait(timeout)
|
- self.__cond.wait(timeout)
|
||||||
+ self.__cond.wait(timeout, balancing)
|
+ self.__cond.wait(timeout, balancing)
|
||||||
return self.__flag
|
return self.__flag
|
||||||
finally:
|
|
||||||
self.__cond.release()
|
# Helper to generate new thread names
|
||||||
@@ -908,7 +911,7 @@ class Thread(_Verbose):
|
@@ -908,7 +911,7 @@ class Thread(_Verbose):
|
||||||
if 'dummy_threading' not in _sys.modules:
|
if 'dummy_threading' not in _sys.modules:
|
||||||
raise
|
raise
|
||||||
|
@ -6,6 +6,6 @@
|
|||||||
return '(frame information optimized out)'
|
return '(frame information optimized out)'
|
||||||
+ if self.filename() == '<string>':
|
+ if self.filename() == '<string>':
|
||||||
+ return '(in an eval block)'
|
+ return '(in an eval block)'
|
||||||
with open(self.filename(), 'r') as f:
|
filename = self.filename()
|
||||||
all_lines = f.readlines()
|
try:
|
||||||
# Convert from 1-based current_line_num to 0-based list offset:
|
f = open(filename, 'r')
|
||||||
|
@ -1,86 +1,3 @@
|
|||||||
diff -Nur Python-3.4.1/Lib/ensurepip/__init__.py Python-3.4.1-rewheel/Lib/ensurepip/__init__.py
|
|
||||||
--- Python-3.4.1/Lib/ensurepip/__init__.py 2014-08-21 10:49:30.792695824 +0200
|
|
||||||
+++ Python-3.4.1-rewheel/Lib/ensurepip/__init__.py 2014-08-21 10:10:41.958341726 +0200
|
|
||||||
@@ -7,6 +7,7 @@ import pkgutil
|
|
||||||
import shutil
|
|
||||||
import sys
|
|
||||||
import tempfile
|
|
||||||
+from ensurepip import rewheel
|
|
||||||
|
|
||||||
|
|
||||||
__all__ = ["version", "bootstrap"]
|
|
||||||
@@ -43,6 +44,8 @@
|
|
||||||
|
|
||||||
# Install the bundled software
|
|
||||||
import pip
|
|
||||||
+ if args[0] in ["install", "list", "wheel"]:
|
|
||||||
+ args.append('--pre')
|
|
||||||
pip.main(args)
|
|
||||||
|
|
||||||
|
|
||||||
@@ -93,21 +96,40 @@ def bootstrap(root=None, upgrade=False,
|
|
||||||
# omit pip and easy_install
|
|
||||||
os.environ["ENSUREPIP_OPTIONS"] = "install"
|
|
||||||
|
|
||||||
+ whls = []
|
|
||||||
+ rewheel_dir = None
|
|
||||||
+ # try to see if we have system-wide versions of _PROJECTS
|
|
||||||
+ dep_records = rewheel.find_system_records([p[0] for p in _PROJECTS])
|
|
||||||
+ # TODO: check if system-wide versions are the newest ones
|
|
||||||
+ # if --upgrade is used?
|
|
||||||
+ if all(dep_records):
|
|
||||||
+ # if we have all _PROJECTS installed system-wide, we'll recreate
|
|
||||||
+ # wheels from them and install those
|
|
||||||
+ rewheel_dir = tempfile.TemporaryDirectory()
|
|
||||||
+ for dr in dep_records:
|
|
||||||
+ new_whl = rewheel.rewheel_from_record(dr, rewheel_dir.name)
|
|
||||||
+ whls.append(os.path.join(rewheel_dir.name, new_whl))
|
|
||||||
+ else:
|
|
||||||
+ # if we don't have all the _PROJECTS installed system-wide,
|
|
||||||
+ # let's just fall back to bundled wheels
|
|
||||||
+ for project, version in _PROJECTS:
|
|
||||||
+ whl = os.path.join(
|
|
||||||
+ os.path.dirname(__file__),
|
|
||||||
+ "_bundled",
|
|
||||||
+ "{}-{}-py2.py3-none-any.whl".format(project, version)
|
|
||||||
+ )
|
|
||||||
+ whls.append(whl)
|
|
||||||
+
|
|
||||||
tmpdir = tempfile.mkdtemp()
|
|
||||||
try:
|
|
||||||
# Put our bundled wheels into a temporary directory and construct the
|
|
||||||
# additional paths that need added to sys.path
|
|
||||||
additional_paths = []
|
|
||||||
- for project, version in _PROJECTS:
|
|
||||||
- wheel_name = "{}-{}-py2.py3-none-any.whl".format(project, version)
|
|
||||||
- whl = pkgutil.get_data(
|
|
||||||
- "ensurepip",
|
|
||||||
- "_bundled/{}".format(wheel_name),
|
|
||||||
- )
|
|
||||||
- with open(os.path.join(tmpdir, wheel_name), "wb") as fp:
|
|
||||||
- fp.write(whl)
|
|
||||||
-
|
|
||||||
- additional_paths.append(os.path.join(tmpdir, wheel_name))
|
|
||||||
+ for whl in whls:
|
|
||||||
+ shutil.copy(whl, tmpdir)
|
|
||||||
+ additional_paths.append(os.path.join(tmpdir, os.path.basename(whl)))
|
|
||||||
+ if rewheel_dir:
|
|
||||||
+ rewheel_dir.cleanup()
|
|
||||||
|
|
||||||
# Construct the arguments to be passed to the pip command
|
|
||||||
args = ["install", "--no-index", "--find-links", tmpdir]
|
|
||||||
diff -Nur Python-3.4.1/Makefile.pre.in Python-3.4.1-rewheel/Makefile.pre.in
|
|
||||||
--- Python-3.4.1/Makefile.pre.in 2014-08-21 10:49:31.512695040 +0200
|
|
||||||
+++ Python-3.4.1-rewheel/Makefile.pre.in 2014-08-21 10:10:41.961341722 +0200
|
|
||||||
@@ -976,7 +976,7 @@ LIBSUBDIRS= lib-tk lib-tk/test lib-tk/te
|
|
||||||
test/tracedmodules \
|
|
||||||
encodings compiler hotshot \
|
|
||||||
email email/mime email/test email/test/data \
|
|
||||||
- ensurepip ensurepip/_bundled \
|
|
||||||
+ ensurepip ensurepip/_bundled ensurepip/rewheel\
|
|
||||||
json json/tests \
|
|
||||||
sqlite3 sqlite3/test \
|
|
||||||
logging bsddb bsddb/test csv importlib wsgiref \
|
|
||||||
diff -ru --new-file Python-2.7.9rc1-rewheel/Lib/ensurepip/rewheel/__init__.py Python-2.7.9rc1/Lib/ensurepip/rewheel/__init__.py
|
diff -ru --new-file Python-2.7.9rc1-rewheel/Lib/ensurepip/rewheel/__init__.py Python-2.7.9rc1/Lib/ensurepip/rewheel/__init__.py
|
||||||
--- Python-2.7.9rc1-rewheel/Lib/ensurepip/rewheel/__init__.py 1970-01-01 01:00:00.000000000 +0100
|
--- Python-2.7.9rc1-rewheel/Lib/ensurepip/rewheel/__init__.py 1970-01-01 01:00:00.000000000 +0100
|
||||||
+++ Python-2.7.9rc1/Lib/ensurepip/rewheel/__init__.py 2014-12-08 11:29:34.215237317 +0100
|
+++ Python-2.7.9rc1/Lib/ensurepip/rewheel/__init__.py 2014-12-08 11:29:34.215237317 +0100
|
||||||
@ -123,7 +40,19 @@ diff -ru --new-file Python-2.7.9rc1-rewheel/Lib/ensurepip/rewheel/__init__.py Py
|
|||||||
+ """
|
+ """
|
||||||
+ records = []
|
+ records = []
|
||||||
+ # get system site-packages dirs
|
+ # get system site-packages dirs
|
||||||
+ sys_sitepack = site.getsitepackages([sys.base_prefix, sys.base_exec_prefix])
|
+ if hasattr(sys, 'real_prefix'):
|
||||||
|
+ #we are in python2 virtualenv and sys.real_prefix is the original sys.prefix
|
||||||
|
+ _orig_prefixes = site.PREFIXES
|
||||||
|
+ setattr(site, 'PREFIXES', [sys.real_prefix]*2)
|
||||||
|
+ sys_sitepack = site.getsitepackages()
|
||||||
|
+ setattr(site, 'PREFIXES', _orig_prefixes)
|
||||||
|
+ elif hasattr(sys, 'base_prefix'): # python3 venv doesn't inject real_prefix to sys
|
||||||
|
+ # we are on python3 and base(_exec)_prefix is unchanged in venv
|
||||||
|
+ sys_sitepack = site.getsitepackages([sys.base_prefix, sys.base_exec_prefix])
|
||||||
|
+ else:
|
||||||
|
+ # we are in python2 without virtualenv
|
||||||
|
+ sys_sitepack = site.getsitepackages()
|
||||||
|
+
|
||||||
+ sys_sitepack = [sp for sp in sys_sitepack if os.path.exists(sp)]
|
+ sys_sitepack = [sp for sp in sys_sitepack if os.path.exists(sp)]
|
||||||
+ # try to find all projects in all system site-packages
|
+ # try to find all projects in all system site-packages
|
||||||
+ for project in projects:
|
+ for project in projects:
|
||||||
@ -154,7 +83,10 @@ diff -ru --new-file Python-2.7.9rc1-rewheel/Lib/ensurepip/rewheel/__init__.py Py
|
|||||||
+ new_wheel = zipfile.ZipFile(new_wheel_path, mode='w', compression=zipfile.ZIP_DEFLATED)
|
+ new_wheel = zipfile.ZipFile(new_wheel_path, mode='w', compression=zipfile.ZIP_DEFLATED)
|
||||||
+ # we need to write a new record with just the files that we will write,
|
+ # we need to write a new record with just the files that we will write,
|
||||||
+ # e.g. not binaries and *.pyc/*.pyo files
|
+ # e.g. not binaries and *.pyc/*.pyo files
|
||||||
+ new_record = io.StringIO()
|
+ if sys.version_info[0] < 3:
|
||||||
|
+ new_record = io.BytesIO()
|
||||||
|
+ else:
|
||||||
|
+ new_record = io.StringIO()
|
||||||
+ writer = csv.writer(new_record)
|
+ writer = csv.writer(new_record)
|
||||||
+
|
+
|
||||||
+ # handle files that we can write straight away
|
+ # handle files that we can write straight away
|
||||||
@ -175,11 +107,11 @@ diff -ru --new-file Python-2.7.9rc1-rewheel/Lib/ensurepip/rewheel/__init__.py Py
|
|||||||
+
|
+
|
||||||
+ wheel_info_path = os.path.join(os.path.dirname(record_path), 'WHEEL')
|
+ wheel_info_path = os.path.join(os.path.dirname(record_path), 'WHEEL')
|
||||||
+ with codecs.open(wheel_info_path, encoding='utf-8') as wheel_info_file:
|
+ with codecs.open(wheel_info_path, encoding='utf-8') as wheel_info_file:
|
||||||
+ wheel_info = email.parser.Parser().parsestr(wheel_info_file.read())
|
+ wheel_info = email.parser.Parser().parsestr(wheel_info_file.read().encode('utf-8'))
|
||||||
+
|
+
|
||||||
+ metadata_path = os.path.join(os.path.dirname(record_path), 'METADATA')
|
+ metadata_path = os.path.join(os.path.dirname(record_path), 'METADATA')
|
||||||
+ with codecs.open(metadata_path, encoding='utf-8') as metadata_file:
|
+ with codecs.open(metadata_path, encoding='utf-8') as metadata_file:
|
||||||
+ metadata = email.parser.Parser().parsestr(metadata_file.read())
|
+ metadata = email.parser.Parser().parsestr(metadata_file.read().encode('utf-8'))
|
||||||
+
|
+
|
||||||
+ # construct name parts according to wheel spec
|
+ # construct name parts according to wheel spec
|
||||||
+ distribution = metadata.get('Name')
|
+ distribution = metadata.get('Name')
|
||||||
@ -228,3 +160,86 @@ diff -ru --new-file Python-2.7.9rc1-rewheel/Lib/ensurepip/rewheel/__init__.py Py
|
|||||||
+ else:
|
+ else:
|
||||||
+ pass # bad RECORD or empty line
|
+ pass # bad RECORD or empty line
|
||||||
+ return to_write, to_omit
|
+ return to_write, to_omit
|
||||||
|
diff -Nur Python-2.7.9/Lib/ensurepip/__init__.py Python-2.7.9-rewheel/Lib/ensurepip/__init__.py
|
||||||
|
--- Python-2.7.9/Lib/ensurepip/__init__.py 2014-08-21 10:49:30.792695824 +0200
|
||||||
|
+++ Python-2.7.9-rewheel/Lib/ensurepip/__init__.py 2014-08-21 10:10:41.958341726 +0200
|
||||||
|
@@ -7,6 +7,7 @@ import pkgutil
|
||||||
|
import shutil
|
||||||
|
import sys
|
||||||
|
import tempfile
|
||||||
|
+from ensurepip import rewheel
|
||||||
|
|
||||||
|
|
||||||
|
__all__ = ["version", "bootstrap"]
|
||||||
|
@@ -43,6 +44,8 @@
|
||||||
|
|
||||||
|
# Install the bundled software
|
||||||
|
import pip
|
||||||
|
+ if args[0] in ["install", "list", "wheel"]:
|
||||||
|
+ args.append('--pre')
|
||||||
|
pip.main(args)
|
||||||
|
|
||||||
|
|
||||||
|
@@ -93,21 +96,40 @@ def bootstrap(root=None, upgrade=False,
|
||||||
|
# omit pip and easy_install
|
||||||
|
os.environ["ENSUREPIP_OPTIONS"] = "install"
|
||||||
|
|
||||||
|
+ whls = []
|
||||||
|
+ rewheel_dir = None
|
||||||
|
+ # try to see if we have system-wide versions of _PROJECTS
|
||||||
|
+ dep_records = rewheel.find_system_records([p[0] for p in _PROJECTS])
|
||||||
|
+ # TODO: check if system-wide versions are the newest ones
|
||||||
|
+ # if --upgrade is used?
|
||||||
|
+ if all(dep_records):
|
||||||
|
+ # if we have all _PROJECTS installed system-wide, we'll recreate
|
||||||
|
+ # wheels from them and install those
|
||||||
|
+ rewheel_dir = tempfile.mkdtemp()
|
||||||
|
+ for dr in dep_records:
|
||||||
|
+ new_whl = rewheel.rewheel_from_record(dr, rewheel_dir)
|
||||||
|
+ whls.append(os.path.join(rewheel_dir, new_whl))
|
||||||
|
+ else:
|
||||||
|
+ # if we don't have all the _PROJECTS installed system-wide,
|
||||||
|
+ # let's just fall back to bundled wheels
|
||||||
|
+ for project, version in _PROJECTS:
|
||||||
|
+ whl = os.path.join(
|
||||||
|
+ os.path.dirname(__file__),
|
||||||
|
+ "_bundled",
|
||||||
|
+ "{}-{}-py2.py3-none-any.whl".format(project, version)
|
||||||
|
+ )
|
||||||
|
+ whls.append(whl)
|
||||||
|
+
|
||||||
|
tmpdir = tempfile.mkdtemp()
|
||||||
|
try:
|
||||||
|
# Put our bundled wheels into a temporary directory and construct the
|
||||||
|
# additional paths that need added to sys.path
|
||||||
|
additional_paths = []
|
||||||
|
- for project, version in _PROJECTS:
|
||||||
|
- wheel_name = "{}-{}-py2.py3-none-any.whl".format(project, version)
|
||||||
|
- whl = pkgutil.get_data(
|
||||||
|
- "ensurepip",
|
||||||
|
- "_bundled/{}".format(wheel_name),
|
||||||
|
- )
|
||||||
|
- with open(os.path.join(tmpdir, wheel_name), "wb") as fp:
|
||||||
|
- fp.write(whl)
|
||||||
|
-
|
||||||
|
- additional_paths.append(os.path.join(tmpdir, wheel_name))
|
||||||
|
+ for whl in whls:
|
||||||
|
+ shutil.copy(whl, tmpdir)
|
||||||
|
+ additional_paths.append(os.path.join(tmpdir, os.path.basename(whl)))
|
||||||
|
+ if rewheel_dir:
|
||||||
|
+ shutil.rmtree(rewheel_dir)
|
||||||
|
|
||||||
|
# Construct the arguments to be passed to the pip command
|
||||||
|
args = ["install", "--no-index", "--find-links", tmpdir]
|
||||||
|
diff -Nur Python-2.7.9/Makefile.pre.in Python-2.7.9-rewheel/Makefile.pre.in
|
||||||
|
--- Python-2.7.9/Makefile.pre.in 2014-08-21 10:49:31.512695040 +0200
|
||||||
|
+++ Python-2.7.9-rewheel/Makefile.pre.in 2014-08-21 10:10:41.961341722 +0200
|
||||||
|
@@ -976,7 +976,7 @@ LIBSUBDIRS= lib-tk lib-tk/test lib-tk/te
|
||||||
|
test/tracedmodules \
|
||||||
|
encodings compiler hotshot \
|
||||||
|
email email/mime email/test email/test/data \
|
||||||
|
- ensurepip ensurepip/_bundled \
|
||||||
|
+ ensurepip ensurepip/_bundled ensurepip/rewheel\
|
||||||
|
json json/tests \
|
||||||
|
sqlite3 sqlite3/test \
|
||||||
|
logging bsddb bsddb/test csv importlib wsgiref \
|
||||||
|
@ -1,52 +0,0 @@
|
|||||||
diff -up Python-2.7.9/Lib/test/test_ssl.py.ssl Python-2.7.9/Lib/test/test_ssl.py
|
|
||||||
--- Python-2.7.9/Lib/test/test_ssl.py.ssl 2014-12-11 10:40:22.657795081 +0100
|
|
||||||
+++ Python-2.7.9/Lib/test/test_ssl.py 2014-12-11 11:25:11.925579957 +0100
|
|
||||||
@@ -713,10 +713,7 @@ class ContextTests(unittest.TestCase):
|
|
||||||
@skip_if_broken_ubuntu_ssl
|
|
||||||
def test_options(self):
|
|
||||||
ctx = ssl.SSLContext(ssl.PROTOCOL_TLSv1)
|
|
||||||
- # OP_ALL | OP_NO_SSLv2 is the default value
|
|
||||||
- self.assertEqual(ssl.OP_ALL | ssl.OP_NO_SSLv2,
|
|
||||||
- ctx.options)
|
|
||||||
- ctx.options |= ssl.OP_NO_SSLv3
|
|
||||||
+ # OP_ALL | OP_NO_SSLv2 | OP_NO_SSLv3 is the default value
|
|
||||||
self.assertEqual(ssl.OP_ALL | ssl.OP_NO_SSLv2 | ssl.OP_NO_SSLv3,
|
|
||||||
ctx.options)
|
|
||||||
if can_clear_options():
|
|
||||||
@@ -2220,24 +2217,20 @@ else:
|
|
||||||
" SSL2 client to SSL23 server test unexpectedly failed:\n %s\n"
|
|
||||||
% str(x))
|
|
||||||
if hasattr(ssl, 'PROTOCOL_SSLv3'):
|
|
||||||
- try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, 'SSLv3')
|
|
||||||
+ try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, False)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv23, True)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_TLSv1, 'TLSv1')
|
|
||||||
|
|
||||||
if hasattr(ssl, 'PROTOCOL_SSLv3'):
|
|
||||||
- try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, 'SSLv3', ssl.CERT_OPTIONAL)
|
|
||||||
+ try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, False, ssl.CERT_OPTIONAL)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv23, True, ssl.CERT_OPTIONAL)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_TLSv1, 'TLSv1', ssl.CERT_OPTIONAL)
|
|
||||||
|
|
||||||
if hasattr(ssl, 'PROTOCOL_SSLv3'):
|
|
||||||
- try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, 'SSLv3', ssl.CERT_REQUIRED)
|
|
||||||
+ try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, False, ssl.CERT_REQUIRED)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv23, True, ssl.CERT_REQUIRED)
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_TLSv1, 'TLSv1', ssl.CERT_REQUIRED)
|
|
||||||
|
|
||||||
- # Server with specific SSL options
|
|
||||||
- if hasattr(ssl, 'PROTOCOL_SSLv3'):
|
|
||||||
- try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv3, False,
|
|
||||||
- server_options=ssl.OP_NO_SSLv3)
|
|
||||||
# Will choose TLSv1
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv23, ssl.PROTOCOL_SSLv23, True,
|
|
||||||
server_options=ssl.OP_NO_SSLv2 | ssl.OP_NO_SSLv3)
|
|
||||||
@@ -2262,7 +2255,7 @@ else:
|
|
||||||
try_protocol_combo(ssl.PROTOCOL_SSLv3, ssl.PROTOCOL_TLSv1, False)
|
|
||||||
if no_sslv2_implies_sslv3_hello():
|
|
||||||
# No SSLv2 => client will use an SSLv3 hello on recent OpenSSLs
|
|
||||||
- try_protocol_combo(ssl.PROTOCOL_SSLv3, ssl.PROTOCOL_SSLv23, 'SSLv3',
|
|
||||||
+ try_protocol_combo(ssl.PROTOCOL_SSLv3, ssl.PROTOCOL_SSLv23, False,
|
|
||||||
client_options=ssl.OP_NO_SSLv2)
|
|
||||||
|
|
||||||
@skip_if_broken_ubuntu_ssl
|
|
11
00200-skip-thread-test.patch
Normal file
11
00200-skip-thread-test.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up Python-2.7.11/Lib/test/test_gdb.py.old Python-2.7.11/Lib/test/test_gdb.py
|
||||||
|
--- Python-2.7.11/Lib/test/test_gdb.py.old 2015-12-24 19:12:46.167487914 +0100
|
||||||
|
+++ Python-2.7.11/Lib/test/test_gdb.py 2015-12-24 19:13:48.833057910 +0100
|
||||||
|
@@ -801,6 +801,7 @@ Traceback \(most recent call first\):
|
||||||
|
foo\(1, 2, 3\)
|
||||||
|
''')
|
||||||
|
|
||||||
|
+ @unittest._skipInRpmBuild('this test fail within rpmbuild')
|
||||||
|
@unittest.skipUnless(thread,
|
||||||
|
"Python was compiled without thread support")
|
||||||
|
def test_threads(self):
|
17
python.spec
17
python.spec
@ -107,8 +107,8 @@
|
|||||||
Summary: An interpreted, interactive, object-oriented programming language
|
Summary: An interpreted, interactive, object-oriented programming language
|
||||||
Name: %{python}
|
Name: %{python}
|
||||||
# Remember to also rebase python-docs when changing this:
|
# Remember to also rebase python-docs when changing this:
|
||||||
Version: 2.7.10
|
Version: 2.7.11
|
||||||
Release: 11%{?dist}
|
Release: 1%{?dist}
|
||||||
License: Python
|
License: Python
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
Requires: %{python}-libs%{?_isa} = %{version}-%{release}
|
Requires: %{python}-libs%{?_isa} = %{version}-%{release}
|
||||||
@ -914,10 +914,10 @@ Patch193: 00193-enable-loading-sqlite-extensions.patch
|
|||||||
Patch198: 00198-add-rewheel-module.patch
|
Patch198: 00198-add-rewheel-module.patch
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# OpenSSL disabled SSLv3 in SSLv23 method
|
# test_gdb.test_threads fails when run within rpmbuild
|
||||||
# This patch alters python tests to reflect this change
|
# I couldnt reproduce the issue outside of rpmbuild, therefore
|
||||||
# Issue: http://bugs.python.org/issue22638 Upstream discussion about SSLv3 in Python
|
# I skip test for now
|
||||||
Patch199: 00199-alter-tests-to-reflect-sslv3-disabled.patch
|
Patch200: 00200-skip-thread-test.patch
|
||||||
|
|
||||||
# (New patches go here ^^^)
|
# (New patches go here ^^^)
|
||||||
#
|
#
|
||||||
@ -1292,8 +1292,8 @@ mv Modules/cryptmodule.c Modules/_cryptmodule.c
|
|||||||
# 00197: upstream as of Python 2.7.9
|
# 00197: upstream as of Python 2.7.9
|
||||||
%if 0%{with_rewheel}
|
%if 0%{with_rewheel}
|
||||||
%patch198 -p1
|
%patch198 -p1
|
||||||
%patch199 -p1
|
|
||||||
%endif
|
%endif
|
||||||
|
%patch200 -p1
|
||||||
|
|
||||||
|
|
||||||
# This shouldn't be necesarry, but is right now (2.2a3)
|
# This shouldn't be necesarry, but is right now (2.2a3)
|
||||||
@ -2155,6 +2155,9 @@ rm -fr %{buildroot}
|
|||||||
# ======================================================
|
# ======================================================
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Dec 15 2015 Robert Kuska <rkuska@redhat.com> - 2.7.11-1
|
||||||
|
- Update to 2.7.11
|
||||||
|
|
||||||
* Thu Oct 15 2015 Thomas Spura <tomspur@fedoraproject.org> - 2.7.10-11
|
* Thu Oct 15 2015 Thomas Spura <tomspur@fedoraproject.org> - 2.7.10-11
|
||||||
- provide/obsolete _isa packages in python_provide (#1271776)
|
- provide/obsolete _isa packages in python_provide (#1271776)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user