Fixed lib64 patch
This commit is contained in:
parent
485c86512c
commit
7455bcf3aa
@ -1,6 +1,6 @@
|
|||||||
diff -up Python-2.7.3/Lib/distutils/command/install.py.lib64 Python-2.7.3/Lib/distutils/command/install.py
|
diff -up Python-2.7.6/Lib/distutils/command/install.py.lib64 Python-2.7.6/Lib/distutils/command/install.py
|
||||||
--- Python-2.7.3/Lib/distutils/command/install.py.lib64 2012-04-09 19:07:29.000000000 -0400
|
--- Python-2.7.6/Lib/distutils/command/install.py.lib64 2013-11-10 08:36:40.000000000 +0100
|
||||||
+++ Python-2.7.3/Lib/distutils/command/install.py 2013-02-19 13:58:20.446015129 -0500
|
+++ Python-2.7.6/Lib/distutils/command/install.py 2014-01-29 13:51:19.779590378 +0100
|
||||||
@@ -42,14 +42,14 @@ else:
|
@@ -42,14 +42,14 @@ else:
|
||||||
INSTALL_SCHEMES = {
|
INSTALL_SCHEMES = {
|
||||||
'unix_prefix': {
|
'unix_prefix': {
|
||||||
@ -18,10 +18,10 @@ diff -up Python-2.7.3/Lib/distutils/command/install.py.lib64 Python-2.7.3/Lib/di
|
|||||||
'headers': '$base/include/python/$dist_name',
|
'headers': '$base/include/python/$dist_name',
|
||||||
'scripts': '$base/bin',
|
'scripts': '$base/bin',
|
||||||
'data' : '$base',
|
'data' : '$base',
|
||||||
diff -up Python-2.7.3/Lib/distutils/sysconfig.py.lib64 Python-2.7.3/Lib/distutils/sysconfig.py
|
diff -up Python-2.7.6/Lib/distutils/sysconfig.py.lib64 Python-2.7.6/Lib/distutils/sysconfig.py
|
||||||
--- Python-2.7.3/Lib/distutils/sysconfig.py.lib64 2012-04-09 19:07:29.000000000 -0400
|
--- Python-2.7.6/Lib/distutils/sysconfig.py.lib64 2013-11-10 08:36:40.000000000 +0100
|
||||||
+++ Python-2.7.3/Lib/distutils/sysconfig.py 2013-02-19 13:58:20.446015129 -0500
|
+++ Python-2.7.6/Lib/distutils/sysconfig.py 2014-01-29 13:51:19.779590378 +0100
|
||||||
@@ -114,8 +114,12 @@ def get_python_lib(plat_specific=0, stan
|
@@ -119,8 +119,12 @@ def get_python_lib(plat_specific=0, stan
|
||||||
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
prefix = plat_specific and EXEC_PREFIX or PREFIX
|
||||||
|
|
||||||
if os.name == "posix":
|
if os.name == "posix":
|
||||||
@ -35,10 +35,10 @@ diff -up Python-2.7.3/Lib/distutils/sysconfig.py.lib64 Python-2.7.3/Lib/distutil
|
|||||||
if standard_lib:
|
if standard_lib:
|
||||||
return libpython
|
return libpython
|
||||||
else:
|
else:
|
||||||
diff -up Python-2.7.3/Lib/site.py.lib64 Python-2.7.3/Lib/site.py
|
diff -up Python-2.7.6/Lib/site.py.lib64 Python-2.7.6/Lib/site.py
|
||||||
--- Python-2.7.3/Lib/site.py.lib64 2012-04-09 19:07:31.000000000 -0400
|
--- Python-2.7.6/Lib/site.py.lib64 2013-11-10 08:36:40.000000000 +0100
|
||||||
+++ Python-2.7.3/Lib/site.py 2013-02-19 13:58:20.447015128 -0500
|
+++ Python-2.7.6/Lib/site.py 2014-01-29 13:51:19.779590378 +0100
|
||||||
@@ -300,12 +300,16 @@ def getsitepackages():
|
@@ -288,12 +288,16 @@ def getsitepackages():
|
||||||
if sys.platform in ('os2emx', 'riscos'):
|
if sys.platform in ('os2emx', 'riscos'):
|
||||||
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
|
sitepackages.append(os.path.join(prefix, "Lib", "site-packages"))
|
||||||
elif os.sep == '/':
|
elif os.sep == '/':
|
||||||
@ -55,9 +55,9 @@ diff -up Python-2.7.3/Lib/site.py.lib64 Python-2.7.3/Lib/site.py
|
|||||||
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
|
||||||
if sys.platform == "darwin":
|
if sys.platform == "darwin":
|
||||||
# for framework builds *only* we add the standard Apple
|
# for framework builds *only* we add the standard Apple
|
||||||
diff -up Python-2.7.3/Lib/test/test_site.py.lib64 Python-2.7.3/Lib/test/test_site.py
|
diff -up Python-2.7.6/Lib/test/test_site.py.lib64 Python-2.7.6/Lib/test/test_site.py
|
||||||
--- Python-2.7.3/Lib/test/test_site.py.lib64 2012-04-09 19:07:32.000000000 -0400
|
--- Python-2.7.6/Lib/test/test_site.py.lib64 2013-11-10 08:36:40.000000000 +0100
|
||||||
+++ Python-2.7.3/Lib/test/test_site.py 2013-02-19 13:58:20.447015128 -0500
|
+++ Python-2.7.6/Lib/test/test_site.py 2014-01-29 13:51:19.780590315 +0100
|
||||||
@@ -241,17 +241,20 @@ class HelperFunctionsTests(unittest.Test
|
@@ -241,17 +241,20 @@ class HelperFunctionsTests(unittest.Test
|
||||||
self.assertEqual(dirs[2], wanted)
|
self.assertEqual(dirs[2], wanted)
|
||||||
elif os.sep == '/':
|
elif os.sep == '/':
|
||||||
@ -83,10 +83,10 @@ diff -up Python-2.7.3/Lib/test/test_site.py.lib64 Python-2.7.3/Lib/test/test_sit
|
|||||||
self.assertEqual(dirs[1], wanted)
|
self.assertEqual(dirs[1], wanted)
|
||||||
|
|
||||||
class PthFile(object):
|
class PthFile(object):
|
||||||
diff -up Python-2.7.3/Makefile.pre.in.lib64 Python-2.7.3/Makefile.pre.in
|
diff -up Python-2.7.6/Makefile.pre.in.lib64 Python-2.7.6/Makefile.pre.in
|
||||||
--- Python-2.7.3/Makefile.pre.in.lib64 2013-02-19 13:58:20.435015131 -0500
|
--- Python-2.7.6/Makefile.pre.in.lib64 2014-01-29 13:51:19.773590757 +0100
|
||||||
+++ Python-2.7.3/Makefile.pre.in 2013-02-19 13:58:20.447015128 -0500
|
+++ Python-2.7.6/Makefile.pre.in 2014-01-29 13:51:19.780590315 +0100
|
||||||
@@ -97,7 +97,7 @@ LIBDIR= @libdir@
|
@@ -106,7 +106,7 @@ LIBDIR= @libdir@
|
||||||
MANDIR= @mandir@
|
MANDIR= @mandir@
|
||||||
INCLUDEDIR= @includedir@
|
INCLUDEDIR= @includedir@
|
||||||
CONFINCLUDEDIR= $(exec_prefix)/include
|
CONFINCLUDEDIR= $(exec_prefix)/include
|
||||||
@ -95,9 +95,30 @@ diff -up Python-2.7.3/Makefile.pre.in.lib64 Python-2.7.3/Makefile.pre.in
|
|||||||
|
|
||||||
# Detailed destination directories
|
# Detailed destination directories
|
||||||
BINLIBDEST= $(LIBDIR)/python$(VERSION)
|
BINLIBDEST= $(LIBDIR)/python$(VERSION)
|
||||||
diff -up Python-2.7.3/Modules/getpath.c.lib64 Python-2.7.3/Modules/getpath.c
|
diff -up Python-2.7.6/Modules/Setup.dist.lib64 Python-2.7.6/Modules/Setup.dist
|
||||||
--- Python-2.7.3/Modules/getpath.c.lib64 2012-04-09 19:07:34.000000000 -0400
|
--- Python-2.7.6/Modules/Setup.dist.lib64 2014-01-29 13:51:19.768591073 +0100
|
||||||
+++ Python-2.7.3/Modules/getpath.c 2013-02-19 13:58:20.448015128 -0500
|
+++ Python-2.7.6/Modules/Setup.dist 2014-01-29 13:51:19.781590252 +0100
|
||||||
|
@@ -416,7 +416,7 @@ gdbm gdbmmodule.c -lgdbm
|
||||||
|
# Edit the variables DB and DBLIBVERto point to the db top directory
|
||||||
|
# and the subdirectory of PORT where you built it.
|
||||||
|
DBINC=/usr/include/libdb
|
||||||
|
-DBLIB=/usr/lib
|
||||||
|
+DBLIB=/usr/lib64
|
||||||
|
_bsddb _bsddb.c -I$(DBINC) -L$(DBLIB) -ldb
|
||||||
|
|
||||||
|
# Historical Berkeley DB 1.85
|
||||||
|
@@ -462,7 +462,7 @@ cPickle cPickle.c
|
||||||
|
# Andrew Kuchling's zlib module.
|
||||||
|
# This require zlib 1.1.3 (or later).
|
||||||
|
# See http://www.gzip.org/zlib/
|
||||||
|
-zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz
|
||||||
|
+zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib64 -lz
|
||||||
|
|
||||||
|
# Interface to the Expat XML parser
|
||||||
|
#
|
||||||
|
diff -up Python-2.7.6/Modules/getpath.c.lib64 Python-2.7.6/Modules/getpath.c
|
||||||
|
--- Python-2.7.6/Modules/getpath.c.lib64 2013-11-10 08:36:41.000000000 +0100
|
||||||
|
+++ Python-2.7.6/Modules/getpath.c 2014-01-29 13:51:19.781590252 +0100
|
||||||
@@ -117,8 +117,8 @@
|
@@ -117,8 +117,8 @@
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
@ -118,7 +139,7 @@ diff -up Python-2.7.3/Modules/getpath.c.lib64 Python-2.7.3/Modules/getpath.c
|
|||||||
|
|
||||||
static void
|
static void
|
||||||
reduce(char *dir)
|
reduce(char *dir)
|
||||||
@@ -528,7 +528,7 @@ calculate_path(void)
|
@@ -543,7 +543,7 @@ calculate_path(void)
|
||||||
}
|
}
|
||||||
else
|
else
|
||||||
strncpy(zip_path, PREFIX, MAXPATHLEN);
|
strncpy(zip_path, PREFIX, MAXPATHLEN);
|
||||||
@ -127,7 +148,7 @@ diff -up Python-2.7.3/Modules/getpath.c.lib64 Python-2.7.3/Modules/getpath.c
|
|||||||
bufsz = strlen(zip_path); /* Replace "00" with version */
|
bufsz = strlen(zip_path); /* Replace "00" with version */
|
||||||
zip_path[bufsz - 6] = VERSION[0];
|
zip_path[bufsz - 6] = VERSION[0];
|
||||||
zip_path[bufsz - 5] = VERSION[2];
|
zip_path[bufsz - 5] = VERSION[2];
|
||||||
@@ -538,7 +538,7 @@ calculate_path(void)
|
@@ -553,7 +553,7 @@ calculate_path(void)
|
||||||
fprintf(stderr,
|
fprintf(stderr,
|
||||||
"Could not find platform dependent libraries <exec_prefix>\n");
|
"Could not find platform dependent libraries <exec_prefix>\n");
|
||||||
strncpy(exec_prefix, EXEC_PREFIX, MAXPATHLEN);
|
strncpy(exec_prefix, EXEC_PREFIX, MAXPATHLEN);
|
||||||
@ -136,40 +157,19 @@ diff -up Python-2.7.3/Modules/getpath.c.lib64 Python-2.7.3/Modules/getpath.c
|
|||||||
}
|
}
|
||||||
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
|
||||||
|
|
||||||
diff -up Python-2.7.3/Modules/Setup.dist.lib64 Python-2.7.3/Modules/Setup.dist
|
diff -up Python-2.7.6/setup.py.lib64 Python-2.7.6/setup.py
|
||||||
--- Python-2.7.3/Modules/Setup.dist.lib64 2013-02-19 13:58:20.442015131 -0500
|
--- Python-2.7.6/setup.py.lib64 2013-11-10 08:36:41.000000000 +0100
|
||||||
+++ Python-2.7.3/Modules/Setup.dist 2013-02-19 14:02:25.255998391 -0500
|
+++ Python-2.7.6/setup.py 2014-01-29 13:56:02.713716528 +0100
|
||||||
@@ -413,7 +413,7 @@ gdbm gdbmmodule.c -lgdbm
|
@@ -438,7 +438,7 @@ class PyBuildExt(build_ext):
|
||||||
# Edit the variables DB and DBLIBVERto point to the db top directory
|
|
||||||
# and the subdirectory of PORT where you built it.
|
|
||||||
DBINC=/usr/include/libdb
|
|
||||||
-DBLIB=/usr/lib
|
|
||||||
+DBLIB=/usr/lib64
|
|
||||||
_bsddb _bsddb.c -I$(DBINC) -L$(DBLIB) -ldb
|
|
||||||
|
|
||||||
# Historical Berkeley DB 1.85
|
|
||||||
@@ -459,7 +459,7 @@ cPickle cPickle.c
|
|
||||||
# Andrew Kuchling's zlib module.
|
|
||||||
# This require zlib 1.1.3 (or later).
|
|
||||||
# See http://www.gzip.org/zlib/
|
|
||||||
-zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz
|
|
||||||
+zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib64 -lz
|
|
||||||
|
|
||||||
# Interface to the Expat XML parser
|
|
||||||
#
|
|
||||||
diff -up Python-2.7.3/setup.py.lib64 Python-2.7.3/setup.py
|
|
||||||
--- Python-2.7.3/setup.py.lib64 2012-04-09 19:07:36.000000000 -0400
|
|
||||||
+++ Python-2.7.3/setup.py 2013-02-19 13:58:20.449015129 -0500
|
|
||||||
@@ -369,7 +369,7 @@ class PyBuildExt(build_ext):
|
|
||||||
|
|
||||||
def detect_modules(self):
|
def detect_modules(self):
|
||||||
# Ensure that /usr/local is always used
|
# Ensure that /usr/local is always used
|
||||||
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
if not cross_compiling:
|
||||||
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
|
||||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
|
||||||
self.add_gcc_paths()
|
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
|
||||||
self.add_multiarch_paths()
|
if cross_compiling:
|
||||||
@@ -677,11 +677,11 @@ class PyBuildExt(build_ext):
|
self.add_gcc_paths()
|
||||||
|
@@ -758,11 +758,11 @@ class PyBuildExt(build_ext):
|
||||||
elif curses_library:
|
elif curses_library:
|
||||||
readline_libs.append(curses_library)
|
readline_libs.append(curses_library)
|
||||||
elif self.compiler.find_library_file(lib_dirs +
|
elif self.compiler.find_library_file(lib_dirs +
|
||||||
@ -183,7 +183,7 @@ diff -up Python-2.7.3/setup.py.lib64 Python-2.7.3/setup.py
|
|||||||
extra_link_args=readline_extra_link_args,
|
extra_link_args=readline_extra_link_args,
|
||||||
libraries=readline_libs) )
|
libraries=readline_libs) )
|
||||||
else:
|
else:
|
||||||
@@ -715,8 +715,8 @@ class PyBuildExt(build_ext):
|
@@ -797,8 +797,8 @@ class PyBuildExt(build_ext):
|
||||||
if krb5_h:
|
if krb5_h:
|
||||||
ssl_incs += krb5_h
|
ssl_incs += krb5_h
|
||||||
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
|
||||||
|
Loading…
Reference in New Issue
Block a user