- build against db4.6

This commit is contained in:
Jeremy Katz 2007-08-14 14:38:32 +00:00
parent 8cf5a31273
commit 50ca1838b0
2 changed files with 30 additions and 1 deletions

21
python-2.5.1-db46.patch Normal file
View File

@ -0,0 +1,21 @@
diff -up Python-2.5.1/setup.py.db46 Python-2.5.1/setup.py
--- Python-2.5.1/setup.py.db46 2007-08-14 10:25:42.000000000 -0400
+++ Python-2.5.1/setup.py 2007-08-14 10:26:11.000000000 -0400
@@ -606,7 +606,7 @@ class PyBuildExt(build_ext):
# a release. Most open source OSes come with one or more
# versions of BerkeleyDB already installed.
- max_db_ver = (4, 5)
+ max_db_ver = (4, 6)
min_db_ver = (3, 3)
db_setup_debug = False # verbose debug prints from this script?
@@ -623,7 +623,7 @@ class PyBuildExt(build_ext):
'/sw/include/db3',
]
# 4.x minor number specific paths
- for x in (0,1,2,3,4,5):
+ for x in (0,1,2,3,4,5,6):
db_inc_paths.append('/usr/include/db4%d' % x)
db_inc_paths.append('/usr/include/db4.%d' % x)
db_inc_paths.append('/usr/local/BerkeleyDB.4.%d/include' % x)

View File

@ -20,7 +20,7 @@
Summary: An interpreted, interactive, object-oriented programming language.
Name: %{python}
Version: 2.5.1
Release: 7%{?dist}
Release: 8%{?dist}
License: Python Software Foundation License v2
Group: Development/Languages
Provides: python-abi = %{pybasever}
@ -39,10 +39,14 @@ Patch5: python-2.5.1-ctypes-exec-stack.patch
# disable egg-infos for now
Patch50: python-2.5-disable-egginfo.patch
# new db version
Patch60: python-2.5.1-db46.patch
# lib64 patches
Patch101: python-2.3.4-lib64-regex.patch
Patch102: python-2.5-lib64.patch
%if %{main_python}
Obsoletes: Distutils
Provides: Distutils
@ -159,6 +163,7 @@ user interface for Python programming.
%patch5 -p1 -b .ctypesexec
%patch50 -p1 -b .egginfo
%patch60 -p1 -b .db46
%if %{_lib} == lib64
%patch101 -p1 -b .lib64-regex
@ -416,6 +421,9 @@ rm -fr $RPM_BUILD_ROOT
%{_libdir}/python%{pybasever}/lib-dynload/_tkinter.so
%changelog
* Tue Aug 14 2007 Jeremy Katz <katzj@redhat.com> - 2.5.1-8
- build against db4.6
* Tue Aug 14 2007 Dennis Gilmore <dennis@ausil.us> - 2.5.1-7
- add sparc64 to the list of archs for _pyconfig64_h