Update to 4.4.1
Drop requires patch, fixed upstream
This commit is contained in:
parent
3946c32701
commit
2c594f80c5
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ tornado-1.0.1.tar.gz
|
||||
/tornado-4.1.tar.gz
|
||||
/tornado-4.2.1.tar.gz
|
||||
/tornado-4.3.tar.gz
|
||||
/tornado-4.4.1.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up tornado-4.3/setup.py.requires tornado-4.3/setup.py
|
||||
--- tornado-4.3/setup.py.requires 2016-09-15 21:31:05.188426632 -0600
|
||||
+++ tornado-4.3/setup.py 2016-09-15 21:49:19.093465027 -0600
|
||||
@@ -124,8 +124,6 @@ if setuptools is not None:
|
||||
if sys.version_info < (2, 7):
|
||||
# Only needed indirectly, for singledispatch.
|
||||
install_requires.append('ordereddict')
|
||||
- if sys.version_info < (3, 2):
|
||||
- install_requires.append('backports.ssl_match_hostname')
|
||||
if sys.version_info < (3, 4):
|
||||
install_requires.append('singledispatch')
|
||||
if sys.version_info < (3, 5):
|
@ -5,8 +5,8 @@
|
||||
%global srcname tornado
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 4.3
|
||||
Release: 5%{?dist}
|
||||
Version: 4.4.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Scalable, non-blocking web server and tools
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -15,9 +15,6 @@ URL: http://www.tornadoweb.org
|
||||
Source0: https://pypi.python.org/packages/source/t/tornado/tornado-%{version}.tar.gz
|
||||
# Patch to use system CA certs instead of certifi
|
||||
Patch0: python-tornado-cert.patch
|
||||
# Remove unnecessary requires (backports.ssl_match_hostname
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1372887
|
||||
Patch1: python-tornado-requires.patch
|
||||
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python2-backports_abc
|
||||
@ -99,7 +96,6 @@ ideal for real-time web services.
|
||||
%prep
|
||||
%setup -q -n %{srcname}-%{version}
|
||||
%patch0 -p1 -b .cert
|
||||
%patch1 -p1 -b .requires
|
||||
# remove shebang from files
|
||||
%{__sed} -i.orig -e '/^#!\//, 1d' *py tornado/*.py tornado/*/*.py
|
||||
|
||||
@ -141,6 +137,10 @@ ideal for real-time web services.
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Sep 15 2016 Orion Poplawski <orion@cora.nwra.com> - 4.4.1-1
|
||||
- Update to 4.4.1
|
||||
- Drop requires patch, fixed upstream
|
||||
|
||||
* Thu Sep 15 2016 Orion Poplawski <orion@cora.nwra.com> - 4.3-5
|
||||
- Remove backports.ssl_match_hostname from python2-tornado egg requires (bug #1372887)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user