New version added filenames with spaces. Adjust accordingly
This commit is contained in:
parent
0d1fa920b4
commit
9d6978a8fa
@ -1,24 +0,0 @@
|
||||
changeset: 754:f64c2d57df43
|
||||
branch: 0.6-maintenance
|
||||
tag: tip
|
||||
user: Toshio Kuratomi <toshio@fedoraproject.org>
|
||||
date: Tue Feb 22 12:05:49 2011 -0800
|
||||
summary: Fix for easy_install running on python-3.2
|
||||
|
||||
diff -r 5bc94690ee6c -r f64c2d57df43 setuptools/command/easy_install.py
|
||||
--- a/setuptools/command/easy_install.py Sat Nov 06 15:01:33 2010 +0100
|
||||
+++ b/setuptools/command/easy_install.py Tue Feb 22 12:05:49 2011 -0800
|
||||
@@ -204,6 +204,12 @@
|
||||
'exec_prefix': exec_prefix,
|
||||
}
|
||||
|
||||
+ try:
|
||||
+ self.config_vars['abiflags'] = sys.abiflags
|
||||
+ except AttributeError:
|
||||
+ # Only python-3.2+ has sys.abiflags
|
||||
+ self.config_vars['abiflags'] = ''
|
||||
+
|
||||
if HAS_USER_SITE:
|
||||
self.config_vars['userbase'] = self.install_userbase
|
||||
self.config_vars['usersite'] = self.install_usersite
|
||||
|
@ -70,7 +70,9 @@ cp -a . %{py3dir}
|
||||
find %{py3dir} -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python3}|'
|
||||
%endif # with_python3
|
||||
|
||||
find -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python}|'
|
||||
for file in setuptools/command/easy_install.py distribute_setup.py ; do
|
||||
sed -i '1s|^#!python|#!%{__python}|' $file
|
||||
done
|
||||
|
||||
%build
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user