Update to 69.2.0
- Resolves: rhbz#2269358
This commit is contained in:
parent
b987401aa1
commit
20fe514069
@ -1,4 +1,4 @@
|
||||
From 58f33f0aef5b137287e6f425b922a03123735a77 Mon Sep 17 00:00:00 2001
|
||||
From cd3eb82521ecb89efc85a319f77cd74583e91b48 Mon Sep 17 00:00:00 2001
|
||||
From: Lumir Balhar <lbalhar@redhat.com>
|
||||
Date: Wed, 20 Sep 2023 17:18:47 +0200
|
||||
Subject: [PATCH] Adjust the setup.py install deprecation message and URL
|
||||
@ -9,7 +9,7 @@ But only when building RPM packages.
|
||||
1 file changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/setuptools/command/install.py b/setuptools/command/install.py
|
||||
index 606cce9..0af1631 100644
|
||||
index 56c1155..ab51004 100644
|
||||
--- a/setuptools/command/install.py
|
||||
+++ b/setuptools/command/install.py
|
||||
@@ -1,6 +1,7 @@
|
||||
@ -19,8 +19,8 @@ index 606cce9..0af1631 100644
|
||||
+import os
|
||||
import platform
|
||||
import distutils.command.install as orig
|
||||
|
||||
@@ -40,8 +41,13 @@ class install(orig.install):
|
||||
from typing import cast
|
||||
@@ -42,8 +43,13 @@ class install(orig.install):
|
||||
Please avoid running ``setup.py`` directly.
|
||||
Instead, use pypa/build, pypa/installer or other
|
||||
standards-based tools.
|
||||
@ -37,5 +37,5 @@ index 606cce9..0af1631 100644
|
||||
# (e.g. by unziping the wheel file)
|
||||
# and then add a due_date to this warning.
|
||||
--
|
||||
2.41.0
|
||||
2.43.2
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 253113e2c9679242f83420627c20888111fe76f4 Mon Sep 17 00:00:00 2001
|
||||
From 4eb2c01dcbfd0782fed8910bd617ac6880bfd801 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Tom=C3=A1=C5=A1=20Hrn=C4=8Diar?= <thrnciar@redhat.com>
|
||||
Date: Fri, 8 Mar 2024 10:40:26 +0100
|
||||
Subject: [PATCH] Remove optional or unpackaged test deps
|
||||
@ -11,14 +11,14 @@ Co-authored-by: Miro Hrončok <miro@hroncok.cz>
|
||||
Co-authored-by: Charalampos Stratakis <cstratak@redhat.com>
|
||||
Co-authored-by: Lumir Balhar <lbalhar@redhat.com>
|
||||
---
|
||||
setup.cfg | 13 -------------
|
||||
1 file changed, 13 deletions(-)
|
||||
setup.cfg | 11 -----------
|
||||
1 file changed, 11 deletions(-)
|
||||
|
||||
diff --git a/setup.cfg b/setup.cfg
|
||||
index edf9798..839ff1a 100644
|
||||
index c1133a7..3aea015 100644
|
||||
--- a/setup.cfg
|
||||
+++ b/setup.cfg
|
||||
@@ -40,15 +40,6 @@ exclude =
|
||||
@@ -40,13 +40,6 @@ exclude =
|
||||
[options.extras_require]
|
||||
testing =
|
||||
pytest >= 6
|
||||
@ -29,13 +29,11 @@ index edf9798..839ff1a 100644
|
||||
- python_implementation != "PyPy"
|
||||
- pytest-enabler >= 2.2
|
||||
- pytest-ruff >= 0.2.1; sys_platform != "cygwin"
|
||||
-
|
||||
- flake8-2020
|
||||
|
||||
virtualenv>=13.0.0
|
||||
wheel
|
||||
pip>=19.1 # For proper file:// URLs support.
|
||||
@@ -57,13 +48,9 @@ testing =
|
||||
pytest-xdist
|
||||
@@ -56,13 +49,9 @@ testing =
|
||||
pytest-xdist>=3 # Dropped dependency on pytest-fork and py
|
||||
jaraco.path>=3.2.0
|
||||
build[virtualenv]
|
||||
- filelock>=3.4.0
|
||||
@ -46,8 +44,8 @@ index edf9798..839ff1a 100644
|
||||
- sys_platform != "cygwin"
|
||||
- jaraco.develop >= 7.21; python_version >= "3.9" and sys_platform != "cygwin"
|
||||
pytest-home >= 0.5
|
||||
testing-integration =
|
||||
pytest
|
||||
mypy==1.9 # pin mypy version so a new version doesn't suddenly cause the CI to fail
|
||||
tomli
|
||||
--
|
||||
2.42.0
|
||||
2.43.2
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
||||
|
||||
Name: python-setuptools
|
||||
# When updating, update the bundled libraries versions bellow!
|
||||
Version: 69.1.1
|
||||
Version: 69.2.0
|
||||
Release: %autorelease
|
||||
Summary: Easily build and distribute Python packages
|
||||
# setuptools is MIT
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (setuptools-69.1.1.tar.gz) = ddd1e94afa8869bcc521494cd66d9a23ba2b9674ff0a7f7f8609ea2bc61137d8f0b6891708eb7c7308e9ac366edfb66bd4439c73a4ba098ae743ca82b45f12ff
|
||||
SHA512 (setuptools-69.2.0.tar.gz) = e69abe573304b1c2c074144c9df663fec0d6ce617359f070ca8d57710e4beb99435d0d2124d45a7d8b24889693597e1e03875bc6ff960fa31f6250e1c253b906
|
||||
|
Loading…
Reference in New Issue
Block a user