Update to 0.14.2 to fix numpy 1.16 compatibility (bugz#1706125)

Add requires on dask and maplotlib-qt5 (bugz#1691823)
This commit is contained in:
Orion Poplawski 2019-05-05 14:34:37 -06:00
parent 662b5064cf
commit acd75948e2
4 changed files with 10 additions and 91 deletions

1
.gitignore vendored
View File

@ -6,3 +6,4 @@
/scikit-image-0.12.3.tar.gz
/scikit-image-0.13.0.tar.gz
/scikit-image-0.14.0.tar.gz
/scikit-image-0.14.2.tar.gz

View File

@ -1,88 +0,0 @@
From 48be23fc5ca94efa0f42a2242f1bb10f11992a42 Mon Sep 17 00:00:00 2001
From: Orion Poplawski <orion@cora.nwra.com>
Date: Wed, 6 Apr 2016 10:33:26 -0600
Subject: [PATCH 1/3] Do not use setup_requires for cython - source tarballs
have shipped .c files
---
setup.py | 2 --
1 file changed, 2 deletions(-)
diff --git a/setup.py b/setup.py
index 53b5aa7..1ca10a5 100644
--- a/setup.py
+++ b/setup.py
@@ -131,8 +131,6 @@ def configuration(parent_package='', top_path=None):
'Operating System :: MacOS',
],
install_requires=INSTALL_REQUIRES,
- # install cython when running setup.py (source install)
- setup_requires=['cython>=0.21'],
requires=REQUIRES,
packages=setuptools.find_packages(exclude=['doc']),
include_package_data=True,
From b90d0b505ac9ae8f51b85058635c063b896566f6 Mon Sep 17 00:00:00 2001
From: Orion Poplawski <orion@cora.nwra.com>
Date: Wed, 6 Apr 2016 10:38:34 -0600
Subject: [PATCH 2/3] Simply do not use cython to rebuild .c files if installed
cython is too old, do not emit error
Give RuntimeError if cython is missing and we need it
---
skimage/_build.py | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
diff --git a/skimage/_build.py b/skimage/_build.py
index 2905ee2..e88d356 100644
--- a/skimage/_build.py
+++ b/skimage/_build.py
@@ -27,15 +27,19 @@ def cython(pyx_files, working_path=''):
try:
from Cython import __version__
if LooseVersion(__version__) < '0.23':
- raise RuntimeError('Cython >= 0.23 needed to build scikit-image')
+ raise ImportError
from Cython.Build import cythonize
except ImportError:
- # If cython is not found, we do nothing -- the build will make use of
- # the distributed .c files
- print("Cython not found; falling back to pre-built %s" \
- % " ".join([f.replace('.pyx.in', 'c').replace('.pyx', '.c')
- for f in pyx_files]))
+ # If cython is not found, the build will make use of
+ # the distributed .c files if present
+ c_files = [f.replace('.pyx.in', '.c').replace('.pyx', '.c') for f in pyx_files]
+ for cfile in [os.path.join(working_path, f) for f in c_files]:
+ if not os.path.isfile(cfile):
+ raise RuntimeError('Cython >= 0.23 is required to build scikit-image from SCM checkout')
+
+ print("Cython >= 0.23 not found; falling back to pre-built %s" \
+ % " ".join(c_files))
else:
for pyxfile in [os.path.join(working_path, f) for f in pyx_files]:
From db4f67ee6cc3f23442fd95597b20c63971bbb13f Mon Sep 17 00:00:00 2001
From: Orion Poplawski <orion@cora.nwra.com>
Date: Sat, 16 Apr 2016 15:10:54 -0600
Subject: [PATCH 3/3] SCM -> git
---
skimage/_build.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/skimage/_build.py b/skimage/_build.py
index e88d356..b50128b 100644
--- a/skimage/_build.py
+++ b/skimage/_build.py
@@ -36,7 +36,7 @@ def cython(pyx_files, working_path=''):
c_files = [f.replace('.pyx.in', '.c').replace('.pyx', '.c') for f in pyx_files]
for cfile in [os.path.join(working_path, f) for f in c_files]:
if not os.path.isfile(cfile):
- raise RuntimeError('Cython >= 0.23 is required to build scikit-image from SCM checkout')
+ raise RuntimeError('Cython >= 0.23 is required to build scikit-image from git checkout')
print("Cython >= 0.23 not found; falling back to pre-built %s" \
% " ".join(c_files))

View File

@ -4,8 +4,8 @@
%{?python_disable_dependency_generator}
Name: python-scikit-image
Version: 0.14.0
Release: 7%{?dist}
Version: 0.14.2
Release: 1%{?dist}
Summary: Image processing in Python
# The following files are BSD 2 clauses, the rest BSD 3 clauses
# skimage/graph/_mcp.pyx
@ -31,6 +31,8 @@ BuildRequires: python3-six >= 1.3
BuildRequires: python3-networkx-core
BuildRequires: python3-pillow
BuildRequires: python3-pywt python3-Cython
Requires: python3-dask
Requires: python3-matplotlib-qt5
Requires: python3-scipy
Requires: python3-six >= 1.3
Requires: python3-networkx-core
@ -94,6 +96,10 @@ popd
%changelog
* Sun May 5 2019 Orion Poplawski <orion@nwra.com> - 0.14.2-1
- Update to 0.14.2 to fix numpy 1.16 compatibility (bugz#1706125)
- Add requires on dask and maplotlib-qt5 (bugz#1691823)
* Mon Mar 04 2019 Christian Dersch <lupinix@mailbox.org> - 0.14.0-7
- Disable automatic dependency generators until we fixed (optional) deps

View File

@ -1 +1 @@
SHA512 (scikit-image-0.14.0.tar.gz) = 224a6af745e1eb7d38c425afa411a9baac3e9504b639233fd10300a55006c3babdf40a3e7ee124e81b327c9f06d0baf35d3f2ccf8f69d3d2d6a54be0e40132f9
SHA512 (scikit-image-0.14.2.tar.gz) = ab31fdb5b1d16b794ccc4d673f6c8bce0a8a54b81c0e43c9a4cdd5eb0465ef69ac184a06e395a1d27da51c2e0911db9afa2be4e740f44bceab952428eb7f599a