python-rpm-macros/python-rpm-macros.spec

126 lines
3.8 KiB
RPMSpec

Name: python-rpm-macros
Version: 3
Release: 15%{?dist}
Summary: The unversioned Python RPM macros
License: MIT
Source0: macros.python
Source1: macros.python-srpm
Source2: macros.python2
Source3: macros.python3
Source5: macros.pybytecompile
BuildArch: noarch
# For %%python3_pkgversion used in %%python_provide
Requires: python-srpm-macros
%description
This package contains the unversioned Python RPM macros, that most
implementations should rely on.
You should not need to install this package manually as the various
python?-devel packages require it. So install a python-devel package instead.
%package -n python-srpm-macros
Summary: RPM macros for building Python source packages
%description -n python-srpm-macros
RPM macros for building Python source packages.
%package -n python2-rpm-macros
Summary: RPM macros for building Python 2 packages
%description -n python2-rpm-macros
RPM macros for building Python 2 packages.
%package -n python3-rpm-macros
Summary: RPM macros for building Python 3 packages
%description -n python3-rpm-macros
RPM macros for building Python 3 packages.
%prep
%build
%install
mkdir -p %{buildroot}/%{rpmmacrodir}
install -m 644 %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE5} \
%{buildroot}/%{rpmmacrodir}
%files
%{rpmmacrodir}/macros.python
%{rpmmacrodir}/macros.pybytecompile
%files -n python-srpm-macros
%{rpmmacrodir}/macros.python-srpm
%files -n python2-rpm-macros
%{rpmmacrodir}/macros.python2
%files -n python3-rpm-macros
%{rpmmacrodir}/macros.python3
%changelog
* Fri Sep 27 2019 Miro Hrončok <mhroncok@redhat.com> - 3-15
- Define %%python2 and %%python3
- Drop hardcoded python2 from %%py_build
* Wed Mar 06 2019 Carl George <carl@george.computer> - 3-14
- Move macros.pybytecompile in here from python3X-devel
- macros.pybytecompile: Detect Python version through sys.version_info instead
of guessing from the executable name
* Mon Jul 09 2018 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-13
- Backport %%python3_platform macro.
* Mon Jun 18 2018 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-12
- Add %%pypi_source macro.
* Thu Sep 15 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-11
- Use %%rpmmacrodir to put the macros in the proper location.
- Change %%python2_version* to a form that works on EL6.
- Change %%__python2 to point explicitly to python2.6 to avoid breakage in
Amazon Linux, which links /usr/bin/python to python2.7. This syncs up with
the macros which were in epel-rpm-macros. See
https://bugzilla.redhat.com/show_bug.cgi?id=1347019
* Tue Jul 12 2016 Orion Poplawski <orion@cora.nwra.com> 3-10
- Do not generate useless Obsoletes with %%{?_isa}
* Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-9
- Make python-rpm-macros require python-srpm-macros (bug #1335860)
* Thu May 12 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-8
- Add single-second sleeps to work around setuptools bug.
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Mon Jan 25 2016 Orion Poplawski <orion@cora.nwra.com> 3-6.1
- Set %%__python3 to /usr/bin/python3.4
* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-6
- Fix typo in %%python_provide
* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-5
- Handle noarch python sub-packages (bug #1290900)
* Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-4.1
- EPEL version
* Wed Jan 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-4
- Fix python2/3-rpm-macros package names
* Thu Jan 7 2016 Orion Poplawski <orion@cora.nwra.com> 3-3
- Add empty %%prep and %%build
* Mon Jan 4 2016 Orion Poplawski <orion@cora.nwra.com> 3-2
- Combined package
* Wed Dec 30 2015 Orion Poplawski <orion@cora.nwra.com> 3-1
- Initial package