Update to 5.15.2.

This commit is contained in:
Richard Shaw 2020-11-28 07:48:06 -06:00
parent 9f5ab4fe18
commit 8be37676ac
5 changed files with 31 additions and 7 deletions

1
.gitignore vendored
View File

@ -8,3 +8,4 @@
/pyside-setup-opensource-src-5.14.2.2.tar.xz
/pyside-setup-opensource-src-5.15.0.tar.xz
/pyside-setup-opensource-src-5.15.1.tar.xz
/pyside-setup-opensource-src-5.15.2.tar.xz

View File

@ -0,0 +1,12 @@
Index: pyside-setup-opensource-src-5.15.2/build_scripts/options.py
===================================================================
--- pyside-setup-opensource-src-5.15.2.orig/build_scripts/options.py
+++ pyside-setup-opensource-src-5.15.2/build_scripts/options.py
@@ -167,6 +167,7 @@ OPTION = {
# Legacy, not used any more.
"JOM": has_option('jom'),
"MACOS_USE_LIBCPP": has_option("macos-use-libc++"),
+ "REUSE_BUILD": has_option("reuse-build"),
"QUIET": has_option('quiet', remove=False),
"SNAPSHOT_BUILD": has_option("snapshot-build"),
"LIMITED_API": option_value("limited-api"),

View File

@ -14,7 +14,7 @@
Name: python-%{pypi_name}
Epoch: 1
Version: 5.15.1
Version: 5.15.2
Release: 1%{?dist}
Summary: Python bindings for the Qt 5 cross-platform application and UI framework
@ -27,6 +27,8 @@ Source0: https://download.qt.io/official_releases/QtForPython/%{pypi_name
Patch0: pyside2-tools-obsolete.patch
# Don't abort the build on Python 3.8/3.9
Patch1: python_ver_classifier.patch
# setuptools --reuse-build option was broken in 5.15.2
Patch2: python-pyside2-options_py.patch
%if 0%{?rhel} == 7
BuildRequires: llvm-toolset-7-clang-devel llvm-toolset-7-llvm-devel
@ -189,14 +191,20 @@ mkdir %{_target} && cd %{_target}
%install
%if 0%{?rhel} || 0%{?fedora} < 33
pushd %{_target}
pushd %{_host}
%cmake_install
popd
%else
%cmake_install
%endif
#
# Generate egg-info manually and install since we're performing a cmake build.
#
# Copy CMake configuration files from the BINARY dir back to the SOURCE dir so
# setuptools can find them.
cp %{_host}/sources/shiboken2/shibokenmodule/{*.py,*.txt} sources/shiboken2/shibokenmodule/
cp %{_host}/sources/pyside2/PySide2/*.py sources/pyside2/PySide2/
%{__python3} setup.py egg_info
for name in PySide2 shiboken2 shiboken2_generator; do
mkdir -p %{buildroot}%{python3_sitearch}/$name-%{version}-py%{python3_version}.egg-info
@ -261,6 +269,9 @@ pathfix.py -pni "%{__python3} %{py3_shbang_opts}" %{buildroot}%{_bindir}/*
%changelog
* Mon Nov 23 2020 Richard Shaw <hobbes1069@gmail.com> - 1:5.15.2-1
- Update to 5.15.2.
* Thu Nov 05 2020 Richard Shaw <hobbes1069@gmail.com> - 1:5.15.1-1
- Update to 5.15.1.
- Update conditionals to support older Fedora and EPEL 8.

View File

@ -1,7 +1,7 @@
Index: pyside-setup-opensource-src-5.15.1/build_scripts/config.py
Index: pyside-setup-opensource-src-5.15.2/build_scripts/config.py
===================================================================
--- pyside-setup-opensource-src-5.15.1.orig/build_scripts/config.py
+++ pyside-setup-opensource-src-5.15.1/build_scripts/config.py
--- pyside-setup-opensource-src-5.15.2.orig/build_scripts/config.py
+++ pyside-setup-opensource-src-5.15.2/build_scripts/config.py
@@ -93,6 +93,7 @@ class Config(object):
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
@ -17,5 +17,5 @@ Index: pyside-setup-opensource-src-5.15.1/build_scripts/config.py
- setup_kwargs['python_requires'] = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, <3.10"
+ setup_kwargs['python_requires'] = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, <3.11"
if quiet:
# Tells distutils / setuptools to be quiet, and only print warnings or errors.

View File

@ -1 +1 @@
SHA512 (pyside-setup-opensource-src-5.15.1.tar.xz) = f14c7037367799005fff73d9fc8e7998db1895700911adf34dfabdeb4db486c7b28ba2afb3eaee37c58f4099b00e4a86917b8f7d85f274026bddfc090658b306
SHA512 (pyside-setup-opensource-src-5.15.2.tar.xz) = 5043c1c9db4ba0133baaabb4d4943182e9741b1007bedd992394758707a37bba0688dc6413ea46620e7c2fb09daa3c74e6a7bb2c302b9d08e5f3bb7575d02b62