Update to 1.5.0 (#2038614)

Signed-off-by: Major Hayden <major@mhtx.net>
This commit is contained in:
Major Hayden 2022-05-04 13:53:48 -05:00 committed by Major Hayden
parent 5b16857123
commit 0be87d10a7
No known key found for this signature in database
GPG Key ID: 737051E0C1011FB1
4 changed files with 7 additions and 64 deletions

1
.gitignore vendored
View File

@ -5,3 +5,4 @@
/pynacl-1.2.1.tar.gz
/pynacl-1.3.0.tar.gz
/pynacl-1.4.0.tar.gz
/pynacl-1.5.0.tar.gz

View File

@ -1,58 +0,0 @@
From 1a14a865a27467914be183f5465c29b36fd27f88 Mon Sep 17 00:00:00 2001
From: Scott Kitterman <scott@kitterman.com>
Date: Tue, 26 May 2020 17:03:17 -0400
Subject: [PATCH 1/2] Remove spurious requirement for wheel
---
pyproject.toml | 1 -
setup.py | 3 +--
2 files changed, 1 insertion(+), 3 deletions(-)
diff --git a/pyproject.toml b/pyproject.toml
index ed437acd..94baf50c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,7 +2,6 @@
# Must be kept in sync with `setup_requirements` in `setup.py`
requires = [
"setuptools>=40.8.0",
- "wheel",
"cffi>=1.4.1; python_implementation != 'PyPy'",
]
build-backend = "setuptools.build_meta"
diff --git a/setup.py b/setup.py
index 9319c1cb..d82a7fe3 100644
--- a/setup.py
+++ b/setup.py
@@ -35,8 +35,7 @@
requirements = ["six"]
-setup_requirements = ["setuptools",
- "wheel"]
+setup_requirements = ["setuptools"]
test_requirements = ["pytest>=3.2.1,!=3.3.0",
"hypothesis>=3.27.0"]
docs_requirements = ["sphinx>=1.6.5",
From 5eb5f1e70580a386d9a95b74eda1a54af13f5e3a Mon Sep 17 00:00:00 2001
From: Scott Kitterman <scott@kitterman.com>
Date: Tue, 26 May 2020 18:44:33 -0400
Subject: [PATCH 2/2] Put wheel back in pyproject.toml
---
pyproject.toml | 1 +
1 file changed, 1 insertion(+)
diff --git a/pyproject.toml b/pyproject.toml
index 94baf50c..ed437acd 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,6 +2,7 @@
# Must be kept in sync with `setup_requirements` in `setup.py`
requires = [
"setuptools>=40.8.0",
+ "wheel",
"cffi>=1.4.1; python_implementation != 'PyPy'",
]
build-backend = "setuptools.build_meta"

View File

@ -3,17 +3,14 @@
%global modname pynacl
Name: python-%{modname}
Version: 1.4.0
Release: 8%{?dist}
Version: 1.5.0
Release: 1%{?dist}
Summary: Python binding to the Networking and Cryptography (NaCl) library
License: ASL 2.0
URL: https://github.com/pyca/pynacl
Source0: %{url}/archive/%{version}/%{modname}-%{version}.tar.gz
# remove spurious wheel dependency
Patch1: %{url}/pull/596.patch
BuildRequires: gcc
BuildRequires: libsodium-devel
@ -66,6 +63,9 @@ export SODIUM_INSTALL=system
%doc README.rst
%changelog
* Wed Aug 31 2022 Major Hayden <major@mhtx.net> - 1.5.0-1
- Update to 1.5.0 (#2038614)
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (pynacl-1.4.0.tar.gz) = 2a11a623452cea60199cdff83db6f5922698237267c11f055f2fd7768e0875a819dcc08c477113ad89461797ab36d66e0b9c7700eee335eb6b16af6b378b9e88
SHA512 (pynacl-1.5.0.tar.gz) = 905d3a7ce7f758b31a5d34471d5a0202fd2ba3d904a7ec59a158bcd1ea572fc87e29fc144c733d151cbaa48788c939808bc51d00acc973fe6d190eefdd3bfd59