python-psycopg3/python-psycopg3-3.0.16-setup.patch
Ondřej Sloup a932804c79 Rebase to the latest upstream version
Create patch files instead of sed
Fix release numbering
2022-08-04 10:30:16 +02:00

28 lines
1.1 KiB
Diff

diff -ur 3.0.16_original/psycopg-3.0.16/psycopg/setup.py 3.0.16/psycopg-3.0.16/psycopg/setup.py
--- 3.0.16_original/psycopg-3.0.16/psycopg/setup.py 2022-08-04 09:58:06.504188489 +0200
+++ 3.0.16/psycopg-3.0.16/psycopg/setup.py 2022-08-04 09:58:18.283216078 +0200
@@ -38,20 +38,17 @@
# Requirements to run the test suite
"test": [
"mypy >= 0.920, != 0.930, != 0.931",
- "pproxy >= 2.7",
- "pytest >= 6.2.5",
+ "pytest",
# 0.16 is still needed to support Python 3.6.
# Only pinned in Psycopg 3.0.x as Psycopg 3.1.x is Py >= 3.7 only.
# - 0.17 requires asyncio_mode in config or it fails with a warning.
# - 0.16 fails if asyncio_mode is in the config.
- "pytest-asyncio >= 0.16, < 0.17",
- "pytest-cov >= 3.0",
- "pytest-randomly >= 3.10",
+ "pytest-asyncio",
+ "pytest-randomly",
],
# Requirements needed for development
"dev": [
"black >= 22.3.0",
- "dnspython >= 2.1",
"flake8 >= 4.0",
"mypy >= 0.920, != 0.930, != 0.931",
"types-setuptools >= 57.4",