Update to latest version (#2053921)

This commit is contained in:
Elliott Sales de Andrade 2022-02-13 05:34:50 -05:00
parent 025989fe78
commit dfafc72dbb
4 changed files with 29 additions and 2 deletions

1
.gitignore vendored
View File

@ -79,3 +79,4 @@
/pikepdf-4.1.0.tar.gz
/pikepdf-4.2.0.tar.gz
/pikepdf-4.4.1.tar.gz
/pikepdf-4.5.0.tar.gz

23
308.patch Normal file
View File

@ -0,0 +1,23 @@
From e88eb19afd67c3696535205bf417fd99562ac0c8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
Date: Sun, 13 Feb 2022 10:18:10 +0100
Subject: [PATCH] docs: Fix typo in TOML loading
Reported by @QuLogic, thanks!
---
docs/conf.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/docs/conf.py b/docs/conf.py
index 88bcda05..602e2038 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -107,7 +107,7 @@ def pip(*args):
templates_path = ['_templates']
with open('../pyproject.toml', 'rb') as f:
- pyproject_toml = toml.load(f)
+ pyproject_toml = tomli.load(f)
toml_env = pyproject_toml['tool']['cibuildwheel']['environment']
rst_prolog = f"""

View File

@ -1,13 +1,16 @@
%global srcname pikepdf
Name: python-%{srcname}
Version: 4.4.1
Version: 4.5.0
Release: %autorelease
Summary: Read and write PDFs with Python, powered by qpdf
License: MPLv2.0
URL: https://github.com/pikepdf/pikepdf
Source0: %pypi_source
# docs: Fix typo in TOML loading
Patch0001: https://github.com/pikepdf/pikepdf/pull/308.patch
BuildRequires: gcc-c++
BuildRequires: qpdf-devel >= 10.3.2
BuildRequires: python3-devel

View File

@ -1 +1 @@
SHA512 (pikepdf-4.4.1.tar.gz) = 1df75b48c5f7b63238d6923ff8ac9e4511794d314be1f92ee2f0284d21a814554e900857f6d31dbdb5bcc13f5c4a03f4dc2d59b618fa737b1bcf4b016fa311b4
SHA512 (pikepdf-4.5.0.tar.gz) = 34bc80a459713261827d7d5f7ecfb75f7864404d13f13cf03e9ddc5fbd09b437288430221af6df4b68621a24d302d3c63d9140a5da957334ecb053d03a407e69