Update to latest version (#2055603)

This commit is contained in:
Elliott Sales de Andrade 2022-03-21 18:45:01 -04:00
parent dfafc72dbb
commit 00cbe6a931
4 changed files with 4 additions and 31 deletions

1
.gitignore vendored
View File

@ -80,3 +80,4 @@
/pikepdf-4.2.0.tar.gz
/pikepdf-4.4.1.tar.gz
/pikepdf-4.5.0.tar.gz
/pikepdf-5.1.0.tar.gz

View File

@ -1,23 +0,0 @@
From e88eb19afd67c3696535205bf417fd99562ac0c8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
Date: Sun, 13 Feb 2022 10:18:10 +0100
Subject: [PATCH] docs: Fix typo in TOML loading
Reported by @QuLogic, thanks!
---
docs/conf.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/docs/conf.py b/docs/conf.py
index 88bcda05..602e2038 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -107,7 +107,7 @@ def pip(*args):
templates_path = ['_templates']
with open('../pyproject.toml', 'rb') as f:
- pyproject_toml = toml.load(f)
+ pyproject_toml = tomli.load(f)
toml_env = pyproject_toml['tool']['cibuildwheel']['environment']
rst_prolog = f"""

View File

@ -1,18 +1,16 @@
%global srcname pikepdf
Name: python-%{srcname}
Version: 4.5.0
Version: 5.1.0
Release: %autorelease
Summary: Read and write PDFs with Python, powered by qpdf
License: MPLv2.0
URL: https://github.com/pikepdf/pikepdf
Source0: %pypi_source
# docs: Fix typo in TOML loading
Patch0001: https://github.com/pikepdf/pikepdf/pull/308.patch
BuildRequires: gcc-c++
BuildRequires: qpdf-devel >= 10.3.2
BuildRequires: qpdf-devel >= 10.6.2
BuildRequires: python3-devel
# Tests:
BuildRequires: poppler-utils
@ -43,9 +41,6 @@ Documentation for pikepdf
%prep
%autosetup -n %{srcname}-%{version} -p1
# Allow new pybind11
sed -i -e '/pybind11/s/, <= 2.8.0//' pyproject.toml
# Drop coverage requirements
sed -i -e '/coverage/d' -e '/pytest-cov/d' setup.cfg

View File

@ -1 +1 @@
SHA512 (pikepdf-4.5.0.tar.gz) = 34bc80a459713261827d7d5f7ecfb75f7864404d13f13cf03e9ddc5fbd09b437288430221af6df4b68621a24d302d3c63d9140a5da957334ecb053d03a407e69
SHA512 (pikepdf-5.1.0.tar.gz) = 5ac2be4ba958a5697ff07b6789f2322334ebbfcb5a186a98e0c51346902c5057543e2f5071649cdc35521b18ec9f59d3c559fdf63e2bc9a1ec5120192066a76d