python-matplotlib/matplotlib-0.87.7-tkagg-che...

23 lines
719 B
Diff

--- matplotlib-0.87.7/setup.py.fix 2006-11-20 19:49:56.000000000 -0900
+++ matplotlib-0.87.7/setup.py 2006-11-20 19:51:03.000000000 -0900
@@ -251,16 +251,9 @@
print 'Tkinter present but import failed'
BUILD_TKAGG = 0
else:
- try:
- tk = Tkinter.Tk()
- tk.withdraw()
- except Tkinter.TclError:
- print 'Tkinter present, but window failed to open'
- BUILD_TKAGG = 0
- else:
- BUILD_AGG = 1
- build_tkagg(ext_modules, packages, NUMERIX)
- rc['backend'] = 'TkAgg'
+ BUILD_AGG = 1
+ build_tkagg(ext_modules, packages, NUMERIX)
+ rc['backend'] = 'TkAgg'
if BUILD_WXAGG:
try: