35 lines
1.0 KiB
Diff
35 lines
1.0 KiB
Diff
diff -up matplotlib-1.5.1/setupext.py.six matplotlib-1.5.1/setupext.py
|
|
--- matplotlib-1.5.1/setupext.py.six 2016-01-10 23:20:20.000000000 +0100
|
|
+++ matplotlib-1.5.1/setupext.py 2016-05-18 13:44:21.534494158 +0200
|
|
@@ -1026,6 +1026,18 @@ class Qhull(SetupPackage):
|
|
ext.sources.extend(glob.glob('extern/qhull/*.c'))
|
|
|
|
|
|
+class Six(SetupPackage):
|
|
+ name = "six"
|
|
+
|
|
+ def check(self):
|
|
+ try:
|
|
+ import six
|
|
+ except ImportError:
|
|
+ return 'not found. pip may install it below.'
|
|
+
|
|
+ return 'version %s' % six.__version__
|
|
+
|
|
+
|
|
class TTConv(SetupPackage):
|
|
name = "ttconv"
|
|
|
|
diff -up matplotlib-1.5.1/setup.py.six matplotlib-1.5.1/setup.py
|
|
--- matplotlib-1.5.1/setup.py.six 2016-01-10 23:20:20.000000000 +0100
|
|
+++ matplotlib-1.5.1/setup.py 2016-05-18 13:44:21.528494040 +0200
|
|
@@ -84,7 +84,7 @@ mpl_packages = [
|
|
setupext.Delaunay(),
|
|
setupext.QhullWrap(),
|
|
setupext.Tri(),
|
|
- setupext.Externals(),
|
|
+ setupext.Six(),
|
|
'Optional subpackages',
|
|
setupext.SampleData(),
|
|
setupext.Toolkits(),
|