Remove outdated patches.
This commit is contained in:
parent
68a10c0be2
commit
e9a5a6f0c0
@ -1,20 +0,0 @@
|
|||||||
diff -up matplotlib-2.0.0b3/lib/matplotlib/sphinxext/tests/test_tinypages.py.tests matplotlib-2.0.0b3/lib/matplotlib/sphinxext/tests/test_tinypages.py
|
|
||||||
--- matplotlib-2.0.0b3/lib/matplotlib/sphinxext/tests/test_tinypages.py.tests 2016-07-17 01:04:11.000000000 +0200
|
|
||||||
+++ matplotlib-2.0.0b3/lib/matplotlib/sphinxext/tests/test_tinypages.py 2016-08-29 13:41:47.661198880 +0200
|
|
||||||
@@ -1,6 +1,7 @@
|
|
||||||
""" Tests for tinypages build using sphinx extensions """
|
|
||||||
|
|
||||||
import shutil
|
|
||||||
+import sys
|
|
||||||
import tempfile
|
|
||||||
|
|
||||||
from os.path import (join as pjoin, dirname, isdir)
|
|
||||||
@@ -16,6 +17,8 @@ TINY_PAGES = pjoin(HERE, 'tinypages')
|
|
||||||
|
|
||||||
def setup():
|
|
||||||
# Check we have the sphinx-build command
|
|
||||||
+ if sys.version_info[0] >= 3:
|
|
||||||
+ raise SkipTest('sphinx-build works only with python 2.x')
|
|
||||||
try:
|
|
||||||
ret = call(['sphinx-build', '--help'], stdout=PIPE, stderr=PIPE)
|
|
||||||
except OSError:
|
|
@ -1,33 +0,0 @@
|
|||||||
--- setupext.py.orig 2013-08-02 09:39:43.914247832 +0200
|
|
||||||
+++ setupext.py 2013-08-02 09:40:14.785304342 +0200
|
|
||||||
@@ -914,28 +914,13 @@ class LibAgg(SetupPackage):
|
|
||||||
self.__class__.found_external = True
|
|
||||||
try:
|
|
||||||
return self._check_for_pkg_config(
|
|
||||||
- 'libagg', 'agg2/agg_basics.h', min_version='PATCH')
|
|
||||||
+ 'libagg', 'agg2/agg_basics.h', min_version='2.5.0')
|
|
||||||
except CheckFailed as e:
|
|
||||||
self.__class__.found_external = False
|
|
||||||
return str(e) + ' Using local copy.'
|
|
||||||
|
|
||||||
def add_flags(self, ext):
|
|
||||||
- if self.found_external:
|
|
||||||
- pkg_config.setup_extension(ext, 'libagg')
|
|
||||||
- else:
|
|
||||||
- ext.include_dirs.append('extern/agg24/include')
|
|
||||||
- agg_sources = [
|
|
||||||
- 'agg_bezier_arc.cpp',
|
|
||||||
- 'agg_curves.cpp',
|
|
||||||
- 'agg_image_filters.cpp',
|
|
||||||
- 'agg_trans_affine.cpp',
|
|
||||||
- 'agg_vcgen_contour.cpp',
|
|
||||||
- 'agg_vcgen_dash.cpp',
|
|
||||||
- 'agg_vcgen_stroke.cpp',
|
|
||||||
- 'agg_vpgen_segmentator.cpp'
|
|
||||||
- ]
|
|
||||||
- ext.sources.extend(
|
|
||||||
- os.path.join('extern', 'agg24', 'src', x) for x in agg_sources)
|
|
||||||
+ pkg_config.setup_extension(ext, 'libagg', default_include_dirs=["/usr/include/agg2"])
|
|
||||||
|
|
||||||
|
|
||||||
class FreeType(SetupPackage):
|
|
@ -1,34 +0,0 @@
|
|||||||
diff -up matplotlib-1.5.1/setupext.py.six matplotlib-1.5.1/setupext.py
|
|
||||||
--- matplotlib-1.5.1/setupext.py.six 2016-01-10 23:20:20.000000000 +0100
|
|
||||||
+++ matplotlib-1.5.1/setupext.py 2016-05-18 13:44:21.534494158 +0200
|
|
||||||
@@ -1026,6 +1026,18 @@ class Qhull(SetupPackage):
|
|
||||||
ext.sources.extend(glob.glob('extern/qhull/*.c'))
|
|
||||||
|
|
||||||
|
|
||||||
+class Six(SetupPackage):
|
|
||||||
+ name = "six"
|
|
||||||
+
|
|
||||||
+ def check(self):
|
|
||||||
+ try:
|
|
||||||
+ import six
|
|
||||||
+ except ImportError:
|
|
||||||
+ return 'not found. pip may install it below.'
|
|
||||||
+
|
|
||||||
+ return 'version %s' % six.__version__
|
|
||||||
+
|
|
||||||
+
|
|
||||||
class TTConv(SetupPackage):
|
|
||||||
name = "ttconv"
|
|
||||||
|
|
||||||
diff -up matplotlib-1.5.1/setup.py.six matplotlib-1.5.1/setup.py
|
|
||||||
--- matplotlib-1.5.1/setup.py.six 2016-01-10 23:20:20.000000000 +0100
|
|
||||||
+++ matplotlib-1.5.1/setup.py 2016-05-18 13:44:21.528494040 +0200
|
|
||||||
@@ -84,7 +84,7 @@ mpl_packages = [
|
|
||||||
setupext.Delaunay(),
|
|
||||||
setupext.QhullWrap(),
|
|
||||||
setupext.Tri(),
|
|
||||||
- setupext.Externals(),
|
|
||||||
+ setupext.Six(),
|
|
||||||
'Optional subpackages',
|
|
||||||
setupext.SampleData(),
|
|
||||||
setupext.Toolkits(),
|
|
@ -424,10 +424,6 @@ sed -i 's/\(USE_FONTCONFIG = \)False/\1True/' lib/matplotlib/font_manager.py
|
|||||||
%patch13 -p1 -b .tests-i686
|
%patch13 -p1 -b .tests-i686
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
chmod -x lib/matplotlib/mpl-data/images/*.svg
|
|
||||||
chmod -x lib/matplotlib/{dates,sankey}.py
|
|
||||||
chmod -x lib/mpl_toolkits/mplot3d/*.py
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export http_proxy=http://127.0.0.1/
|
export http_proxy=http://127.0.0.1/
|
||||||
MPLCONFIGDIR=$PWD \
|
MPLCONFIGDIR=$PWD \
|
||||||
|
Loading…
Reference in New Issue
Block a user