Update to latest version.

This commit is contained in:
Elliott Sales de Andrade 2020-06-20 03:06:07 -04:00
parent 3fa499ba45
commit bea895839b
4 changed files with 19 additions and 13 deletions

2
.gitignore vendored
View File

@ -47,3 +47,5 @@ matplotlib-1.0.0-without-gpc.tar.gz
/matplotlib-3.2.0.tar.gz
/matplotlib-3.2.0-with-freetype-2.10.1.tar.gz
/matplotlib-3.2.1.tar.gz
/matplotlib-3.2.2.tar.gz
/matplotlib-3.2.2-with-freetype-2.10.1.tar.gz

View File

@ -1,4 +1,4 @@
From 0ffab3ff58bee5346b9443a8b769d9786aba3b26 Mon Sep 17 00:00:00 2001
From a3fec73e39558f1a8d41663fe05783889e735af4 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sat, 2 Mar 2019 18:18:29 -0500
Subject: [PATCH] Use packaged jquery and jquery-ui.
@ -7,8 +7,8 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
.../backends/web_backend/all_figures.html | 6 +--
.../backends/web_backend/single_figure.html | 6 +--
setup.py | 53 -------------------
3 files changed, 6 insertions(+), 59 deletions(-)
setup.py | 54 -------------------
3 files changed, 6 insertions(+), 60 deletions(-)
diff --git a/lib/matplotlib/backends/web_backend/all_figures.html b/lib/matplotlib/backends/web_backend/all_figures.html
index 41f48dc6d..69097eb4f 100644
@ -45,10 +45,10 @@ index 4d5a366fb..c11c86618 100644
<script src="{{ prefix }}/js/mpl.js"></script>
<script>
diff --git a/setup.py b/setup.py
index 760e84af1..2b184749f 100644
index bf03159fb..81c2f96d7 100644
--- a/setup.py
+++ b/setup.py
@@ -26,8 +26,6 @@ from zipfile import ZipFile
@@ -28,8 +28,6 @@ from zipfile import ZipFile
from setuptools import setup, find_packages, Extension
from setuptools.command.build_ext import build_ext as BuildExtCommand
@ -57,7 +57,7 @@ index 760e84af1..2b184749f 100644
from setuptools.command.test import test as TestCommand
# The setuptools version of sdist adds a setup.cfg file to the tree.
@@ -115,57 +113,6 @@ cmdclass['test'] = NoopTestCommand
@@ -120,58 +118,6 @@ cmdclass['test'] = NoopTestCommand
cmdclass['build_ext'] = BuildExtraLibraries
@ -79,8 +79,9 @@ index 760e84af1..2b184749f 100644
- try:
- buff = download_or_cache(url, sha)
- except Exception:
- raise IOError(f"Failed to download jquery-ui. Please download "
- f"{url} and extract it to {dest}.")
- raise IOError(
- "Failed to download jquery-ui. Please download "
- "{url} and extract it to {dest}.".format(url=url, dest=dest))
- with ZipFile(buff) as zf:
- zf.extractall(dest)
-
@ -116,5 +117,5 @@ index 760e84af1..2b184749f 100644
# however, this is needed on Windows to avoid creating infinite subprocesses
# when using multiprocessing.
--
2.21.0
2.25.4

View File

@ -37,13 +37,13 @@
#global rctag rc2
# Updated test images for new FreeType.
%global mpl_images_version 3.2.0
%global mpl_images_version 3.2.2
# The version of FreeType in this Fedora branch.
%global ftver 2.10.1
Name: python-matplotlib
Version: 3.2.1
Version: 3.2.2
Release: 1%{?rctag:.%{rctag}}%{?dist}
Summary: Python 2D plotting library
# qt4_editor backend is MIT
@ -429,6 +429,9 @@ PYTHONDONTWRITEBYTECODE=1 \
%changelog
* Sat Jun 20 2020 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 3.2.2-1
- Update to latest version
* Wed Mar 18 2020 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 3.2.1-1
- Update to latest version

View File

@ -1,2 +1,2 @@
SHA512 (matplotlib-3.2.1.tar.gz) = 2725ebb2e3665f3f110354efab6a6ec20721667acbaf1dc22a9396dbdca096edaabe79b0e602970b1c0769a5eb849cd815774af00a366f3d4e2f336bce06208e
SHA512 (matplotlib-3.2.0-with-freetype-2.10.1.tar.gz) = 5fefa148dae612b431bbf1430f93df20f3cfc06f01db072148893bf067f1fab5c9944575a3d1a587fe7d44b17fb755f4532bf61dfdb7fc64b2fd7821f9fa12ac
SHA512 (matplotlib-3.2.2.tar.gz) = 4c9312e929357a7c73ead51fa1a679c04b2b9735edfe0f1a2d08a07ec4d94d67df4ff6e8c6d594665a3b270cd3033c48ea8f2aa50fb1e2746812f24c27181f59
SHA512 (matplotlib-3.2.2-with-freetype-2.10.1.tar.gz) = 498fb1224f74c5254e3a2620d4d36571ed712a7ac261bcb4b2a548ea57d6b7431634dfad547b529d6fa1a3fab90e6b489150afe815485a3030d1e899edfd9be8