Update to 0.90.1

This commit is contained in:
Orion Poplawski 2007-06-04 17:35:30 +00:00
parent 32df714ed8
commit bb617decf4
6 changed files with 64 additions and 57 deletions

View File

@ -1 +1 @@
matplotlib-0.90.0.tar.gz
matplotlib-0.90.1.tar.gz

View File

@ -1,25 +0,0 @@
--- matplotlib-0.87.7/setup.py.pygtk 2006-12-05 11:13:58.000000000 -0700
+++ matplotlib-0.87.7/setup.py 2006-12-05 11:31:22.000000000 -0700
@@ -207,8 +207,9 @@
print 'GTK requires pygtk'
BUILD_GTK = 0
except RuntimeError:
- print 'pygtk present but import failed'
- BUILD_GTK = 0
+ BUILD_GTK = 1
+ build_gdk(ext_modules, packages, NUMERIX)
+ rc['backend'] = 'GTK'
else:
version = (2,2,0)
if gtk.pygtk_version < version:
@@ -228,7 +229,9 @@
BUILD_GTKAGG=0
except RuntimeError:
print 'pygtk present but import failed'
- BUILD_GTKAGG = 0
+ BUILD_GTKAGG = 1
+ build_gtkagg(ext_modules, packages, NUMERIX)
+ rc['backend'] = 'GTKAgg'
else:
version = (2,2,0)
if gtk.pygtk_version < version:

View File

@ -1,22 +0,0 @@
--- matplotlib-0.87.7/setup.py.fix 2006-11-20 19:49:56.000000000 -0900
+++ matplotlib-0.87.7/setup.py 2006-11-20 19:51:03.000000000 -0900
@@ -251,16 +251,9 @@
print 'Tkinter present but import failed'
BUILD_TKAGG = 0
else:
- try:
- tk = Tkinter.Tk()
- tk.withdraw()
- except Tkinter.TclError:
- print 'Tkinter present, but window failed to open'
- BUILD_TKAGG = 0
- else:
- BUILD_AGG = 1
- build_tkagg(ext_modules, packages, NUMERIX)
- rc['backend'] = 'TkAgg'
+ BUILD_AGG = 1
+ build_tkagg(ext_modules, packages, NUMERIX)
+ rc['backend'] = 'TkAgg'
if BUILD_WXAGG:
try:

View File

@ -0,0 +1,53 @@
--- matplotlib-0.90.1/setup.py.tkagg 2007-06-04 10:34:46.000000000 -0600
+++ matplotlib-0.90.1/setup.py 2007-06-04 10:54:44.000000000 -0600
@@ -28,13 +28,13 @@
# it. It makes very nice antialiased output and also supports alpha
# blending
BUILD_AGG = 1
-BUILD_GTKAGG = 'auto'
-BUILD_GTK = 'auto'
+BUILD_GTKAGG = 1
+BUILD_GTK = 1
# build TK GUI with Agg renderer ; requires Tkinter Python extension
# and Tk includes
# Use False or 0 if you don't want to build
-BUILD_TKAGG = 'auto'
+BUILD_TKAGG = 1
# build wxPython extension code to efficiently blit agg into wx. Only
# needed for wxpython <2.8 if you plan on doing animations
@@ -226,11 +226,11 @@
havegtk.gotit = None
-if BUILD_GTK and havegtk():
+if BUILD_GTK:
build_gdk(ext_modules, packages, NUMERIX)
rc['backend'] = 'GTK'
-if BUILD_GTKAGG and havegtk():
+if BUILD_GTKAGG:
BUILD_AGG = 1
build_gtkagg(ext_modules, packages, NUMERIX)
rc['backend'] = 'GTKAgg'
@@ -245,16 +245,9 @@
print 'Tkinter present but import failed'
BUILD_TKAGG = 0
else:
- try:
- tk = Tkinter.Tk()
- tk.withdraw()
- except Tkinter.TclError:
- print 'Tkinter present, but window failed to open'
- BUILD_TKAGG = 0
- else:
- BUILD_AGG = 1
- build_tkagg(ext_modules, packages, NUMERIX)
- rc['backend'] = 'TkAgg'
+ BUILD_AGG = 1
+ build_tkagg(ext_modules, packages, NUMERIX)
+ rc['backend'] = 'TkAgg'
if BUILD_WXAGG:
try:

View File

@ -1,17 +1,16 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Name: python-matplotlib
Version: 0.90.0
Release: 3%{?dist}
Version: 0.90.1
Release: 1%{?dist}
Summary: Python plotting library
Group: Development/Libraries
License: Python Software Foundation License
URL: http://sourceforge.net/projects/matplotlib
Source0: http://dl.sf.net/matplotlib/matplotlib-%{version}.tar.gz
Source0: http://downloads.sourceforge.net/matplotlib/matplotlib-%{version}.tar.gz
Patch0: matplotlib-0.87.7-matplotlibrc.patch
Patch1: matplotlib-0.87.7-tkagg-check.patch
Patch2: matplotlib-0.87.7-pygtk-check.patch
Patch1: matplotlib-0.90.1-setup.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python-devel, freetype-devel, libpng-devel, zlib-devel
@ -41,9 +40,8 @@ Requires: tkinter
%prep
%setup -q -n matplotlib-%{version}
%patch0 -p1 -b .matplotlibrc
%patch1 -p1 -b .tkagg
%patch2 -p1 -b .pygtk
chmod -x images/*.svg
%patch1 -p1 -b .setup
chmod -x lib/matplotlib/mpl-data/images/*.svg
%build
%{__python} setup.py build
@ -75,6 +73,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Mon Jun 04 2007 Orion Poplawski <orion@cora.nwra.com> 0.90.1-1
- Update to 0.90.1
* Wed Feb 14 2007 Orion Poplawski <orion@cora.nwra.com> 0.90.0-2
- Rebuild for Tcl/Tk downgrade

View File

@ -1 +1 @@
31ea12395826080b5be9c1e292cda6f1 matplotlib-0.90.0.tar.gz
e1344bd72660e7c9c0b7540a72cc45b8 matplotlib-0.90.1.tar.gz