Update to latest version (#2273293)
This commit is contained in:
parent
1d44751f59
commit
97d2c5437b
1
.gitignore
vendored
1
.gitignore
vendored
@ -107,3 +107,4 @@ matplotlib-1.0.0-without-gpc.tar.gz
|
||||
/matplotlib-3.8.2.tar.gz
|
||||
/matplotlib-3.8.3.tar.gz
|
||||
/matplotlib-3.8.3-with-freetype-2.13.1.tar.gz
|
||||
/matplotlib-3.8.4.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a035d73964343cbba0daad79b9349153a51af56a Mon Sep 17 00:00:00 2001
|
||||
From ce0e47a95ec43750080afa889b35ec26106a6a47 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Wed, 27 Sep 2017 19:35:59 -0400
|
||||
Subject: [PATCH 1/5] matplotlibrc path search fix
|
||||
@ -39,5 +39,5 @@ index 353406832c..26dd9372e1 100644
|
||||
|
||||
for fname in gen_candidates():
|
||||
--
|
||||
2.41.0
|
||||
2.43.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 789bb69a3175c6ecc03449128d72cac63522d98f Mon Sep 17 00:00:00 2001
|
||||
From 05484ecf85b7f9ca67da454a4147098023626a81 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Fri, 11 Aug 2023 02:36:06 -0400
|
||||
Subject: [PATCH 2/5] Unpin NumPy build requirement
|
||||
@ -9,22 +9,33 @@ run against a version different from the one it was built against.
|
||||
|
||||
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
---
|
||||
pyproject.toml | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
pyproject.toml | 13 +------------
|
||||
1 file changed, 1 insertion(+), 12 deletions(-)
|
||||
|
||||
diff --git a/pyproject.toml b/pyproject.toml
|
||||
index 7131609c63..e76ec736d7 100644
|
||||
index 44f56d8cc1..33ce124527 100644
|
||||
--- a/pyproject.toml
|
||||
+++ b/pyproject.toml
|
||||
@@ -2,7 +2,7 @@
|
||||
build-backend = "setuptools.build_meta"
|
||||
requires = [
|
||||
"certifi>=2020.06.20",
|
||||
- "numpy>=1.25",
|
||||
+ "numpy",
|
||||
@@ -5,18 +5,7 @@ requires = [
|
||||
"pybind11>=2.6",
|
||||
"setuptools>=64",
|
||||
"setuptools_scm>=7",
|
||||
-
|
||||
- # Comments on numpy build requirement range:
|
||||
- #
|
||||
- # 1. >=2.0.x is the numpy requirement for wheel builds for distribution
|
||||
- # on PyPI - building against 2.x yields wheels that are also
|
||||
- # ABI-compatible with numpy 1.x at runtime.
|
||||
- # 2. Note that building against numpy 1.x works fine too - users and
|
||||
- # redistributors can do this by installing the numpy version they like
|
||||
- # and disabling build isolation.
|
||||
- # 3. The <2.3 upper bound is for matching the numpy deprecation policy,
|
||||
- # it should not be loosened.
|
||||
- "numpy>=2.0.0rc1,<2.3",
|
||||
+ "numpy",
|
||||
]
|
||||
|
||||
[tool.setuptools_scm]
|
||||
--
|
||||
2.41.0
|
||||
2.43.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From a5490ca593e1515bddbc96491efd8d1ff5e372d6 Mon Sep 17 00:00:00 2001
|
||||
From 1bbba2045f0722ccd97513037d49f2f656e349df Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Fri, 14 Feb 2020 06:05:42 -0500
|
||||
Subject: [PATCH 3/5] Set FreeType version to 2.13.1 and update tolerances
|
||||
@ -29,10 +29,10 @@ index 26dd9372e1..81b77d455f 100644
|
||||
from matplotlib import ft2font
|
||||
if (ft2font.__freetype_version__ != LOCAL_FREETYPE_VERSION or
|
||||
diff --git a/lib/matplotlib/tests/test_axes.py b/lib/matplotlib/tests/test_axes.py
|
||||
index 6c5dd712b7..0a70c37891 100644
|
||||
index 0372747009..9cee2dbd41 100644
|
||||
--- a/lib/matplotlib/tests/test_axes.py
|
||||
+++ b/lib/matplotlib/tests/test_axes.py
|
||||
@@ -7623,7 +7623,7 @@ def test_normal_axes():
|
||||
@@ -7642,7 +7642,7 @@ def test_normal_axes():
|
||||
]
|
||||
for nn, b in enumerate(bbaxis):
|
||||
targetbb = mtransforms.Bbox.from_bounds(*target[nn])
|
||||
@ -41,7 +41,7 @@ index 6c5dd712b7..0a70c37891 100644
|
||||
|
||||
target = [
|
||||
[150.0, 119.999, 930.0, 11.111],
|
||||
@@ -7641,7 +7641,7 @@ def test_normal_axes():
|
||||
@@ -7660,7 +7660,7 @@ def test_normal_axes():
|
||||
|
||||
target = [85.5138, 75.88888, 1021.11, 1017.11]
|
||||
targetbb = mtransforms.Bbox.from_bounds(*target)
|
||||
@ -51,7 +51,7 @@ index 6c5dd712b7..0a70c37891 100644
|
||||
# test that get_position roundtrips to get_window_extent
|
||||
axbb = ax.get_position().transformed(fig.transFigure).bounds
|
||||
diff --git a/lib/matplotlib/tests/test_backend_pgf.py b/lib/matplotlib/tests/test_backend_pgf.py
|
||||
index a866916c58..a746cc2ca9 100644
|
||||
index 8a83515f16..26bc9d6c48 100644
|
||||
--- a/lib/matplotlib/tests/test_backend_pgf.py
|
||||
+++ b/lib/matplotlib/tests/test_backend_pgf.py
|
||||
@@ -165,7 +165,7 @@ def test_pathclip():
|
||||
@ -118,7 +118,7 @@ index 759ac6aada..8140d4d69f 100644
|
||||
|
||||
@image_comparison(['legend_stackplot.png'])
|
||||
diff --git a/lib/matplotlib/tests/test_polar.py b/lib/matplotlib/tests/test_polar.py
|
||||
index 9d6e78da2c..5f6ed538d1 100644
|
||||
index 9a1c6be6fc..7df88e96b4 100644
|
||||
--- a/lib/matplotlib/tests/test_polar.py
|
||||
+++ b/lib/matplotlib/tests/test_polar.py
|
||||
@@ -321,7 +321,7 @@ def test_get_tightbbox_polar():
|
||||
@ -198,5 +198,5 @@ index 9f78d88c87..6dc740e8f7 100644
|
||||
def do_custom_build(self, env):
|
||||
# We're using a system freetype
|
||||
--
|
||||
2.41.0
|
||||
2.43.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 88d4c6305161338ecb1f095c92ad7c6920ac5697 Mon Sep 17 00:00:00 2001
|
||||
From 59c900f49d605c1300c4bdaef23c94ad32a07e29 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Mon, 22 Aug 2022 18:43:28 -0400
|
||||
Subject: [PATCH 4/5] Use old stride_windows implementation on 32-bit x86
|
||||
@ -80,5 +80,5 @@ index 1948e6333e..158417a1c0 100644
|
||||
resultY = resultY * window.reshape((-1, 1))
|
||||
resultY = np.fft.fft(resultY, n=pad_to, axis=0)[:numFreqs, :]
|
||||
--
|
||||
2.41.0
|
||||
2.43.0
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From c3b9e1f09d8b061db4810640afb4b92f0cc25aaf Mon Sep 17 00:00:00 2001
|
||||
From f6edb2b275f8fb4daa047df0b12008eac53306f0 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Fri, 11 Aug 2023 05:13:38 -0400
|
||||
Subject: [PATCH 5/5] TST: Increase some tolerances for non-x86 arches
|
||||
@ -9,10 +9,10 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/mpl_toolkits/mplot3d/tests/test_axes3d.py b/lib/mpl_toolkits/mplot3d/tests/test_axes3d.py
|
||||
index 9cebc8a33e..080f17ac81 100644
|
||||
index b3fcffcc6e..f400312859 100644
|
||||
--- a/lib/mpl_toolkits/mplot3d/tests/test_axes3d.py
|
||||
+++ b/lib/mpl_toolkits/mplot3d/tests/test_axes3d.py
|
||||
@@ -2249,7 +2249,7 @@ def test_scatter_masked_color():
|
||||
@@ -2264,7 +2264,7 @@ def test_scatter_masked_color():
|
||||
len(super(type(path3d), path3d).get_facecolors())
|
||||
|
||||
|
||||
@ -22,5 +22,5 @@ index 9cebc8a33e..080f17ac81 100644
|
||||
fig = plt.figure()
|
||||
ax = fig.add_subplot(projection='3d')
|
||||
--
|
||||
2.41.0
|
||||
2.43.0
|
||||
|
||||
|
@ -36,7 +36,7 @@
|
||||
%global ftver 2.13.1
|
||||
|
||||
Name: python-matplotlib
|
||||
Version: 3.8.3
|
||||
Version: 3.8.4
|
||||
%global Version %{version_no_tilde %{quote:%nil}}
|
||||
Release: %autorelease
|
||||
Summary: Python 2D plotting library
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (matplotlib-3.8.3.tar.gz) = 457d1d62b76752938a24780c697461949de00d779df55df122d789f9ebef154edda037f2a804241880a0b442c5fa8139b8ab13054898b8e08fd17a56bdc23312
|
||||
SHA512 (matplotlib-3.8.4.tar.gz) = d4c6a5b3484927dbae1b1203e9984b67d08c958c4a5136abaa805f1eb221146fb1211e5f20456e281d41fc09c94917a796ffacfdb185c58eeeb6d19e60c78b1a
|
||||
SHA512 (matplotlib-3.8.3-with-freetype-2.13.1.tar.gz) = 72b207fac6539cf9e64706cbd61be4bf2349be8d5f66083db1f014cdbdf049c48f2ce17a67ac0e646f668818cff6ffa9053fc31f2c2f4bc3f8e9f70272146d8f
|
||||
|
Loading…
Reference in New Issue
Block a user