2016-11-20: Retired orphaned package, because it was orphaned for

more than six weeks.
This commit is contained in:
Till Maas 2016-11-20 11:15:02 +01:00
parent b655eaf82c
commit 4956ab1103
8 changed files with 3 additions and 431 deletions

1
.gitignore vendored
View File

@ -1 +0,0 @@
matplotlib-0.99.1.2.tar.gz

3
dead.package Normal file
View File

@ -0,0 +1,3 @@
2016-11-20: Retired orphaned package, because it was orphaned for
more than six weeks.

View File

@ -1,13 +0,0 @@
--- matplotlib-0.87/setup.py.orig 2006-02-14 11:11:32.000000000 -0700
+++ matplotlib-0.87/setup.py 2006-02-27 15:19:28.000000000 -0700
@@ -258,8 +258,8 @@
# packagers: set rc['numerix'] and rc['backend'] here to override the auto
# defaults, eg
-#rc['numerix'] = numpy
-#rc['backend'] = GTKAgg
+rc['numerix'] = 'numpy'
+rc['backend'] = 'GTKAgg'
if sys.platform=='win32':
rc = dict(backend='TkAgg', numerix='Numeric')
template = file('matplotlibrc.template').read()

View File

@ -1,53 +0,0 @@
--- matplotlib-0.90.1/setup.py.tkagg 2007-06-04 10:34:46.000000000 -0600
+++ matplotlib-0.90.1/setup.py 2007-06-04 10:54:44.000000000 -0600
@@ -28,13 +28,13 @@
# it. It makes very nice antialiased output and also supports alpha
# blending
BUILD_AGG = 1
-BUILD_GTKAGG = 'auto'
-BUILD_GTK = 'auto'
+BUILD_GTKAGG = 1
+BUILD_GTK = 1
# build TK GUI with Agg renderer ; requires Tkinter Python extension
# and Tk includes
# Use False or 0 if you don't want to build
-BUILD_TKAGG = 'auto'
+BUILD_TKAGG = 1
# build wxPython extension code to efficiently blit agg into wx. Only
# needed for wxpython <2.8 if you plan on doing animations
@@ -226,11 +226,11 @@
havegtk.gotit = None
-if BUILD_GTK and havegtk():
+if BUILD_GTK:
build_gdk(ext_modules, packages, NUMERIX)
rc['backend'] = 'GTK'
-if BUILD_GTKAGG and havegtk():
+if BUILD_GTKAGG:
BUILD_AGG = 1
build_gtkagg(ext_modules, packages, NUMERIX)
rc['backend'] = 'GTKAgg'
@@ -245,16 +245,9 @@
print 'Tkinter present but import failed'
BUILD_TKAGG = 0
else:
- try:
- tk = Tkinter.Tk()
- tk.withdraw()
- except Tkinter.TclError:
- print 'Tkinter present, but window failed to open'
- BUILD_TKAGG = 0
- else:
- BUILD_AGG = 1
- build_tkagg(ext_modules, packages, NUMERIX)
- rc['backend'] = 'TkAgg'
+ BUILD_AGG = 1
+ build_tkagg(ext_modules, packages, NUMERIX)
+ rc['backend'] = 'TkAgg'
if BUILD_WXAGG:
try:

View File

@ -1,63 +0,0 @@
diff -u -r matplotlib-0.91.2-old/ttconv/pprdrv.h matplotlib-0.91.2/ttconv/pprdrv.h
--- matplotlib-0.91.2-old/ttconv/pprdrv.h 2007-11-29 17:36:53.000000000 -0900
+++ matplotlib-0.91.2/ttconv/pprdrv.h 2008-03-21 13:58:01.000000000 -0800
@@ -20,7 +20,7 @@
*/
#include <vector>
-#include <assert.h>
+#include <cassert>
/*
* Encapsulates all of the output to write to an arbitrary output
diff -u -r matplotlib-0.91.2-old/ttconv/pprdrv_tt2.cpp matplotlib-0.91.2/ttconv/pprdrv_tt2.cpp
--- matplotlib-0.91.2-old/ttconv/pprdrv_tt2.cpp 2007-11-29 17:36:53.000000000 -0900
+++ matplotlib-0.91.2/ttconv/pprdrv_tt2.cpp 2008-03-21 16:04:49.000000000 -0800
@@ -31,10 +31,11 @@
*/
#include "global_defines.h"
-#include <math.h>
-#include <stdlib.h>
-#include <string.h>
-#include <memory.h>
+#include <cmath>
+#include <cstdlib>
+#include <cstdio>
+#include <cstring>
+#include <memory>
#include "pprdrv.h"
#include "truetype.h"
#include <algorithm>
diff -u -r matplotlib-0.91.2-old/ttconv/pprdrv_tt.cpp matplotlib-0.91.2/ttconv/pprdrv_tt.cpp
--- matplotlib-0.91.2-old/ttconv/pprdrv_tt.cpp 2007-11-29 17:36:53.000000000 -0900
+++ matplotlib-0.91.2/ttconv/pprdrv_tt.cpp 2008-03-21 15:57:42.000000000 -0800
@@ -23,9 +23,9 @@
*/
#include "global_defines.h"
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
+#include <cstdio>
+#include <cstdlib>
+#include <cstring>
#include "pprdrv.h"
#include "truetype.h"
#include <sstream>
diff -u -r matplotlib-0.91.2-old/ttconv/ttutil.cpp matplotlib-0.91.2/ttconv/ttutil.cpp
--- matplotlib-0.91.2-old/ttconv/ttutil.cpp 2007-11-29 17:36:53.000000000 -0900
+++ matplotlib-0.91.2/ttconv/ttutil.cpp 2008-03-24 11:25:06.000000000 -0800
@@ -8,9 +8,9 @@
/* (c) Frank Siegert 1996 */
#include "global_defines.h"
-#include <stdio.h>
-#include <stdarg.h>
-#include <stdlib.h>
+#include <cstdio>
+#include <cstdarg>
+#include <cstdlib>
#include "pprdrv.h"
#if DEBUG_TRUETYPE

View File

@ -1,219 +0,0 @@
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Name: python-matplotlib
Version: 0.99.1.2
Release: 1%{?dist}
Summary: Python plotting library
Group: Development/Libraries
License: Python
URL: http://sourceforge.net/projects/matplotlib
Source0: http://downloads.sourceforge.net/matplotlib/matplotlib-%{version}.tar.gz
Source1: setup.cfg
Patch0: matplotlib-gcc43.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python-devel, freetype-devel, libpng-devel, zlib-devel
BuildRequires: pygtk2-devel, gtk2-devel, tkinter, tk-devel
BuildRequires: pytz, python-dateutil, numpy
Requires: numpy, pytz, python-dateutil
Requires: pycairo >= 1.2.0
#Requires: dejavu-fonts
%description
Matplotlib is a pure python plotting library with the goal of making
publication quality plots using a syntax familiar to matlab users. The
library uses Numeric for handling large data sets and supports a variety
of output backends
%package tk
Summary: Tk backend for python-matplotlib
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: tkinter
%description tk
%{summary}
%prep
#%setup -q -n matplotlib-%{version}
%setup -q -n matplotlib-0.99.1.1
#%patch0 -p1
chmod -x lib/matplotlib/mpl-data/images/*.svg
%build
cp %{SOURCE1} ./setup.cfg
%{__python} setup.py build
%install
rm -rf $RPM_BUILD_ROOT
%{__python} setup.py install -O1 --skip-build --root=$RPM_BUILD_ROOT
chmod +x $RPM_BUILD_ROOT%{python_sitearch}/matplotlib/dates.py
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root,-)
%doc README.txt license/LICENSE license/LICENSE_enthought.txt
%doc license/LICENSE_PAINT license/LICENSE_PIL
%doc CHANGELOG CXX INSTALL INTERACTIVE KNOWN_BUGS
%doc PKG-INFO TODO examples
%if 0%{?fedora} >= 9
%{python_sitearch}/*egg-info
%endif
%{python_sitearch}/matplotlib/
%{python_sitearch}/mpl_toolkits/
%{python_sitearch}/pylab.py*
%exclude %{python_sitearch}/matplotlib/backends/backend_tkagg.*
%exclude %{python_sitearch}/matplotlib/backends/tkagg.*
%exclude %{python_sitearch}/matplotlib/backends/_tkagg.so
%files tk
%{python_sitearch}/matplotlib/backends/backend_tkagg.py*
%{python_sitearch}/matplotlib/backends/tkagg.py*
%{python_sitearch}/matplotlib/backends/_tkagg.so
%changelog
* Mon Feb 22 2010 Orion Poplawski <orion@cora.nwra.com> - 0.99.1.2
- Update to 0.99.1.2
* Tue May 26 2009 Jef Spaleta <jspaleta AT fedoraproject DOT org> - 0.98.5-3
- Latest upstream release
- Updated to work with numpy update see EPEL bug 502082
- Be aware that some internal matplotlib APIs have changed
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.98.3-2
- Rebuild for Python 2.6
* Wed Aug 6 2008 Jef Spaleta <jspaleta AT fedoraproject DOT org> - 0.98.3-1
- Latest upstream release
* Fri Jul 1 2008 Jef Spaleta <jspaleta AT fedoraproject DOT org> - 0.98.1-1
- Latest upstream release
* Fri Mar 21 2008 Jef Spaleta <jspaleta[AT]fedoraproject org> - 0.91.2-2
- gcc43 cleanups
* Fri Mar 21 2008 Jef Spaleta <jspaleta[AT]fedoraproject org> - 0.91.2-1
- New upstream version
- Adding Fedora specific setup.cfg from included template
- removed numarry and numerics build requirements
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.90.1-6
- Autorebuild for GCC 4.3
* Fri Jan 4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.90.1-5
- Fixed typo in spec.
* Fri Jan 4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.90.1-4
- Support for Python Eggs for F9+
* Thu Jan 3 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.90.1-3
- Rebuild for new Tcl 8.5
* Thu Aug 23 2007 Orion Poplawski <orion@cora.nwra.com> 0.90.1-2
- Update license tag to Python
- Rebuild for BuildID
* Mon Jun 04 2007 Orion Poplawski <orion@cora.nwra.com> 0.90.1-1
- Update to 0.90.1
* Wed Feb 14 2007 Orion Poplawski <orion@cora.nwra.com> 0.90.0-2
- Rebuild for Tcl/Tk downgrade
* Sat Feb 10 2007 Jef Spaleta <jspaleta@gmail.com> 0.90.0-2
- Release bump for rebuild against new tk
* Fri Feb 09 2007 Orion Poplawski <orion@cora.nwra.com> 0.90.0-1
- Update to 0.90.0
* Tue Jan 5 2007 Orion Poplawski <orion@cora.nwra.com> 0.87.7-4
- Add examples to %docs
* Mon Dec 11 2006 Jef Spaleta <jspaleta@gmail.com> 0.87.7-3
- Release bump for rebuild against python 2.5 in devel tree
* Tue Dec 5 2006 Orion Poplawski <orion@cora.nwra.com> 0.87.7-2
- Force build of gtk/gtkagg backends in mock (bug #218153)
- Change Requires from python-numeric to numpy (bug #218154)
* Tue Nov 21 2006 Orion Poplawski <orion@cora.nwra.com> 0.87.7-1
- Update to 0.87.7 and fix up the defaults to use numpy
- Force build of tkagg backend without X server
- Use src.rpm from Jef Spaleta, closes bug 216578
* Fri Oct 6 2006 Orion Poplawski <orion@cora.nwra.com> 0.87.6-1
- Update to 0.87.6
* Thu Sep 7 2006 Orion Poplawski <orion@cora.nwra.com> 0.87.5-1
- Update to 0.87.5
* Thu Jul 27 2006 Orion Poplawski <orion@cora.nwra.com> 0.87.4-1
- Update to 0.87.4
* Wed Jun 7 2006 Orion Poplawski <orion@cora.nwra.com> 0.87.3-1
- Update to 0.87.3
* Mon May 15 2006 Orion Poplawski <orion@cora.nwra.com> 0.87.2-2
- Rebuild for new numpy
* Tue Mar 7 2006 Orion Poplawski <orion@cora.nwra.com> 0.87.2-1
- Update to 0.87.2
* Tue Mar 7 2006 Orion Poplawski <orion@cora.nwra.com> 0.87.1-1
- Update to 0.87.1
- Add pycairo >= 1.0.2 requires (FC5+ only)
* Fri Feb 24 2006 Orion Poplawski <orion@cora.nwra.com> 0.87-1
- Update to 0.87
- Add BR numpy and python-numarray
- Add patch to keep Numeric as the default numerix package
- Add BR tkinter and tk-devel for TkInter backend
- Make separate package for Tk backend
* Tue Jan 10 2006 Orion Poplawski <orion@cora.nwra.com> 0.86-1
- Update to 0.86
* Thu Dec 22 2005 Orion Poplawski <orion@cora.nwra.com> 0.85-2
- Rebuild
* Sun Nov 20 2005 Orion Poplawski <orion@cora.nwra.com> 0.85-1
- New upstream version 0.85
* Mon Sep 19 2005 Orion Poplawski <orion@cora.nwra.com> 0.84-1
- New upstream version 0.84
* Tue Aug 02 2005 Orion Poplawski <orion@cora.nwra.com> 0.83.2-3
- bump release
* Tue Aug 02 2005 Orion Poplawski <orion@cora.nwra.com> 0.83.2-2
- Add Requires: python-numeric, pytz, python-dateutil
* Fri Jul 29 2005 Orion Poplawski <orion@cora.nwra.com> 0.83.2-1
- New upstream version matplotlib 0.83.2
* Thu Jul 28 2005 Orion Poplawski <orion@cora.nwra.com> 0.83.1-2
- Bump rel to fix botched tag
* Thu Jul 28 2005 Orion Poplawski <orion@cora.nwra.com> 0.83.1-1
- New upstream version matplotlib 0.83.1
* Tue Jul 05 2005 Orion Poplawski <orion@cora.nwra.com> 0.82-4
- BuildRequires: pytz, python-dateutil - use upstream
- Don't use INSTALLED_FILES, list dirs
- Fix execute permissions
* Fri Jul 01 2005 Orion Poplawski <orion@cora.nwra.com> 0.82-3
- Use %%{python_sitearch}
* Thu Jun 30 2005 Orion Poplawski <orion@cora.nwra.com> 0.82-2
- Rename to python-matplotlib
- Remove unneeded Requires: python
- Add private directories to %files
* Tue Jun 28 2005 Orion Poplawski <orion@cora.nwra.com> 0.82-1
- Initial package for Fedora Extras

View File

@ -1,81 +0,0 @@
# Rename this file to setup.cfg to modify matplotlib's
# build options.
[egg_info]
tag_svn_revision = 1
[status]
# To suppress display of the dependencies and their versions
# at the top of the build log, uncomment the following line:
#suppress = True
#
# Uncomment to insert lots of diagnostic prints in extension code
#verbose = True
[provide_packages]
# By default, matplotlib checks for a few dependencies and
# installs them if missing. This feature can be turned off
# by uncommenting the following lines. Acceptible values are:
# True: install, overwrite an existing installation
# False: do not install
# auto: install only if the package is unavailable. This
# is the default behavior
#
## Date/timezone support:
#pytz = False
#dateutil = False
#
## Experimental config package support:
enthought.traits = False
configobj = False
[gui_support]
# Matplotlib supports multiple GUI toolkits, including Cocoa,
# GTK, Fltk, Qt, Qt4, Tk, and WX. Support for many of these
# toolkits requires AGG, the Anti-Grain Geometry library, which
# is provided by matplotlib and built by default.
#
# Some backends are written in pure Python, and others require
# extension code to be compiled. By default, matplotlib checks
# for these GUI toolkits during installation and, if present,
# compiles the required extensions to support the toolkit. GTK
# support requires the GTK runtime environment and PyGTK. Wx
# support requires wxWidgets and wxPython. Tk support requires
# Tk and Tkinter. The other GUI toolkits do not require any
# extension code, and can be used as long as the libraries are
# installed on your system.
#
# You can uncomment any the following lines if you know you do
# not want to use the GUI toolkit. Acceptible values are:
# True: build the extension. Exits with a warning if the
# required dependencies are not available
# False: do not build the extension
# auto: build if the required dependencies are available,
# otherwise skip silently. This is the default
# behavior
#
gtk = True
gtkagg = True
tkagg = True
wxagg = False
[rc_options]
# User-configurable options
#
# Default backend, one of: Agg, Cairo, CocoaAgg, GTK, GTKAgg,
# GTKCairo, FltkAgg, Pdf, Ps, QtAgg, Qt4Agg, SVG, TkAgg, WX, WXAgg.
#
# The Agg, Ps, Pdf and SVG backends do not require external
# dependencies. Do not choose GTK, GTKAgg, GTKCairo, TkAgg or WXAgg if
# you have disabled the relevent extension modules. Agg will be used
# by default.
#
backend = GTKAgg
#
# The numerix module was historically used to provide
# compatibility between the Numeric, numarray, and NumPy array
# packages. Now that NumPy has emerge as the universal array
# package for python, numerix is not really necessary and is
# maintained to provide backward compatibility. Do not change
# this unless you have a compelling reason to do so.
numerix = numpy

View File

@ -1 +0,0 @@
952e2c992e4a762b8538171f51c9140a matplotlib-0.99.1.2.tar.gz