Update to 3.1.2.

This commit is contained in:
Elliott Sales de Andrade 2019-11-22 20:10:32 -05:00
parent c533793071
commit 1f37c6ab3a
12 changed files with 151 additions and 156 deletions

1
.gitignore vendored
View File

@ -41,3 +41,4 @@ matplotlib-1.0.0-without-gpc.tar.gz
/matplotlib-3.1.0-with-freetype-2.10.0.tar.gz
/matplotlib-3.1.1.tar.gz
/matplotlib-3.1.1-with-freetype-2.10.0.tar.gz
/matplotlib-3.1.2.tar.gz

View File

@ -0,0 +1,36 @@
From f0dbd8d7b76ac217df3641d03997b393c476d77c Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Wed, 20 Nov 2019 15:58:04 -0500
Subject: [PATCH] Fix env override in WebAgg backend test.
It's only necessary to override DISPLAY, not throw away the rest of the
environment. Without the other environment variables, stuff like custom
PYTHONPATH break in this test.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
lib/matplotlib/tests/test_backend_webagg.py | 8 +++-----
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/lib/matplotlib/tests/test_backend_webagg.py b/lib/matplotlib/tests/test_backend_webagg.py
index 220670aa4..997c36a3a 100644
--- a/lib/matplotlib/tests/test_backend_webagg.py
+++ b/lib/matplotlib/tests/test_backend_webagg.py
@@ -8,11 +8,9 @@ import pytest
def test_webagg_fallback(backend):
if backend == "nbagg":
pytest.importorskip("IPython")
- env = {}
- if os.name == "nt":
- env = dict(os.environ)
- else:
- env = {"DISPLAY": ""}
+ env = dict(os.environ)
+ if os.name != "nt":
+ env["DISPLAY"] = ""
env["MPLBACKEND"] = backend
--
2.21.0

View File

@ -0,0 +1,25 @@
From 5c714fede82e29bd42a3a6f20ec2898a9c37a0ed Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Fri, 22 Nov 2019 19:50:20 -0500
Subject: [PATCH] Skip webagg test if tornado is not available.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
lib/matplotlib/tests/test_backend_webagg.py | 1 +
1 file changed, 1 insertion(+)
diff --git a/lib/matplotlib/tests/test_backend_webagg.py b/lib/matplotlib/tests/test_backend_webagg.py
index 997c36a3a..5c6ddfa25 100644
--- a/lib/matplotlib/tests/test_backend_webagg.py
+++ b/lib/matplotlib/tests/test_backend_webagg.py
@@ -6,6 +6,7 @@ import pytest
@pytest.mark.parametrize("backend", ["webagg", "nbagg"])
def test_webagg_fallback(backend):
+ pytest.importorskip("tornado")
if backend == "nbagg":
pytest.importorskip("IPython")
env = dict(os.environ)
--
2.21.0

View File

@ -1,14 +1,14 @@
From a587261dcf6821dd03e1956cc1644a3a7aaa4031 Mon Sep 17 00:00:00 2001
From c2af74bf18d46d03ec34bfda32afe1a99511ac9f Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sat, 2 Mar 2019 18:18:29 -0500
Subject: [PATCH] Use packaged jquery and jquery-ui.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
.../backends/web_backend/all_figures.html | 6 +--
.../backends/web_backend/single_figure.html | 6 +--
setup.py | 46 -------------------
3 files changed, 6 insertions(+), 52 deletions(-)
.../backends/web_backend/all_figures.html | 6 +-
.../backends/web_backend/single_figure.html | 6 +-
setup.py | 56 -------------------
3 files changed, 6 insertions(+), 62 deletions(-)
diff --git a/lib/matplotlib/backends/web_backend/all_figures.html b/lib/matplotlib/backends/web_backend/all_figures.html
index 41f48dc6d..69097eb4f 100644
@ -45,10 +45,10 @@ index 4d5a366fb..c11c86618 100644
<script src="{{ prefix }}/js/mpl.js"></script>
<script>
diff --git a/setup.py b/setup.py
index d5ff91c43..a2b82f692 100644
index adabf1753..57d6b91b4 100644
--- a/setup.py
+++ b/setup.py
@@ -26,8 +26,6 @@ from zipfile import ZipFile
@@ -27,8 +27,6 @@ from zipfile import ZipFile
from setuptools import setup, Extension
from setuptools.command.build_ext import build_ext as BuildExtCommand
@ -57,11 +57,21 @@ index d5ff91c43..a2b82f692 100644
from setuptools.command.test import test as TestCommand
# The setuptools version of sdist adds a setup.cfg file to the tree.
@@ -123,50 +121,6 @@ cmdclass['test'] = NoopTestCommand
@@ -124,60 +122,6 @@ cmdclass['test'] = NoopTestCommand
cmdclass['build_ext'] = BuildExtraLibraries
-def _download_jquery_to(dest):
- if os.path.exists(os.path.join(dest, "jquery-ui-1.12.1")):
- return
-
- # If we are installing from an sdist, use the already downloaded jquery-ui
- sdist_src = os.path.join(
- "lib/matplotlib/backends/web_backend", "jquery-ui-1.12.1")
- if os.path.exists(sdist_src):
- shutil.copytree(sdist_src, os.path.join(dest, "jquery-ui-1.12.1"))
- return
-
- # Note: When bumping the jquery-ui version, also update the versions in
- # single_figure.html and all_figures.html.
- url = "https://jqueryui.com/resources/download/jquery-ui-1.12.1.zip"

View File

@ -1,4 +1,4 @@
From c11c024a8355b542101c4ed2089919e1a95cbaed Mon Sep 17 00:00:00 2001
From 7a2146f4de31667bf977ba11598078f76beaf89c Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Wed, 27 Sep 2017 19:35:59 -0400
Subject: [PATCH 1/4] matplotlibrc path search fix
@ -10,10 +10,10 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
2 files changed, 16 insertions(+), 21 deletions(-)
diff --git a/lib/matplotlib/__init__.py b/lib/matplotlib/__init__.py
index 350d4c554..66f60a4f9 100644
index 825303171..7a4115491 100644
--- a/lib/matplotlib/__init__.py
+++ b/lib/matplotlib/__init__.py
@@ -623,18 +623,8 @@ def _get_data_path():
@@ -624,18 +624,8 @@ def _get_data_path():
return path
def get_candidate_paths():
@ -34,7 +34,7 @@ index 350d4c554..66f60a4f9 100644
for path in get_candidate_paths():
if path.is_dir():
@@ -677,8 +667,7 @@ def matplotlib_fname():
@@ -678,8 +668,7 @@ def matplotlib_fname():
is not defined)
- On other platforms,
- ``$HOME/.matplotlib/matplotlibrc`` if ``$HOME`` is defined
@ -44,7 +44,7 @@ index 350d4c554..66f60a4f9 100644
"""
def gen_candidates():
@@ -691,7 +680,7 @@ def matplotlib_fname():
@@ -692,7 +681,7 @@ def matplotlib_fname():
yield matplotlibrc
yield os.path.join(matplotlibrc, 'matplotlibrc')
yield os.path.join(get_configdir(), 'matplotlibrc')
@ -54,7 +54,7 @@ index 350d4c554..66f60a4f9 100644
for fname in gen_candidates():
if os.path.exists(fname) and not os.path.isdir(fname):
diff --git a/lib/matplotlib/tests/test_rcparams.py b/lib/matplotlib/tests/test_rcparams.py
index 123ffe4ae..b5a490855 100644
index d8fe73ceb..c3aeb58ef 100644
--- a/lib/matplotlib/tests/test_rcparams.py
+++ b/lib/matplotlib/tests/test_rcparams.py
@@ -1,6 +1,7 @@
@ -65,7 +65,7 @@ index 123ffe4ae..b5a490855 100644
from unittest import mock
import warnings
@@ -436,11 +437,17 @@ def test_rcparams_reset_after_fail():
@@ -457,11 +458,17 @@ def test_rcparams_reset_after_fail():
assert mpl.rcParams['text.usetex'] is False
@ -86,7 +86,7 @@ index 123ffe4ae..b5a490855 100644
rclines = f.readlines()
missing = {}
for k, v in mpl.defaultParams.items():
@@ -463,11 +470,10 @@ def test_if_rctemplate_is_up_to_date():
@@ -484,11 +491,10 @@ def test_if_rctemplate_is_up_to_date():
.format(missing.items()))

View File

@ -1,21 +1,22 @@
From 567818c8afbb758626d2f4c5d2abbcd960f4c5a9 Mon Sep 17 00:00:00 2001
From 53e911c1eb6b840036acfd6b630439bc55b4bdca Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sat, 4 May 2019 04:36:45 -0400
Subject: [PATCH 2/4] Set FreeType version to 2.10.0 and update tolerances.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
lib/matplotlib/__init__.py | 2 +-
lib/matplotlib/tests/test_axes.py | 6 +++---
lib/matplotlib/tests/test_tightlayout.py | 10 +++++-----
setupext.py | 5 ++++-
4 files changed, 13 insertions(+), 10 deletions(-)
lib/matplotlib/__init__.py | 2 +-
lib/matplotlib/tests/test_axes.py | 6 +++---
lib/matplotlib/tests/test_constrainedlayout.py | 2 +-
lib/matplotlib/tests/test_tightlayout.py | 10 +++++-----
setupext.py | 5 ++++-
5 files changed, 14 insertions(+), 11 deletions(-)
diff --git a/lib/matplotlib/__init__.py b/lib/matplotlib/__init__.py
index 66f60a4f9..ba5bb8e72 100644
index 7a4115491..1bf9d3e03 100644
--- a/lib/matplotlib/__init__.py
+++ b/lib/matplotlib/__init__.py
@@ -1363,7 +1363,7 @@ def _init_tests():
@@ -1361,7 +1361,7 @@ def _init_tests():
# The version of FreeType to install locally for running the
# tests. This must match the value in `setupext.py`
@ -25,10 +26,10 @@ index 66f60a4f9..ba5bb8e72 100644
from matplotlib import ft2font
if (ft2font.__freetype_version__ != LOCAL_FREETYPE_VERSION or
diff --git a/lib/matplotlib/tests/test_axes.py b/lib/matplotlib/tests/test_axes.py
index 3ffcde798..1168ef983 100644
index 8ff5ac45d..25f5695f3 100644
--- a/lib/matplotlib/tests/test_axes.py
+++ b/lib/matplotlib/tests/test_axes.py
@@ -6184,7 +6184,7 @@ def test_normal_axes():
@@ -6198,7 +6198,7 @@ def test_normal_axes():
]
for nn, b in enumerate(bbaxis):
targetbb = mtransforms.Bbox.from_bounds(*target[nn])
@ -37,7 +38,7 @@ index 3ffcde798..1168ef983 100644
target = [
[150.0, 119.999, 930.0, 11.111],
@@ -6202,7 +6202,7 @@ def test_normal_axes():
@@ -6216,7 +6216,7 @@ def test_normal_axes():
target = [85.5138, 75.88888, 1021.11, 1017.11]
targetbb = mtransforms.Bbox.from_bounds(*target)
@ -46,7 +47,7 @@ index 3ffcde798..1168ef983 100644
# test that get_position roundtrips to get_window_extent
axbb = ax.get_position().transformed(fig.transFigure).bounds
@@ -6327,7 +6327,7 @@ def test_get_tightbbox_polar():
@@ -6341,7 +6341,7 @@ def test_get_tightbbox_polar():
fig.canvas.draw()
bb = ax.get_tightbbox(fig.canvas.get_renderer())
assert_allclose(bb.extents,
@ -55,6 +56,16 @@ index 3ffcde798..1168ef983 100644
@check_figures_equal(extensions=["png"])
diff --git a/lib/matplotlib/tests/test_constrainedlayout.py b/lib/matplotlib/tests/test_constrainedlayout.py
index 8769fcec3..e9ae292f6 100644
--- a/lib/matplotlib/tests/test_constrainedlayout.py
+++ b/lib/matplotlib/tests/test_constrainedlayout.py
@@ -416,4 +416,4 @@ def test_hidden_axes():
extents1 = np.copy(axs[0, 0].get_position().extents)
np.testing.assert_allclose(extents1,
- [0.045552, 0.548288, 0.47319, 0.982638], rtol=1e-5)
+ [0.045552, 0.548288, 0.47319, 0.982638], rtol=1e-2)
diff --git a/lib/matplotlib/tests/test_tightlayout.py b/lib/matplotlib/tests/test_tightlayout.py
index 0b9469cb8..7963b82ff 100644
--- a/lib/matplotlib/tests/test_tightlayout.py

View File

@ -1,4 +1,4 @@
From 64f6b21fba56fc6baeb0171873e9d77d35b73eb6 Mon Sep 17 00:00:00 2001
From b3b02bdfe6db629bc68a87a472b5f88d988bf5f2 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Tue, 23 Jan 2018 20:27:17 -0500
Subject: [PATCH 3/4] Increase tolerances for non-x86_64 arches.
@ -23,10 +23,10 @@ index a712680cd..6007c9b9a 100644
def test_masks_and_nans():
X, Y, U, V = velocity_field()
diff --git a/lib/mpl_toolkits/tests/test_axes_grid1.py b/lib/mpl_toolkits/tests/test_axes_grid1.py
index fef2ebc21..75b35d0b7 100644
index 95b1ae5a3..e054196b4 100644
--- a/lib/mpl_toolkits/tests/test_axes_grid1.py
+++ b/lib/mpl_toolkits/tests/test_axes_grid1.py
@@ -361,7 +361,7 @@ def test_zooming_with_inverted_axes():
@@ -362,7 +362,7 @@ def test_zooming_with_inverted_axes():
@image_comparison(baseline_images=['anchored_direction_arrows'],

View File

@ -1,4 +1,4 @@
From 953aea628b7a3d956949aa6ef38b9634b3a57021 Mon Sep 17 00:00:00 2001
From fb6a3a64fe6f5b314c1c54bbef745b78ee512417 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sat, 31 Mar 2018 00:15:14 -0400
Subject: [PATCH 4/4] Increase some tolerances for 32-bit systems.
@ -57,7 +57,7 @@ index 9bf15d0b9..5339dd2eb 100644
exterior = mpath.Path.unit_rectangle().deepcopy()
exterior.vertices *= 4
diff --git a/lib/matplotlib/tests/test_axes.py b/lib/matplotlib/tests/test_axes.py
index 1168ef983..038b7fd98 100644
index 25f5695f3..f6ddc4e95 100644
--- a/lib/matplotlib/tests/test_axes.py
+++ b/lib/matplotlib/tests/test_axes.py
@@ -562,7 +562,7 @@ def test_single_point():
@ -107,7 +107,7 @@ index 1168ef983..038b7fd98 100644
def test_arc_angles():
from matplotlib import patches
# Ellipse parameters
@@ -2627,7 +2629,7 @@ def test_boxplot_mod_artist_after_plotting():
@@ -2635,7 +2637,7 @@ def test_boxplot_mod_artist_after_plotting():
@image_comparison(baseline_images=['violinplot_vert_baseline',
'violinplot_vert_baseline'],
@ -116,7 +116,7 @@ index 1168ef983..038b7fd98 100644
def test_vert_violinplot_baseline():
# First 9 digits of frac(sqrt(2))
np.random.seed(414213562)
@@ -2645,7 +2647,7 @@ def test_vert_violinplot_baseline():
@@ -2653,7 +2655,7 @@ def test_vert_violinplot_baseline():
@image_comparison(baseline_images=['violinplot_vert_showmeans'],
@ -125,7 +125,7 @@ index 1168ef983..038b7fd98 100644
def test_vert_violinplot_showmeans():
ax = plt.axes()
# First 9 digits of frac(sqrt(3))
@@ -2656,7 +2658,7 @@ def test_vert_violinplot_showmeans():
@@ -2664,7 +2666,7 @@ def test_vert_violinplot_showmeans():
@image_comparison(baseline_images=['violinplot_vert_showextrema'],
@ -134,7 +134,7 @@ index 1168ef983..038b7fd98 100644
def test_vert_violinplot_showextrema():
ax = plt.axes()
# First 9 digits of frac(sqrt(5))
@@ -2667,7 +2669,7 @@ def test_vert_violinplot_showextrema():
@@ -2675,7 +2677,7 @@ def test_vert_violinplot_showextrema():
@image_comparison(baseline_images=['violinplot_vert_showmedians'],
@ -143,7 +143,7 @@ index 1168ef983..038b7fd98 100644
def test_vert_violinplot_showmedians():
ax = plt.axes()
# First 9 digits of frac(sqrt(7))
@@ -2678,7 +2680,7 @@ def test_vert_violinplot_showmedians():
@@ -2686,7 +2688,7 @@ def test_vert_violinplot_showmedians():
@image_comparison(baseline_images=['violinplot_vert_showall'],
@ -152,7 +152,7 @@ index 1168ef983..038b7fd98 100644
def test_vert_violinplot_showall():
ax = plt.axes()
# First 9 digits of frac(sqrt(11))
@@ -2689,7 +2691,7 @@ def test_vert_violinplot_showall():
@@ -2697,7 +2699,7 @@ def test_vert_violinplot_showall():
@image_comparison(baseline_images=['violinplot_vert_custompoints_10'],
@ -161,7 +161,7 @@ index 1168ef983..038b7fd98 100644
def test_vert_violinplot_custompoints_10():
ax = plt.axes()
# First 9 digits of frac(sqrt(13))
@@ -2700,7 +2702,7 @@ def test_vert_violinplot_custompoints_10():
@@ -2708,7 +2710,7 @@ def test_vert_violinplot_custompoints_10():
@image_comparison(baseline_images=['violinplot_vert_custompoints_200'],
@ -170,7 +170,7 @@ index 1168ef983..038b7fd98 100644
def test_vert_violinplot_custompoints_200():
ax = plt.axes()
# First 9 digits of frac(sqrt(17))
@@ -2711,7 +2713,7 @@ def test_vert_violinplot_custompoints_200():
@@ -2719,7 +2721,7 @@ def test_vert_violinplot_custompoints_200():
@image_comparison(baseline_images=['violinplot_horiz_baseline'],
@ -179,7 +179,7 @@ index 1168ef983..038b7fd98 100644
def test_horiz_violinplot_baseline():
ax = plt.axes()
# First 9 digits of frac(sqrt(19))
@@ -2722,7 +2724,7 @@ def test_horiz_violinplot_baseline():
@@ -2730,7 +2732,7 @@ def test_horiz_violinplot_baseline():
@image_comparison(baseline_images=['violinplot_horiz_showmedians'],
@ -188,7 +188,7 @@ index 1168ef983..038b7fd98 100644
def test_horiz_violinplot_showmedians():
ax = plt.axes()
# First 9 digits of frac(sqrt(23))
@@ -2733,7 +2735,7 @@ def test_horiz_violinplot_showmedians():
@@ -2741,7 +2743,7 @@ def test_horiz_violinplot_showmedians():
@image_comparison(baseline_images=['violinplot_horiz_showmeans'],
@ -197,7 +197,7 @@ index 1168ef983..038b7fd98 100644
def test_horiz_violinplot_showmeans():
ax = plt.axes()
# First 9 digits of frac(sqrt(29))
@@ -2744,7 +2746,7 @@ def test_horiz_violinplot_showmeans():
@@ -2752,7 +2754,7 @@ def test_horiz_violinplot_showmeans():
@image_comparison(baseline_images=['violinplot_horiz_showextrema'],
@ -206,7 +206,7 @@ index 1168ef983..038b7fd98 100644
def test_horiz_violinplot_showextrema():
ax = plt.axes()
# First 9 digits of frac(sqrt(31))
@@ -2755,7 +2757,7 @@ def test_horiz_violinplot_showextrema():
@@ -2763,7 +2765,7 @@ def test_horiz_violinplot_showextrema():
@image_comparison(baseline_images=['violinplot_horiz_showall'],
@ -215,7 +215,7 @@ index 1168ef983..038b7fd98 100644
def test_horiz_violinplot_showall():
ax = plt.axes()
# First 9 digits of frac(sqrt(37))
@@ -2766,7 +2768,7 @@ def test_horiz_violinplot_showall():
@@ -2774,7 +2776,7 @@ def test_horiz_violinplot_showall():
@image_comparison(baseline_images=['violinplot_horiz_custompoints_10'],
@ -224,7 +224,7 @@ index 1168ef983..038b7fd98 100644
def test_horiz_violinplot_custompoints_10():
ax = plt.axes()
# First 9 digits of frac(sqrt(41))
@@ -2777,7 +2779,7 @@ def test_horiz_violinplot_custompoints_10():
@@ -2785,7 +2787,7 @@ def test_horiz_violinplot_custompoints_10():
@image_comparison(baseline_images=['violinplot_horiz_custompoints_200'],
@ -233,7 +233,7 @@ index 1168ef983..038b7fd98 100644
def test_horiz_violinplot_custompoints_200():
ax = plt.axes()
# First 9 digits of frac(sqrt(43))
@@ -3501,8 +3503,7 @@ def test_vertex_markers():
@@ -3509,8 +3511,7 @@ def test_vertex_markers():
@image_comparison(baseline_images=['vline_hline_zorder',
@ -243,7 +243,7 @@ index 1168ef983..038b7fd98 100644
def test_eb_line_zorder():
x = list(range(10))
@@ -4182,7 +4183,7 @@ def test_psd_noise():
@@ -4190,7 +4191,7 @@ def test_psd_noise():
@image_comparison(baseline_images=['csd_freqs'], remove_text=True,
@ -252,7 +252,7 @@ index 1168ef983..038b7fd98 100644
def test_csd_freqs():
'''test axes.csd with sinusoidal stimuli'''
n = 10000
@@ -5100,7 +5101,7 @@ def test_rc_spines():
@@ -5108,7 +5109,7 @@ def test_rc_spines():
@image_comparison(baseline_images=['rc_grid'], extensions=['png'],
@ -261,7 +261,7 @@ index 1168ef983..038b7fd98 100644
def test_rc_grid():
fig = plt.figure()
rc_dict0 = {
@@ -5656,7 +5657,7 @@ def test_date_timezone_y():
@@ -5670,7 +5671,7 @@ def test_date_timezone_y():
@image_comparison(baseline_images=['date_timezone_x_and_y'],
@ -271,7 +271,7 @@ index 1168ef983..038b7fd98 100644
# Tests issue 5575
UTC = datetime.timezone.utc
diff --git a/lib/matplotlib/tests/test_collections.py b/lib/matplotlib/tests/test_collections.py
index c12ed7004..e03a2b326 100644
index 773093100..37356d5e0 100644
--- a/lib/matplotlib/tests/test_collections.py
+++ b/lib/matplotlib/tests/test_collections.py
@@ -466,7 +466,7 @@ def test_EllipseCollection():
@ -334,7 +334,7 @@ index c65ad02c3..79deb249c 100644
fig = plt.figure(figsize=(8, 6))
ax1 = fig.add_axes([0.05, 0.85, 0.9, 0.1])
diff --git a/lib/matplotlib/tests/test_constrainedlayout.py b/lib/matplotlib/tests/test_constrainedlayout.py
index df3e5cf18..c8e29939e 100644
index e9ae292f6..0edfa1e27 100644
--- a/lib/matplotlib/tests/test_constrainedlayout.py
+++ b/lib/matplotlib/tests/test_constrainedlayout.py
@@ -246,7 +246,7 @@ def test_constrained_layout12():
@ -422,7 +422,7 @@ index 6ecb3edbe..47aff1b74 100644
# Check the figure.align_labels() command
fig = plt.figure(tight_layout=True)
diff --git a/lib/matplotlib/tests/test_image.py b/lib/matplotlib/tests/test_image.py
index ae803000d..0f2a83b0f 100644
index 22cd78d46..b4d41f882 100644
--- a/lib/matplotlib/tests/test_image.py
+++ b/lib/matplotlib/tests/test_image.py
@@ -810,7 +810,7 @@ def test_imshow_endianess():
@ -487,7 +487,7 @@ index bbb442638..b5d291c87 100644
matplotlib.rcParams['mathtext.fontset'] = fontset
fig = plt.figure(figsize=(5.25, 0.75))
diff --git a/lib/matplotlib/tests/test_patches.py b/lib/matplotlib/tests/test_patches.py
index 13c5dd1a8..f071bffeb 100644
index 31c240a60..979ab3ad0 100644
--- a/lib/matplotlib/tests/test_patches.py
+++ b/lib/matplotlib/tests/test_patches.py
@@ -259,9 +259,8 @@ def test_wedge_movement():

View File

@ -1,23 +0,0 @@
From 8b398bf086d426bd9071a4cde5186c5f86a5fc8e Mon Sep 17 00:00:00 2001
From: Thomas A Caswell <tcaswell@gmail.com>
Date: Sun, 28 Jul 2019 13:37:39 -0400
Subject: [PATCH] Backport PR #14901: Fix GH14900: numpy 1.17.0 breaks
test_colors.
---
lib/matplotlib/colors.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/matplotlib/colors.py b/lib/matplotlib/colors.py
index 1e47c00c79b..585381d9a7a 100644
--- a/lib/matplotlib/colors.py
+++ b/lib/matplotlib/colors.py
@@ -1685,7 +1685,7 @@ def shade_normals(self, normals, fraction=1.):
# visually appears better than a "hard" clip.
intensity -= imin
intensity /= (imax - imin)
- intensity = np.clip(intensity, 0, 1, intensity)
+ intensity = np.clip(intensity, 0, 1)
return intensity

View File

@ -1,68 +0,0 @@
commit 4651a1253ca5dc597550c5cd746f30dabee770bc
Author: Jody Klymak <jklymak@gmail.com>
Date: Wed Sep 4 10:48:01 2019 -0700
Backport PR #15168: MNT: explicitly cast np.bool_ -> bool to prevent deprecation warning
diff --git a/lib/matplotlib/axes/_base.py b/lib/matplotlib/axes/_base.py
index ff5aaf032..c2a4d2f42 100644
--- a/lib/matplotlib/axes/_base.py
+++ b/lib/matplotlib/axes/_base.py
@@ -3267,7 +3267,8 @@ class _AxesBase(martist.Artist):
reverse = left > right
left, right = self.xaxis.get_major_locator().nonsingular(left, right)
left, right = self.xaxis.limit_range_for_scale(left, right)
- left, right = sorted([left, right], reverse=reverse)
+ # cast to bool to avoid bad interaction between python 3.8 and np.bool_
+ left, right = sorted([left, right], reverse=bool(reverse))
self.viewLim.intervalx = (left, right)
if auto is not None:
@@ -3649,7 +3650,8 @@ class _AxesBase(martist.Artist):
reverse = bottom > top
bottom, top = self.yaxis.get_major_locator().nonsingular(bottom, top)
bottom, top = self.yaxis.limit_range_for_scale(bottom, top)
- bottom, top = sorted([bottom, top], reverse=reverse)
+ # cast to bool to avoid bad interaction between python 3.8 and np.bool_
+ bottom, top = sorted([bottom, top], reverse=bool(reverse))
self.viewLim.intervaly = (bottom, top)
if auto is not None:
diff --git a/lib/matplotlib/axis.py b/lib/matplotlib/axis.py
index a4cdffc55..e23b5748c 100644
--- a/lib/matplotlib/axis.py
+++ b/lib/matplotlib/axis.py
@@ -2156,7 +2156,8 @@ class XAxis(Axis):
def set_inverted(self, inverted):
# docstring inherited
a, b = self.get_view_interval()
- self.axes.set_xlim(sorted((a, b), reverse=inverted), auto=None)
+ # cast to bool to avoid bad interaction between python 3.8 and np.bool_
+ self.axes.set_xlim(sorted((a, b), reverse=bool(inverted)), auto=None)
def set_default_intervals(self):
# docstring inherited
@@ -2463,7 +2464,8 @@ class YAxis(Axis):
def set_inverted(self, inverted):
# docstring inherited
a, b = self.get_view_interval()
- self.axes.set_ylim(sorted((a, b), reverse=inverted), auto=None)
+ # cast to bool to avoid bad interaction between python 3.8 and np.bool_
+ self.axes.set_ylim(sorted((a, b), reverse=bool(inverted)), auto=None)
def set_default_intervals(self):
# docstring inherited
diff --git a/lib/mpl_toolkits/mplot3d/axes3d.py b/lib/mpl_toolkits/mplot3d/axes3d.py
index 4202be9a1..047234b36 100644
--- a/lib/mpl_toolkits/mplot3d/axes3d.py
+++ b/lib/mpl_toolkits/mplot3d/axes3d.py
@@ -626,7 +626,8 @@ class Axes3D(Axes):
reverse = left > right
left, right = self.xaxis.get_major_locator().nonsingular(left, right)
left, right = self.xaxis.limit_range_for_scale(left, right)
- left, right = sorted([left, right], reverse=reverse)
+ # cast to bool to avoid bad interaction between python 3.8 and np.bool_
+ left, right = sorted([left, right], reverse=bool(reverse))
self.xy_viewLim.intervalx = (left, right)
if auto is not None:

View File

@ -43,8 +43,8 @@
%global ftver 2.10.0
Name: python-matplotlib
Version: 3.1.1
Release: 2%{?rctag:.%{rctag}}%{?dist}
Version: 3.1.2
Release: 1%{?rctag:.%{rctag}}%{?dist}
Summary: Python 2D plotting library
# qt4_editor backend is MIT
License: Python and MIT
@ -59,13 +59,11 @@ Patch0001: 0001-Force-using-system-qhull.patch
# Don't attempt to download jQuery and jQuery UI
Patch0002: 0001-Use-packaged-jquery-and-jquery-ui.patch
# Fix tests with NumPy 1.17.
# https://github.com/matplotlib/matplotlib/pull/14901
Patch0003: 1230e83b6793e5ccda8543f3584eb8bc2dc657e2.patch
# Fix np.bool_ -> bool deprecation warnings on Python 3.8.
# https://github.com/matplotlib/matplotlib/pull/15168
Patch0004: 4651a1253ca5dc597550c5cd746f30dabee770bc.patch
# Fix WebAgg test
# https://github.com/matplotlib/matplotlib/pull/15737
Patch0003: 0001-Fix-env-override-in-WebAgg-backend-test.patch
# https://github.com/matplotlib/matplotlib/pull/15763
Patch0004: 0001-Skip-webagg-test-if-tornado-is-not-available.patch
# Fedora-specific patches; see:
# https://github.com/fedora-python/matplotlib/tree/fedora-patches
@ -155,6 +153,8 @@ Requires: python3-kiwisolver
Requires: python3-matplotlib-%{?backend_subpackage}%{!?backend_subpackage:tk}%{?_isa} = %{version}-%{release}
%if %{run_tests}
BuildRequires: python3-pytest
BuildRequires: python3-pytest-rerunfailures
BuildRequires: python3-pytest-timeout
BuildRequires: python3-pytest-xdist
%endif
Requires: python3-numpy
@ -457,6 +457,9 @@ PYTHONDONTWRITEBYTECODE=1 \
%changelog
* Fri Nov 22 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 3.1.2-1
- Update to latest version
* Fri Sep 06 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 3.1.1-2
- Backport bool deprecation fix for Python 3.8

View File

@ -1,2 +1,2 @@
SHA512 (matplotlib-3.1.1.tar.gz) = 157ced0cdcb17c9c82f897ee1621ea06a063491ce7393cda4c74a07a970c49385167b5cf32c1666a2933af50ccc53811cf871b6465b796a42abf4a358c76f6c0
SHA512 (matplotlib-3.1.2.tar.gz) = 514e66ff76381dccb185a8b8dee44ecbf5108e99ecc5ce46b56750e2a62b782e2b67f0ba02b01545541a1499ffe2347b6bc502077455d8a742796161017cba42
SHA512 (matplotlib-3.1.1-with-freetype-2.10.0.tar.gz) = 257546b047ff79302b616f1d37caa028a7b9abc1682cf10861e1347a3db9f437967abe24e11aee898ae11c6f163939d48bc5aeaec2894d6472b4326f8edaed8b