Re-enable tests on secondary arches. Fixes #1252899

- Applied patch to build on ppc64le. Fixes #1252900
This commit is contained in:
Kevin Fenzi 2015-08-21 11:23:29 -06:00
parent c514aa67e7
commit c6fa048a91
2 changed files with 93 additions and 6 deletions

View File

@ -0,0 +1,83 @@
From 9ad99fb5b9db916ca81bd3f5717c67e20384f7e0 Mon Sep 17 00:00:00 2001
From: Ulrich Weigand <uweigand@de.ibm.com>
Date: Fri, 17 Jul 2015 14:03:17 -0500
Subject: [PATCH 1/2] Add suuport for ppc64 in LE mode running ABIv2
Signed-off-by: Ulrich Weigand <uweigand@de.ibm.com>
Signed-off-by: Tony Breeds <tony@bakeyournoodle.com>
---
platform/switch_ppc64_linux.h | 22 +++++++++++++++++++---
1 file changed, 19 insertions(+), 3 deletions(-)
diff --git a/platform/switch_ppc64_linux.h b/platform/switch_ppc64_linux.h
index ee40f67..0f20756 100644
--- a/platform/switch_ppc64_linux.h
+++ b/platform/switch_ppc64_linux.h
@@ -2,6 +2,8 @@
* this is the internal transfer function.
*
* HISTORY
+ * 10-Dec-13 Ulrich Weigand <uweigand@de.ibm.com>
+ * Support ELFv2 ABI. Save float/vector registers.
* 09-Mar-12 Michael Ellerman <michael@ellerman.id.au>
* 64-bit implementation, copied from 32-bit.
* 07-Sep-05 (py-dev mailing list discussion)
@@ -40,14 +42,28 @@
#ifdef SLP_EVAL
+#if _CALL_ELF == 2
+#define STACK_MAGIC 4
+#else
#define STACK_MAGIC 6
+#endif
+
+#if defined(__ALTIVEC__)
+#define ALTIVEC_REGS \
+ "v20", "v21", "v22", "v23", "v24", "v25", "v26", "v27", \
+ "v28", "v29", "v30", "v31",
+#else
+#define ALTIVEC_REGS
+#endif
-/* !!!!WARNING!!!! need to add "r31" in the next line if this header file
- * is meant to be compiled non-dynamically!
- */
#define REGS_TO_SAVE "r2", "r14", "r15", "r16", "r17", "r18", "r19", "r20", \
"r21", "r22", "r23", "r24", "r25", "r26", "r27", "r28", "r29", "r31", \
+ "fr14", "fr15", "fr16", "fr17", "fr18", "fr19", "fr20", "fr21", \
+ "fr22", "fr23", "fr24", "fr25", "fr26", "fr27", "fr28", "fr29", \
+ "fr30", "fr31", \
+ ALTIVEC_REGS \
"cr2", "cr3", "cr4"
+
static int
slp_switch(void)
{
From 4d0c450852a2b0cf6307cf6ca53dcdeea357cd48 Mon Sep 17 00:00:00 2001
From: Tony Breeds <tony@bakeyournoodle.com>
Date: Fri, 17 Jul 2015 14:05:04 -0500
Subject: [PATCH 2/2] Force -fno-tree-dominator-opts for ppc64 in LE mode
Disable the optimisations that are most likely to break the fragile
C/asm logic.
Signed-off-by: Tony Breeds <tony@bakeyournoodle.com>
---
setup.py | 2 ++
1 file changed, 2 insertions(+)
diff --git a/setup.py b/setup.py
index ab02d93..acf9fec 100755
--- a/setup.py
+++ b/setup.py
@@ -50,6 +50,8 @@ def _find_platform_headers():
if sys.platform == 'win32' and os.environ.get('GREENLET_STATIC_RUNTIME') in ('1', 'yes'):
extra_compile_args = ['/MT']
+ elif os.uname()[4] in ['ppc64el', 'ppc64le']:
+ extra_compile_args = ['-fno-tree-dominator-opts']
else:
extra_compile_args = []

View File

@ -2,12 +2,16 @@
Name: python-greenlet
Version: 0.4.7
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Lightweight in-process concurrent programming
Group: Development/Libraries
License: MIT
URL: http://pypi.python.org/pypi/greenlet
Source0: http://pypi.python.org/packages/source/g/greenlet/greenlet-%{version}.zip
#
# already upstreamed, should be in next release.
# https://github.com/python-greenlet/greenlet/pull/89
Patch0: python-greenlet-0.4.7-ppc64le.patch
BuildRequires: python2-devel
BuildRequires: python-setuptools
%if 0%{?with_python3}
@ -53,6 +57,7 @@ This package contains header files required for C modules development.
%prep
%setup -q -n greenlet-%{version}
%patch0 -p1
chmod 644 benchmarks/*.py
%if 0%{?with_python3}
rm -rf %{py3dir}
@ -77,10 +82,6 @@ popd
%endif # if with_python3
%{__python2} setup.py install -O1 --skip-build --root %{buildroot}
# -02 or higher breaks on some archs. Refs:
# https://github.com/python-greenlet/greenlet/issues/63 and 66.
# TODO: find how to turn opt level down or wait for upstream fix
%ifnarch ppc64 s390 s390x
%check
# Run the upstream test suite and benchmarking suite to further exercise the code
%{__python2} setup.py test
@ -92,7 +93,6 @@ pushd %{py3dir}
2to3 -w --no-diffs -n benchmarks/chain.py
PYTHONPATH=$(pwd) %{__python3} benchmarks/chain.py
%endif # if with_python3
%endif # ppc64 s390 s390x
%files
%doc AUTHORS NEWS README.rst LICENSE LICENSE.PSF NEWS
@ -117,6 +117,10 @@ PYTHONPATH=$(pwd) %{__python3} benchmarks/chain.py
%endif # if with_python3
%changelog
* Fri Aug 21 2015 Kevin Fenzi <kevin@scrye.com> 0.4.7-2
- Re-enable tests on secondary arches. Fixes #1252899
- Applied patch to build on ppc64le. Fixes #1252900
* Fri Jun 26 2015 Kevin Fenzi <kevin@scrye.com> 0.4.7-1
- Update to 0.4.7. Fixes bug #1235896