Patch out fewer upstream compiler flags

We can leave those controlling warnings and dynamic symbol visibility;
we must remove any that hard-code the optimization settings or otherwise
ail to respect the distribution defaults.
This commit is contained in:
Benjamin A. Beasley 2022-11-17 20:13:44 -05:00
parent f432e332d8
commit 1482058081
3 changed files with 35 additions and 43 deletions

View File

@ -0,0 +1,29 @@
From 977fb56cff63b2103275df07ecd9f3ed43ef0e71 Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Thu, 17 Nov 2022 20:11:53 -0500
Subject: [PATCH] Remove upstream compiler flags
We can leave those controlling warnings and dynamic symbol visibility;
we must remove any that hard-code the optimization settings or otherwise
fail to respect the distribution defaults.
---
configure.ac | 3 ---
1 file changed, 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 6acddaf5..6bbe9898 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,9 +68,6 @@ dnl disable deprecation warning, to silence some harmless BGL-related warnings
dnl set default visibility
[CXXFLAGS="-fvisibility=default -fvisibility-inlines-hidden ${CXXFLAGS}"]
-dnl set default optimizations
-[CXXFLAGS="-O3 ${CXXFLAGS}"]
-
dnl OpenMP
AC_DEFINE([OPENMP_MIN_THRESH], 300, [default minimum number of vertices for parallel loops])
--
2.38.1

View File

@ -1,41 +0,0 @@
From 9fbea59c00a3aa74a3a01b18434d94f85ea1e2f9 Mon Sep 17 00:00:00 2001
From: "Ankur Sinha (Ankur Sinha Gmail)" <sanjay.ankur@gmail.com>
Date: Tue, 10 Aug 2021 20:15:48 +0100
Subject: [PATCH] remove upstream compilation flags
---
configure.ac | 11 -----------
1 file changed, 11 deletions(-)
diff --git a/configure.ac b/configure.ac
index 6acddaf5..e9246abc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,8 +41,6 @@ PKG_INSTALLDIR
AX_CXX_COMPILE_STDCXX_17([ext],[mandatory])
-dnl turn on warnings
-[CXXFLAGS="-Wall -Wextra -ftemplate-backtrace-limit=0 ${CXXFLAGS}"]
dnl Checks for options
@@ -62,15 +60,6 @@ AC_ARG_ENABLE([debug],
[CPPFLAGS="-DNDEBUG ${CPPFLAGS}"]
[AC_MSG_RESULT(no)])
-dnl disable deprecation warning, to silence some harmless BGL-related warnings
-[CXXFLAGS="-Wno-deprecated ${CXXFLAGS}"]
-
-dnl set default visibility
-[CXXFLAGS="-fvisibility=default -fvisibility-inlines-hidden ${CXXFLAGS}"]
-
-dnl set default optimizations
-[CXXFLAGS="-O3 ${CXXFLAGS}"]
-
dnl OpenMP
AC_DEFINE([OPENMP_MIN_THRESH], 300, [default minimum number of vertices for parallel loops])
--
2.31.1

View File

@ -75,8 +75,12 @@ Summary: Efficient network analysis tool written in Python
License: LGPL-3.0-or-later AND BSL-1.0
URL: https://graph-tool.skewed.de/
Source0: https://downloads.skewed.de/graph-tool/graph-tool-%{version}.tar.bz2
# Remove the compilation flags upstream sets
Patch0: 0001-remove-upstream-compilation-flags.patch
# Remove upstream compiler flags
#
# We can leave those controlling warnings and dynamic symbol visibility;
# we must remove any that hard-code the optimization settings or otherwise
# fail to respect the distribution defaults.
Patch: 0001-Remove-upstream-compiler-flags.patch
# Need to reduce debugging symbols to make compiling possible on these
# architectures at all. See: