Version 2.1.0 beta5. Drop all patches.
This commit is contained in:
parent
aa7e4af166
commit
88a64e445b
@ -1,11 +0,0 @@
|
||||
--- a/test/test_gmpy2_math.txt
|
||||
+++ b/test/test_gmpy2_math.txt
|
||||
@@ -233,8 +233,6 @@ TypeError: factorial() requires non-nega
|
||||
mpfr('1.2146304367025329e+205')
|
||||
>>> gmpy2.factorial(123456)
|
||||
mpfr('2.6040699049291379e+574964')
|
||||
->>> gmpy2.factorial(123456789)
|
||||
-mpfr('inf')
|
||||
>>> gmpy2.factorial(1234567899999999999999)
|
||||
Traceback (most recent call last):
|
||||
File "<stdin>", line 1, in <module>
|
@ -1,16 +1,14 @@
|
||||
%global srcname gmpy2
|
||||
%global prerelease b4
|
||||
%global prerelease b5
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 2.1.0
|
||||
Release: 0.15%{?prerelease:.%{prerelease}}%{?dist}
|
||||
Release: 0.16%{?prerelease:.%{prerelease}}%{?dist}
|
||||
Summary: Python interface to GMP, MPFR, and MPC
|
||||
|
||||
License: LGPLv3+
|
||||
URL: https://pypi.python.org/pypi/gmpy2
|
||||
Source0: https://github.com/aleaxit/gmpy/archive/%{srcname}-%{version}%{?prerelease}.tar.gz
|
||||
# Work around an apparent inflooping bug in MPFR on 32-bit systems
|
||||
Patch0: %{name}-factorial-32bit.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gmp-devel
|
||||
@ -44,16 +42,13 @@ Provides: bundled(jquery)
|
||||
%{common_desc}
|
||||
|
||||
%prep
|
||||
%autosetup -N -n gmpy-%{srcname}-%{version}%{?prerelease}
|
||||
%if 0%{?__isa_bits} == 32
|
||||
%patch0 -p1
|
||||
%endif
|
||||
%autosetup -n gmpy-%{srcname}-%{version}%{?prerelease}
|
||||
|
||||
# Update the sphinx theme name
|
||||
sed -i "s/'default'/'classic'/" docs/conf.py
|
||||
|
||||
# Version 2.1.0b4 still calls itself 2.1.0b1
|
||||
sed -i "s/b1/b4/" docs/conf.py
|
||||
# Version 2.1.0b5 still calls itself 2.1.0b1
|
||||
sed -i "s/b1/b5/" docs/conf.py
|
||||
|
||||
# Symbols from the math library are also used
|
||||
sed -i "s/'mpfr','gmp'/&,'m'/" setup.py
|
||||
@ -83,6 +78,10 @@ cd -
|
||||
%{python3_sitearch}/%{srcname}*
|
||||
|
||||
%changelog
|
||||
* Fri Jul 31 2020 Jerry James <loganjerry@gmail.com> - 2.1.0-0.16.b5
|
||||
- Version 2.1.0 beta5
|
||||
- Drop all patches
|
||||
|
||||
* Mon Feb 10 2020 Jerry James <loganjerry@gmail.com> - 2.1.0-0.15.b4
|
||||
- Version 2.1.0 beta4
|
||||
- Also run the Cython tests
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (gmpy2-2.1.0b4.tar.gz) = 80e339827022063b443e624abf919f88495c092d5481a253899bb7b0b241993aa2ab9c2ece759c2a32e25540784f3340008aa730bfad28b2c5a398e297e96fea
|
||||
SHA512 (gmpy2-2.1.0b5.tar.gz) = 13c5c9111d374907cce606d8358b577620a30b683386e7505588ad9bf1017712ede9a1d0870f5a638cc3817848a2d09218348bc9b52b546035974b968d428dc5
|
||||
|
Loading…
x
Reference in New Issue
Block a user