removed version requirement for greenlet

This commit is contained in:
Dan Callaghan 2015-06-26 14:10:55 +10:00
parent 5290c1f553
commit 74e1293642
2 changed files with 37 additions and 1 deletions

View File

@ -0,0 +1,27 @@
From 8805203cabef9919b5e2173dab85bde762f1d842 Mon Sep 17 00:00:00 2001
From: Dan Callaghan <dcallagh@redhat.com>
Date: Fri, 26 Jun 2015 13:29:04 +1000
Subject: [PATCH 2/2] remove version requirement for greenlet
We currently have 0.4.5 in Fedora which is also fine (Python 2.5 support
is not relevant for us).
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 1e7fbfa..5793eb9 100755
--- a/setup.py
+++ b/setup.py
@@ -307,7 +307,7 @@ def run_setup(ext_modules):
packages=['gevent'],
ext_modules=ext_modules,
cmdclass=dict(build_ext=my_build_ext, sdist=sdist),
- install_requires=['greenlet>=0.4.7'],
+ install_requires=['greenlet'],
classifiers=[
"License :: OSI Approved :: MIT License",
"Programming Language :: Python :: 2.5",
--
1.9.3

View File

@ -6,7 +6,7 @@
Name: python-%{upstream_name}
Version: 1.0.2
Release: 1%{?dist}
Release: 2%{?dist}
Summary: A coroutine-based Python networking library
Group: Development/Languages
@ -14,6 +14,11 @@ License: MIT
URL: http://www.gevent.org/
Source0: http://pypi.python.org/packages/source/g/gevent/gevent-%{version}.tar.gz
# gevent requires greenlet >= 0.4.7 but we have 0.4.5 in Fedora.
# The version requirement is only related to Python 2.5 support
# so we are fine with any version.
Patch2: 0002-remove-version-requirement-for-greenlet.patch
BuildRequires: python2-devel
BuildRequires: c-ares-devel
BuildRequires: libev-devel
@ -36,6 +41,7 @@ Features include:
%setup -q -n %{upstream_name}-%{version}
# Remove bundled libraries
rm -r c-ares libev
%patch2 -p1
%build
CFLAGS="%{optflags} -I%{_includedir}/libev" %{__python2} setup.py build
@ -51,6 +57,9 @@ CFLAGS="%{optflags} -I%{_includedir}/libev" %{__python2} setup.py build
%{python2_sitearch}/%{upstream_name}-%{version}-*.egg-info
%changelog
* Fri Jun 26 2015 Dan Callaghan <dcallagh@redhat.com> - 1.0.2-2
- removed version requirement for greenlet
* Mon Jun 22 2015 Dan Callaghan <dcallagh@redhat.com> - 1.0.2-1
- bug fix release 1.0.2:
https://github.com/gevent/gevent/blob/v1.0.2/changelog.rst#release-102-may-23-2015