Ignore warnings from Pandas

This commit is contained in:
Elliott Sales de Andrade 2023-11-26 19:19:05 -05:00
parent cd8020f346
commit 7f30dda570
8 changed files with 39 additions and 6 deletions

View File

@ -1,7 +1,7 @@
From 108137a7dd964cfd46e134d523cc45dd4e5dab08 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sun, 7 Mar 2021 04:07:32 -0500
Subject: [PATCH 1/6] Skip test_encoding_gh601 on big-endian machines.
Subject: [PATCH 1/7] Skip test_encoding_gh601 on big-endian machines.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---

View File

@ -1,7 +1,7 @@
From 743a70400f3fa4fca4e2524d9da5d449865c7300 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sun, 7 May 2023 23:13:59 -0400
Subject: [PATCH 2/6] Skip coverage testing
Subject: [PATCH 2/7] Skip coverage testing
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---

View File

@ -1,7 +1,7 @@
From 4d70d754eac43c1152bfae750ad2df319b508a1d Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Thu, 20 Jul 2023 00:05:48 -0400
Subject: [PATCH 3/6] TST: Increase maximum for sizeof test to pass 32-bit
Subject: [PATCH 3/7] TST: Increase maximum for sizeof test to pass 32-bit
In that case, the result is 1244, which is ~2.6 * `sys.sizeof` (476),
slightly over the 2 used in the existing test.

View File

@ -1,7 +1,7 @@
From 65c859e60bb56326a22722dc92bea63d30735ace Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sat, 19 Aug 2023 16:49:33 -0400
Subject: [PATCH 4/6] Fix test_pandas_timestamp_overflow_pyarrow condition
Subject: [PATCH 4/7] Fix test_pandas_timestamp_overflow_pyarrow condition
The new behavior in pyarrow only occurs with Pandas 2.0 as well.

View File

@ -1,7 +1,7 @@
From fe84b30ae6d72bac68972da3594897fe4de9eef4 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sat, 25 Nov 2023 20:22:50 -0500
Subject: [PATCH 5/6] Allow older versioneer
Subject: [PATCH 5/7] Allow older versioneer
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---

View File

@ -1,7 +1,7 @@
From 71c47a4501b9eca50776efc74bbfda5aeba89d90 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sat, 25 Nov 2023 23:01:54 -0500
Subject: [PATCH 6/6] Skip an unsupported test
Subject: [PATCH 6/7] Skip an unsupported test
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---

View File

@ -0,0 +1,29 @@
From 6a9e51c4c468e3595982f23e367d5305abf231ac Mon Sep 17 00:00:00 2001
From: James Bourbeau <jrbourbeau@gmail.com>
Date: Mon, 22 May 2023 12:53:20 -0500
Subject: [PATCH 7/7] Ignore NumPy warnings from Pandas
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
pyproject.toml | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/pyproject.toml b/pyproject.toml
index 1f820da4..d2482f20 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -143,6 +143,11 @@ filterwarnings = [
# https://pandas.pydata.org/docs/dev/whatsnew/v1.5.0.html#using-group-keys-with-transformers-in-groupby-apply
"ignore:Not prepending group keys:FutureWarning",
"ignore:.*:dask.tests.warning_aliases.RemovedIn20Warning",
+ # This is coming from pandas use of np.find_common_type
+ # See https://github.com/pandas-dev/pandas/issues/53236
+ "ignore:np.find_common_type is deprecated:DeprecationWarning",
+ "ignore:`cumproduct` is deprecated:DeprecationWarning",
+ "ignore:`product` is deprecated:DeprecationWarning",
"ignore:When grouping with a length-1 list-like, you will need to pass a length-1 tuple to get_group in a future version of pandas:FutureWarning",
'ignore:DataFrameGroupBy\.apply operated on the grouping columns\. This behavior is deprecated, and in a future version of pandas the grouping columns will be excluded from the operation\. Either pass `include_groups=False` to exclude the groupings or explicitly select the grouping columns after groupby to silence this warning\.:FutureWarning',
'ignore:Passing a BlockManager to DataFrame is deprecated and will raise in a future version. Use public APIs instead:DeprecationWarning', # https://github.com/apache/arrow/issues/35081
--
2.42.0

View File

@ -30,6 +30,10 @@ Patch: 0004-Fix-test_pandas_timestamp_overflow_pyarrow-condition.patch
Patch: https://salsa.debian.org/python-team/packages/dask/-/raw/08ffea1b7b53e9c71c9a926d5786288c2e6c1b5b/debian/patches/force-little-endian-random.patch
Patch: 0005-Allow-older-versioneer.patch
Patch: 0006-Skip-an-unsupported-test.patch
# Ignore warnings from Pandas.
# Upstream had https://github.com/dask/dask/pull/10307 but reverted it because
# a new Pandas was released that fixed the warning, but we don't have it yet.
Patch: 0007-Ignore-NumPy-warnings-from-Pandas.patch
%description
Dask is a flexible parallel computing library for analytics.