Update to latest version (#2186901)
This commit is contained in:
parent
5b8ad56cae
commit
7cd18b9b61
1
.gitignore
vendored
1
.gitignore
vendored
@ -69,3 +69,4 @@
|
||||
/dask-2023.2.0.tar.gz
|
||||
/dask-2023.3.2.tar.gz
|
||||
/dask-2023.4.0.tar.gz
|
||||
/dask-2023.4.1.tar.gz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From dd144df006fa18c53547e54ff2623e47e6ca9520 Mon Sep 17 00:00:00 2001
|
||||
From 5ee683719a19c8865a7b80725a0adf55baa3e9c9 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Sun, 7 Mar 2021 04:07:32 -0500
|
||||
Subject: [PATCH 1/2] Skip test_encoding_gh601 on big-endian machines.
|
||||
@ -9,7 +9,7 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/dask/dataframe/io/tests/test_csv.py b/dask/dataframe/io/tests/test_csv.py
|
||||
index abf90ca4..fb4358f3 100644
|
||||
index b50a727b..0ac1df4c 100644
|
||||
--- a/dask/dataframe/io/tests/test_csv.py
|
||||
+++ b/dask/dataframe/io/tests/test_csv.py
|
||||
@@ -2,6 +2,7 @@ import gzip
|
||||
@ -20,7 +20,7 @@ index abf90ca4..fb4358f3 100644
|
||||
from unittest import mock
|
||||
|
||||
import pytest
|
||||
@@ -1116,6 +1117,7 @@ def test_read_csv_with_datetime_index_partitions_n():
|
||||
@@ -1146,6 +1147,7 @@ def test_read_csv_with_datetime_index_partitions_n():
|
||||
xfail_pandas_100 = pytest.mark.xfail(reason="https://github.com/dask/dask/issues/5787")
|
||||
|
||||
|
||||
@ -29,5 +29,5 @@ index abf90ca4..fb4358f3 100644
|
||||
"encoding",
|
||||
[
|
||||
--
|
||||
2.36.1
|
||||
2.40.0
|
||||
|
||||
|
26
0002-Skip-coverage-testing.patch
Normal file
26
0002-Skip-coverage-testing.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 54487feeef6d7d41e3b6d4e4ece5b6342071068b Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Sun, 7 May 2023 23:13:59 -0400
|
||||
Subject: [PATCH 2/2] Skip coverage testing
|
||||
|
||||
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
---
|
||||
pyproject.toml | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/pyproject.toml b/pyproject.toml
|
||||
index a7d504ff..36dfca8e 100644
|
||||
--- a/pyproject.toml
|
||||
+++ b/pyproject.toml
|
||||
@@ -121,7 +121,7 @@ markers = [
|
||||
"skip_with_pyarrow_strings: Tests that should be skipped when pyarrow string conversion is turned on",
|
||||
"xfail_with_pyarrow_strings: Tests that should be xfailed when pyarrow string conversion is turned on",
|
||||
]
|
||||
-addopts = "-v -rsxfE --durations=10 --color=yes --cov-config=pyproject.toml"
|
||||
+addopts = "-v -rsxfE --durations=10 --color=yes"
|
||||
filterwarnings = [
|
||||
# From Cython-1753
|
||||
"ignore:can't resolve:ImportWarning",
|
||||
--
|
||||
2.40.0
|
||||
|
@ -10,8 +10,8 @@
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 2023.4.0
|
||||
%global tag 2023.4.0
|
||||
Version: 2023.4.1
|
||||
%global tag 2023.4.1
|
||||
Release: %autorelease
|
||||
Summary: Parallel PyData with Task Scheduling
|
||||
|
||||
@ -20,6 +20,8 @@ URL: https://github.com/dask/dask
|
||||
Source0: %{pypi_source %{srcname}}
|
||||
# https://github.com/dask/dask/issues/6725
|
||||
Patch: 0001-Skip-test_encoding_gh601-on-big-endian-machines.patch
|
||||
# Fedora-specific patch.
|
||||
Patch: 0002-Skip-coverage-testing.patch
|
||||
|
||||
%description
|
||||
Dask is a flexible parallel computing library for analytics.
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dask-2023.4.0.tar.gz) = 92711f2378bdff38b3a1aceb4eabf52e28558c145992cabcee26042a7fcf6d2c30d64a363f5f6edf53c17ecd7c47861e9d171373df1e9e9d1689868544165b93
|
||||
SHA512 (dask-2023.4.1.tar.gz) = 2fad1317aad845f7b11d8efceafb11eb9e945aca649bcf7ccd71e8692c3ca18c6f595c82b4e2930cba4e9622dd384965b3cf0ea3f68bdbc2f6f18c7a2d806b26
|
||||
|
Loading…
Reference in New Issue
Block a user