Add “pandas[test]” to “test” extra

This is important because the python-pandas package will now install
pandas.tests only with python3-pandas+tests, and Dask’s tests import
from Pandas’s test suite.
This commit is contained in:
Benjamin A. Beasley 2022-05-21 08:27:46 -04:00
parent e5d1690c6b
commit 7bcad28c0f
2 changed files with 30 additions and 0 deletions

27
9110.patch Normal file
View File

@ -0,0 +1,27 @@
From 96112f76bb28608f100920732825e45917ee0e5d Mon Sep 17 00:00:00 2001
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
Date: Sat, 21 May 2022 08:09:39 -0400
Subject: [PATCH] =?UTF-8?q?Add=20=E2=80=9Cpandas[test]=E2=80=9D=20to=20?=
=?UTF-8?q?=E2=80=9Ctest=E2=80=9D=20extra?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Since the tests use “pandas.test” (the actual Pandas test suite), not
only “pandas.testing”, it makes sense to rely on Pandass test extra.
---
setup.py | 1 +
1 file changed, 1 insertion(+)
diff --git a/setup.py b/setup.py
index d52adf72d29..c3ae3ff62d9 100755
--- a/setup.py
+++ b/setup.py
@@ -25,6 +25,7 @@
extras_require["complete"] = sorted({v for req in extras_require.values() for v in req})
# after complete is set, add in test
extras_require["test"] = [
+ "pandas[test]",
"pytest",
"pytest-rerunfailures",
"pytest-xdist",

View File

@ -40,6 +40,9 @@ Patch: 0001-Skip-test_encoding_gh601-on-big-endian-machines.patch
# This patch has been trivially rebased to apply to the PyPI sdist, which uses
# tabs rather than spaces in setup.cfg.
Patch: dask-2022.5.0-pr-9113.patch
# Add “pandas[test]” to “test” extra
# https://github.com/dask/dask/pull/9110
Patch: %{url}/pull/9110.patch
%description
Dask is a flexible parallel computing library for analytics.