Update to latest version (#2115959)
This commit is contained in:
parent
12974de1b2
commit
63a4375377
1
.gitignore
vendored
1
.gitignore
vendored
@ -58,3 +58,4 @@
|
||||
/dask-2022.05.0.tar.gz
|
||||
/dask-2022.5.0.tar.gz
|
||||
/dask-2022.7.1.tar.gz
|
||||
/dask-2022.8.0.tar.gz
|
||||
|
27
9110.patch
27
9110.patch
@ -1,27 +0,0 @@
|
||||
From 96112f76bb28608f100920732825e45917ee0e5d Mon Sep 17 00:00:00 2001
|
||||
From: "Benjamin A. Beasley" <code@musicinmybrain.net>
|
||||
Date: Sat, 21 May 2022 08:09:39 -0400
|
||||
Subject: [PATCH] =?UTF-8?q?Add=20=E2=80=9Cpandas[test]=E2=80=9D=20to=20?=
|
||||
=?UTF-8?q?=E2=80=9Ctest=E2=80=9D=20extra?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Since the tests use “pandas.test” (the actual Pandas test suite), not
|
||||
only “pandas.testing”, it makes sense to rely on Pandas’s test extra.
|
||||
---
|
||||
setup.py | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index d52adf72d29..c3ae3ff62d9 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -25,6 +25,7 @@
|
||||
extras_require["complete"] = sorted({v for req in extras_require.values() for v in req})
|
||||
# after complete is set, add in test
|
||||
extras_require["test"] = [
|
||||
+ "pandas[test]",
|
||||
"pytest",
|
||||
"pytest-rerunfailures",
|
||||
"pytest-xdist",
|
@ -10,8 +10,8 @@
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 2022.7.1
|
||||
%global tag 2022.7.1
|
||||
Version: 2022.8.0
|
||||
%global tag 2022.8.0
|
||||
Release: %autorelease
|
||||
Summary: Parallel PyData with Task Scheduling
|
||||
|
||||
@ -20,9 +20,6 @@ URL: https://github.com/dask/dask
|
||||
Source0: %{pypi_source %{srcname}}
|
||||
# https://github.com/dask/dask/issues/6725
|
||||
Patch: 0001-Skip-test_encoding_gh601-on-big-endian-machines.patch
|
||||
# Add “pandas[test]” to “test” extra
|
||||
# https://github.com/dask/dask/pull/9110
|
||||
Patch: %{url}/pull/9110.patch
|
||||
|
||||
%description
|
||||
Dask is a flexible parallel computing library for analytics.
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dask-2022.7.1.tar.gz) = c72818a9654ca35686f616105eafb2dcf29052be2e021454a8f1bda6049db81617b8ff8516e56135cbcdea1c5fb85a0a230e8104145947f397d03af82e8df9d8
|
||||
SHA512 (dask-2022.8.0.tar.gz) = f57ac7a88494bbad83567f086b15f6cf016058f3def1edcd264964c4e8d2fba2d6713aabb9eba39c74cbcf39f46f9e041a9cdbcb215c2eae4acbc915db8fb7b4
|
||||
|
Loading…
Reference in New Issue
Block a user