Fix test on i686 arch

This commit is contained in:
Elliott Sales de Andrade 2022-12-18 19:24:16 -05:00
parent 2bdde6351f
commit 18bb90e1d0
3 changed files with 37 additions and 2 deletions

View File

@ -1,7 +1,7 @@
From 3a7b31a4d0a602a5b45799e95c24b6bc59960c5d Mon Sep 17 00:00:00 2001
From dd144df006fa18c53547e54ff2623e47e6ca9520 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sun, 7 Mar 2021 04:07:32 -0500
Subject: [PATCH] Skip test_encoding_gh601 on big-endian machines.
Subject: [PATCH 1/2] Skip test_encoding_gh601 on big-endian machines.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---

View File

@ -0,0 +1,30 @@
From 9a7f39e1dc96f76caf9edec527ec78aec374b046 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Sun, 18 Dec 2022 19:18:43 -0500
Subject: [PATCH 2/2] TST: Reduce size of expected DoK sparse matrix
Apparently, SciPy was not available on 32-bit, and this test was
skipped, but it's recently become available again, and this value is too
large.
Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
dask/tests/test_sizeof.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dask/tests/test_sizeof.py b/dask/tests/test_sizeof.py
index a13b85b4..934ae834 100644
--- a/dask/tests/test_sizeof.py
+++ b/dask/tests/test_sizeof.py
@@ -82,7 +82,7 @@ def test_sparse_matrix():
assert sizeof(sp.tocoo()) >= 240
assert sizeof(sp.tocsc()) >= 232
assert sizeof(sp.tocsr()) >= 232
- assert sizeof(sp.todok()) >= 192
+ assert sizeof(sp.todok()) >= 188
assert sizeof(sp.tolil()) >= 204
--
2.36.1

View File

@ -20,6 +20,8 @@ URL: https://github.com/dask/dask
Source0: %{pypi_source %{srcname}}
# https://github.com/dask/dask/issues/6725
Patch: 0001-Skip-test_encoding_gh601-on-big-endian-machines.patch
# https://github.com/dask/dask/pull/9775
Patch: 0002-TST-Reduce-size-of-expected-DoK-sparse-matrix.patch
%description
Dask is a flexible parallel computing library for analytics.
@ -105,6 +107,9 @@ Documentation for dask.
# we don't use pre-commit when running tests
sed -i '/"pre-commit"/d' setup.py
# https://github.com/dask/dask/pull/9774
chmod -x dask/dataframe/io/orc/utils.py
%generate_buildrequires
%pyproject_buildrequires -r -x test,array,bag,dataframe,delayed