Update to latest version (#2089862)
This commit is contained in:
parent
0d23a08eb0
commit
12974de1b2
1
.gitignore
vendored
1
.gitignore
vendored
@ -57,3 +57,4 @@
|
||||
/dask-2022.02.1.tar.gz
|
||||
/dask-2022.05.0.tar.gz
|
||||
/dask-2022.5.0.tar.gz
|
||||
/dask-2022.7.1.tar.gz
|
||||
|
@ -1,30 +0,0 @@
|
||||
Copyright (c) 2005-2015, NumPy Developers.
|
||||
All rights reserved.
|
||||
|
||||
Redistribution and use in source and binary forms, with or without
|
||||
modification, are permitted provided that the following conditions are
|
||||
met:
|
||||
|
||||
* Redistributions of source code must retain the above copyright
|
||||
notice, this list of conditions and the following disclaimer.
|
||||
|
||||
* Redistributions in binary form must reproduce the above
|
||||
copyright notice, this list of conditions and the following
|
||||
disclaimer in the documentation and/or other materials provided
|
||||
with the distribution.
|
||||
|
||||
* Neither the name of the NumPy Developers nor the names of any
|
||||
contributors may be used to endorse or promote products derived
|
||||
from this software without specific prior written permission.
|
||||
|
||||
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
70
conftest.py
70
conftest.py
@ -1,70 +0,0 @@
|
||||
import pytest
|
||||
|
||||
import dask
|
||||
|
||||
# The doctests in these files fail due to either:
|
||||
# - Non-required dependencies not being installed
|
||||
# - Imported doctests due to pulling the docstrings from other packages
|
||||
# (e.g. `numpy`). No need to run these doctests.
|
||||
collect_ignore = [
|
||||
"dask/bytes/hdfs3.py",
|
||||
"dask/bytes/pyarrow.py",
|
||||
"dask/bytes/s3.py",
|
||||
"dask/array/ghost.py",
|
||||
"dask/array/fft.py",
|
||||
"dask/dataframe/io/io.py",
|
||||
"dask/dataframe/io/parquet/arrow.py",
|
||||
"dask/dot.py",
|
||||
"dask/ml.py",
|
||||
]
|
||||
|
||||
collect_ignore_glob = []
|
||||
try:
|
||||
import numpy # noqa: F401
|
||||
except ImportError:
|
||||
collect_ignore_glob.append("dask/array/*")
|
||||
|
||||
try:
|
||||
import pandas # noqa: F401
|
||||
except ImportError:
|
||||
collect_ignore_glob.append("dask/dataframe/*")
|
||||
|
||||
try:
|
||||
import scipy # noqa: F401
|
||||
except ImportError:
|
||||
collect_ignore.append("dask/array/stats.py")
|
||||
|
||||
try:
|
||||
import pyarrow # noqa: F401
|
||||
except ImportError:
|
||||
collect_ignore.append("dask/dataframe/io/orc/arrow.py")
|
||||
|
||||
try:
|
||||
import tiledb # noqa: F401
|
||||
except ImportError:
|
||||
collect_ignore.append("dask/array/tiledb_io.py")
|
||||
|
||||
try:
|
||||
import sqlalchemy # noqa: F401
|
||||
except ImportError:
|
||||
collect_ignore.append("dask/dataframe/io/sql.py")
|
||||
|
||||
|
||||
def pytest_addoption(parser):
|
||||
parser.addoption("--runslow", action="store_true", help="run slow tests")
|
||||
|
||||
|
||||
def pytest_runtest_setup(item):
|
||||
if "slow" in item.keywords and not item.config.getoption("--runslow"):
|
||||
pytest.skip("need --runslow option to run")
|
||||
|
||||
|
||||
pytest.register_assert_rewrite(
|
||||
"dask.array.utils", "dask.dataframe.utils", "dask.bag.utils"
|
||||
)
|
||||
|
||||
|
||||
@pytest.fixture(params=["disk", "tasks"])
|
||||
def shuffle_method(request):
|
||||
with dask.config.set(shuffle=request.param):
|
||||
yield request.param
|
@ -1,14 +0,0 @@
|
||||
diff -Naur dask-2022.5.0-original/setup.cfg dask-2022.5.0/setup.cfg
|
||||
--- dask-2022.5.0-original/setup.cfg 2022-05-02 14:24:38.606312800 -0400
|
||||
+++ dask-2022.5.0/setup.cfg 2022-05-22 09:06:51.480496179 -0400
|
||||
@@ -55,7 +55,9 @@
|
||||
xfail_strict = true
|
||||
|
||||
[metadata]
|
||||
-license_files = LICENSE.txt
|
||||
+license_files =
|
||||
+ LICENSE.txt
|
||||
+ dask/array/NUMPY_LICENSE.txt
|
||||
|
||||
[mypy]
|
||||
python_version = 3.9
|
@ -10,36 +10,16 @@
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: python-%{srcname}
|
||||
Version: 2022.5.0
|
||||
%global tag 2022.05.0
|
||||
Version: 2022.7.1
|
||||
%global tag 2022.7.1
|
||||
Release: %autorelease
|
||||
Summary: Parallel PyData with Task Scheduling
|
||||
|
||||
License: BSD
|
||||
URL: https://github.com/dask/dask/
|
||||
URL: https://github.com/dask/dask
|
||||
Source0: %{pypi_source %{srcname}}
|
||||
# These are missing from the PyPI sdist. Until our PR#9113 and PR#9115 are
|
||||
# accepted and included in a release, we grab them from the release tag in the
|
||||
# GitHub repository.
|
||||
Source1: https://github.com/dask/dask/raw/%{tag}/dask/array/NUMPY_LICENSE.txt
|
||||
# PyPI sdist tarball is missing 'conftest.py'
|
||||
# https://github.com/dask/dask/issues/8475
|
||||
# Include conftest.py in sdists
|
||||
# https://github.com/dask/dask/pull/9115
|
||||
Source2: https://github.com/dask/dask/raw/%{tag}/conftest.py
|
||||
# https://github.com/dask/dask/issues/6725
|
||||
Patch: 0001-Skip-test_encoding_gh601-on-big-endian-machines.patch
|
||||
# Add NUMPY_LICENSE.txt to license_files in setup.cfg
|
||||
# https://github.com/dask/dask/pull/9113
|
||||
#
|
||||
# Fixes:
|
||||
#
|
||||
# dask/array/NUMPY_LICENSE.txt not included in PyPI distributions
|
||||
# https://github.com/dask/dask/issues/9112
|
||||
#
|
||||
# This patch has been trivially rebased to apply to the PyPI sdist, which uses
|
||||
# tabs rather than spaces in setup.cfg.
|
||||
Patch: dask-2022.5.0-pr-9113.patch
|
||||
# Add “pandas[test]” to “test” extra
|
||||
# https://github.com/dask/dask/pull/9110
|
||||
Patch: %{url}/pull/9110.patch
|
||||
@ -125,8 +105,6 @@ Documentation for dask.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{srcname}-%{version} -p1
|
||||
cp -p '%{SOURCE1}' dask/array/
|
||||
cp -p '%{SOURCE2}' ./
|
||||
# we don't use pre-commit when running tests
|
||||
sed -i '/"pre-commit"/d' setup.py
|
||||
|
||||
@ -224,9 +202,6 @@ k="${k-}${k+ and }not test_development_guidelines_matches_ci"
|
||||
pytest_args=(
|
||||
-m 'not network'
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1968947#c4
|
||||
--deselect=dask/dataframe/io/tests/test_sql.py::test_select_from_select
|
||||
|
||||
-n %[0%{?have_arm}?"2":"auto"]
|
||||
|
||||
# Ignore https://github.com/numpy/numpy/issues/20225 and Pandas issues
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (dask-2022.5.0.tar.gz) = 40d119f5cee86c5ae6756501ed9f73a6fde0954cae961cca0ddf947e36df227163f87d7176d04388ab9ffe8ba18efbfb908adcf45de0064041a412b7596209a8
|
||||
SHA512 (dask-2022.7.1.tar.gz) = c72818a9654ca35686f616105eafb2dcf29052be2e021454a8f1bda6049db81617b8ff8516e56135cbcdea1c5fb85a0a230e8104145947f397d03af82e8df9d8
|
||||
|
Loading…
Reference in New Issue
Block a user