Version 1.10.3. Add -minsigstksz patch to fix FTBFS (bz 1935643).

This commit is contained in:
Jerry James 2021-06-17 13:50:52 -06:00
parent c6cc01df11
commit d64c735479
4 changed files with 27 additions and 5 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/cysignals-*.tar.gz
/*.tar.gz

View File

@ -0,0 +1,12 @@
--- src/cysignals/implementation.c.orig 2021-05-27 14:03:35.653774857 -0600
+++ src/cysignals/implementation.c 2021-05-27 14:19:42.225312505 -0600
@@ -445,7 +445,8 @@ static void setup_alt_stack(void)
/* Static space for the alternate signal stack. The size should be
* of the form MINSIGSTKSZ + constant. The constant is chosen rather
* ad hoc but sufficiently large. */
- static char alt_stack[MINSIGSTKSZ + 5120 + BACKTRACELEN * sizeof(void*)];
+ /* MINSIGSTKSIZE is now nonconstant. */
+ static char alt_stack[4096 + 5120 + BACKTRACELEN * sizeof(void*)];
stack_t ss;
ss.ss_sp = alt_stack;

View File

@ -4,14 +4,15 @@
%global _python_bytecompile_extra 0
Name: python-%{modname}
Version: 1.10.2
Release: 12%{?dist}
Version: 1.10.3
Release: 1%{?dist}
Summary: Interrupt and signal handling for Cython
License: LGPLv3+
URL: https://github.com/sagemath/%{modname}
Source0: https://github.com/sagemath/%{modname}/releases/download/%{version}/%{modname}-%{version}.tar.gz
Source0: %{url}/archive/refs/tags/%{version}.tar.gz
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: libtool
BuildRequires: make
BuildRequires: pari-devel
# https://bugzilla.redhat.com/show_bug.cgi?id=1445411#c2
@ -26,6 +27,8 @@ Patch3: %{name}-underlink.patch
Patch4: %{name}-crash-logs.patch
# Remove workaround for Cython bug that is already fixed in Fedora
Patch5: %{name}-sigismember.patch
# Workaround for nonconstant MINSIGSTKSZ
Patch6: %{name}-minsigstksz.patch
%global _description %{expand:
When writing Cython code, special care must be taken to ensure that the
@ -79,6 +82,9 @@ sed -i 's/language_level=2/language_level=3/' setup.py
# The doctest timeout is sometimes too short for 32-bit builders
sed -i 's/600/2400/' rundoctests.py
# Upstream does not generate the configure script
autoreconf -fi .
%build
%configure
%py3_build
@ -121,6 +127,10 @@ export PATH PYTHONPATH
%{_docdir}/%{name}/html
%changelog
* Thu Jun 17 2021 Jerry James <loganjerry@gmail.com> - 1.10.3-1
- Version 1.10.3
- Add -minsigstksz patch to fix FTBFS (bz 1935643)
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 1.10.2-12
- Rebuilt for Python 3.10

View File

@ -1 +1 @@
SHA512 (cysignals-1.10.2.tar.gz) = e76b1c2a479c21c4502a9836770a772dd6ead427799fc1dfcf7fba17008240d40bbf2ad3ce65f1ba4db550c802d60a9844182b5a4ebd30180edf797bb68d15c0
SHA512 (1.10.3.tar.gz) = aa7549afca7006ef3565b612f6b10e43fe135b4383c0b3ea9ecba56a0a6bc79de269cf6c0cb02ab758c9e259f2c8b9461438903b349c84e0e4e2c906964ebe95