New upstream release (bz 1601237).

Drop upstreamed -import patch.
The Cython libraries are used at runtime, so add Requires.
This commit is contained in:
Jerry James 2018-08-10 20:07:52 -06:00
parent 439efd22fe
commit 54251165d0
6 changed files with 28 additions and 36 deletions

View File

@ -1,7 +1,6 @@
diff -up src/cysignals/implementation.c.orig src/cysignals/implementation.c
--- src/cysignals/implementation.c.orig 2018-04-17 06:09:44.000000000 -0600
+++ src/cysignals/implementation.c 2018-05-18 13:07:49.838120881 -0600
@@ -102,7 +102,7 @@ static int sig_raise_exception(int sig,
--- src/cysignals/implementation.c.orig 2018-07-10 14:22:01.000000000 -0600
+++ src/cysignals/implementation.c 2018-08-01 13:27:13.278964441 -0600
@@ -107,7 +107,7 @@ static int sig_raise_exception(int sig,
*/
static inline void reset_CPU(void)
{

View File

@ -1,16 +1,14 @@
diff -up setup.py.orig setup.py
--- setup.py.orig 2018-04-17 06:09:44.000000000 -0600
+++ setup.py 2018-05-18 15:00:29.947627141 -0600
@@ -42,10 +42,13 @@ if sys.platform == 'cygwin':
--- setup.py.orig 2018-08-01 13:27:41.966583309 -0600
+++ setup.py 2018-08-01 13:28:43.609764343 -0600
@@ -45,9 +45,12 @@ if sys.platform == 'cygwin':
# false positives in the longjmp() check.
undef_macros = ["_FORTIFY_SOURCE"]
+extra_compile_args = ["-Wp,-U_FORTIFY_SOURCE"]
+
kwds = dict(include_dirs=[opj("src", "cysignals"),
opj(cythonize_dir, "src"),
opj(cythonize_dir, "src", "cysignals")],
depends=glob(opj("src", "cysignals", "*.h")),
kwds = dict(include_dirs=[opj("src"),
opj("src", "cysignals")],
depends=depends,
+ extra_compile_args=extra_compile_args,
define_macros=macros,
undef_macros=undef_macros)

View File

@ -1,12 +0,0 @@
diff -up src/cysignals/signals.pxd.orig src/cysignals/signals.pxd
--- src/cysignals/signals.pxd.orig 2018-04-17 06:09:44.000000000 -0600
+++ src/cysignals/signals.pxd 2018-05-19 15:21:19.591334451 -0600
@@ -16,7 +16,7 @@
#*****************************************************************************
# Auto-generated file setting the correct include directories
-cimport cysignals.__init__
+import cysignals.__init__
from libc.signal cimport sig_atomic_t

View File

@ -1,6 +1,6 @@
--- setup.py.orig 2018-05-18 15:00:29.947627141 -0600
+++ setup.py 2018-05-19 17:31:15.645373508 -0600
@@ -51,9 +51,11 @@ kwds = dict(include_dirs=[opj("src", "cy
--- setup.py.orig 2018-08-01 13:28:43.609764343 -0600
+++ setup.py 2018-08-01 13:31:04.099897839 -0600
@@ -53,9 +53,11 @@ kwds = dict(include_dirs=[opj("src"),
extra_compile_args=extra_compile_args,
define_macros=macros,
undef_macros=undef_macros)

View File

@ -1,8 +1,11 @@
%global modname cysignals
# Python files are installed into nonstandard locations
%global _python_bytecompile_extra 0
Name: python-%{modname}
Version: 1.7.1
Release: 3%{?dist}
Version: 1.7.2
Release: 1%{?dist}
Summary: Interrupt and signal handling for Cython
License: LGPLv3+
URL: https://github.com/sagemath/%{modname}
@ -15,10 +18,8 @@ Patch0: %{name}-gdb.patch
Patch1: %{name}-emms.patch
# Counteract _FORTIFY_SOURCE
Patch2: %{name}-fortify.patch
# Fix an import error
Patch3: %{name}-import.patch
# Fix underlinked signals.so
Patch4: %{name}-underlink.patch
Patch3: %{name}-underlink.patch
%global _description \
When writing Cython code, special care must be taken to ensure that the\
@ -42,6 +43,7 @@ Summary: %{summary}
BuildRequires: python2-devel
BuildRequires: python2-Cython
BuildRequires: python2-setuptools
Requires: python2-Cython
%description -n python2-%{modname} %{_description}
%package -n python2-%{modname}-devel
@ -56,6 +58,7 @@ Summary: %{summary}
BuildRequires: python3-devel
BuildRequires: python3-Cython
BuildRequires: python3-setuptools
Requires: python3-Cython
%description -n python3-%{modname} %{_description}
%package -n python3-%{modname}-devel
@ -78,7 +81,6 @@ Documentation and examples for %{name}.
%patch1
%patch2
%patch3
%patch4
%build
%configure
@ -129,7 +131,7 @@ export PYTHONPATH
%license LICENSE
%doc PKG-INFO README.rst
%{_bindir}/%{modname}-CSI-2
%{_bindir}/%{modname}-CSI-helper.py
%{_datadir}/%{modname}/
%{python2_sitearch}/%{modname}
%{python2_sitearch}/%{modname}-*.egg-info
%exclude %{python2_sitearch}/%{modname}/*.h
@ -145,7 +147,7 @@ export PYTHONPATH
%license LICENSE
%doc PKG-INFO README.rst
%{_bindir}/%{modname}-CSI-3
%{_bindir}/%{modname}-CSI-helper.py
%{_datadir}/%{modname}/
%{python3_sitearch}/%{modname}
%{python3_sitearch}/%{modname}-*.egg-info
%exclude %{python3_sitearch}/%{modname}/*.h
@ -162,6 +164,11 @@ export PYTHONPATH
%{_docdir}/%{name}/html
%changelog
* Fri Aug 10 2018 Jerry James <loganjerry@gmail.com> - 1.7.2-1
- New upstream release (bz 1601237)
- Drop upstreamed -import patch
- The Cython libraries are used at runtime, so add Requires
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (cysignals-1.7.1.tar.gz) = 7ea34f6017aeb6619a79a0e9de055e0e17d36bcc26586582ac59dc33736dd4b551a66b6cceb404a940276dbcad200923de7fdfb2460c6f065d74f59c6235a4cb
SHA512 (cysignals-1.7.2.tar.gz) = aa3526322f081877c5e9a51a4247a2b8c7c39bff0d96e2daabcfce27b7792e4403693a6077edc4198d57b8c72b7fd87eb42bd796cdc599d8963efd94b1100429