New upstream version.

This commit is contained in:
Jerry James 2019-04-23 14:40:18 -06:00
parent c02bdf432c
commit 105d4153fb
5 changed files with 26 additions and 23 deletions

View File

@ -1,6 +1,7 @@
diff -up src/cysignals/implementation.c.orig src/cysignals/implementation.c
--- src/cysignals/implementation.c.orig 2018-07-10 14:22:01.000000000 -0600
+++ src/cysignals/implementation.c 2018-08-01 13:27:13.278964441 -0600
@@ -107,7 +107,7 @@ static int sig_raise_exception(int sig,
@@ -118,7 +118,7 @@ static int sig_raise_exception(int sig,
*/
static inline void reset_CPU(void)
{

View File

@ -1,15 +1,12 @@
--- setup.py.orig 2018-08-01 13:27:41.966583309 -0600
+++ setup.py 2018-08-01 13:28:43.609764343 -0600
@@ -45,9 +45,12 @@ if sys.platform == 'cygwin':
# false positives in the longjmp() check.
undef_macros = ["_FORTIFY_SOURCE"]
+extra_compile_args = ["-Wp,-U_FORTIFY_SOURCE"]
+
kwds = dict(include_dirs=[opj("src"),
opj("src", "cysignals")],
diff -up setup.py.orig setup.py
--- setup.py.orig 2019-03-14 07:39:24.000000000 -0600
+++ setup.py 2019-04-08 09:38:40.734211624 -0600
@@ -50,7 +50,7 @@ kwds = dict(include_dirs=[opj("src"),
depends=depends,
+ extra_compile_args=extra_compile_args,
define_macros=macros,
undef_macros=undef_macros)
undef_macros=undef_macros,
- extra_compile_args=["-pthread"],
+ extra_compile_args=["-Wp,-U_FORTIFY_SOURCE", "-pthread"],
extra_link_args=["-pthread"],)
extensions = [

View File

@ -1,9 +1,10 @@
--- setup.py.orig 2018-08-01 13:28:43.609764343 -0600
+++ setup.py 2018-08-01 13:31:04.099897839 -0600
@@ -53,9 +53,11 @@ kwds = dict(include_dirs=[opj("src"),
extra_compile_args=extra_compile_args,
define_macros=macros,
undef_macros=undef_macros)
diff -up setup.py.orig setup.py
--- setup.py.orig 2019-04-08 09:38:40.734211624 -0600
+++ setup.py 2019-04-08 09:39:15.984581008 -0600
@@ -52,9 +52,11 @@ kwds = dict(include_dirs=[opj("src"),
undef_macros=undef_macros,
extra_compile_args=["-Wp,-U_FORTIFY_SOURCE", "-pthread"],
extra_link_args=["-pthread"],)
+parikwds = kwds.copy()
+parikwds['libraries'] = ['pari']

View File

@ -4,13 +4,14 @@
%global _python_bytecompile_extra 0
Name: python-%{modname}
Version: 1.8.1
Release: 2%{?dist}
Version: 1.10.2
Release: 1%{?dist}
Summary: Interrupt and signal handling for Cython
License: LGPLv3+
URL: https://github.com/sagemath/%{modname}
Source0: https://github.com/sagemath/%{modname}/releases/download/%{version}/%{modname}-%{version}.tar.gz
BuildRequires: gcc
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: pari-devel
# https://bugzilla.redhat.com/show_bug.cgi?id=1445411#c2
Patch0: %{name}-gdb.patch
@ -114,6 +115,9 @@ export PATH PYTHONPATH
%{_docdir}/%{name}/html
%changelog
* Tue Apr 23 2019 Jerry James <loganjerry@gmail.com> - 1.10.2-1
- New upstream release
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (cysignals-1.8.1.tar.gz) = 70b29b0ab99077ba89bf9aae89438c030076a93e790d2c278a7d87d22e458158a6b7ca74b95cc01ee3945eaa72b9862de57aec505a6b7eeb5a342345435f8768
SHA512 (cysignals-1.10.2.tar.gz) = e76b1c2a479c21c4502a9836770a772dd6ead427799fc1dfcf7fba17008240d40bbf2ad3ce65f1ba4db550c802d60a9844182b5a4ebd30180edf797bb68d15c0