python-blivet/0003-Revert-Use-PARTITION_E...

60 lines
1.8 KiB
Diff

From 639153117b9981b7b38480a7dbadb22725798f50 Mon Sep 17 00:00:00 2001
From: Vojtech Trefny <vtrefny@redhat.com>
Date: Mon, 19 Jul 2021 10:57:55 +0200
Subject: [PATCH] Revert "Use PARTITION_ESP flag for EFIFS partitions
(#1930486)"
This reverts commit aeffc4d50d5059e6a782ee41ccd49061d28996ab.
Using the correct 0xef partition type for EFI System Partition
unfortunately doesn't work with RaspberryPi so we need to keep
using 0x06 with "normal" boot flag to make it boot.
Resolves: rhbz#1975375
---
blivet/formats/fs.py | 10 ++--------
python-blivet.spec | 2 +-
2 files changed, 3 insertions(+), 9 deletions(-)
diff --git a/blivet/formats/fs.py b/blivet/formats/fs.py
index d75a34eb2..23c6f968a 100644
--- a/blivet/formats/fs.py
+++ b/blivet/formats/fs.py
@@ -29,13 +29,7 @@
import random
import stat
-from parted import fileSystemType
-
-try:
- from parted import PARTITION_ESP
-except ImportError:
- # this flag is sometimes not available in pyparted, see https://github.com/dcantrell/pyparted/issues/80
- PARTITION_ESP = 18
+from parted import fileSystemType, PARTITION_BOOT
from ..tasks import fsck
from ..tasks import fsinfo
@@ -948,7 +942,7 @@ class EFIFS(FATFS):
_min_size = Size("50 MiB")
_check = True
_mount_class = fsmount.EFIFSMount
- parted_flag = PARTITION_ESP
+ parted_flag = PARTITION_BOOT
@property
def supported(self):
diff --git a/python-blivet.spec b/python-blivet.spec
index c0cb91c95..3a18ca7fa 100644
--- a/python-blivet.spec
+++ b/python-blivet.spec
@@ -33,7 +33,7 @@ Source1: http://github.com/storaged-project/blivet/archive/%{realname}-%{realver
# Versions of required components (done so we make sure the buildrequires
# match the requires versions of things).
-%global partedver 3.2
+%global partedver 1.8.1
%global pypartedver 3.10.4
%global utillinuxver 2.15.1
%global libblockdevver 2.24