From 19c06ca1e99eeca40b99a42867a43f3333512bd9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
Date: Fri, 10 Dec 2021 12:14:57 +0100
Subject: [PATCH] Include the Python version in the summary and description

---
 pypy3.7.spec | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/pypy3.7.spec b/pypy3.7.spec
index 956b601..71f97b7 100644
--- a/pypy3.7.spec
+++ b/pypy3.7.spec
@@ -3,7 +3,7 @@
 Name:           pypy%{pyversion}
 Version:        %{basever}.7
 Release:        1%{?dist}
-Summary:        Python 3 implementation with a Just-In-Time compiler
+Summary:        Python %{pyversion} implementation with a Just-In-Time compiler
 
 # PyPy is MIT
 # Python standard library is Python
@@ -251,9 +251,9 @@ Obsoletes: pypy3 < 7.3.4-4
 %endif
 
 %description
-PyPy's implementation of Python 3, featuring a Just-In-Time compiler on some CPU
-architectures, and various optimized implementations of the standard types
-(strings, dictionaries, etc)
+PyPy's implementation of Python %{pyversion}, featuring a Just-In-Time compiler
+on some CPU architectures, and various optimized implementations
+of the standard types (strings, dictionaries, etc.).
 
 %if 0%{with_jit}
 This build of PyPy has JIT-compilation enabled.
@@ -264,7 +264,7 @@ CPU architecture.
 
 
 %package libs
-Summary:  Run-time libraries used by PyPy implementations of Python 3
+Summary:  Run-time libraries used by PyPy implementations of Python %{pyversion}
 
 # We supply an emacs mode for the JIT viewer.
 # (This doesn't bring in all of emacs, just the directory structure)
@@ -302,11 +302,11 @@ Provides: bundled(python3dist(ply)) = 3.9
 Provides: bundled(python3dist(cryptography)) = 2.7
 
 %description libs
-Libraries required by the various PyPy implementations of Python 3.
+Libraries required by the various PyPy implementations of Python %{pyversion}.
 
 
 %package devel
-Summary:  Development tools for working with PyPy3
+Summary:  Development tools for working with PyPy%{pyversion}
 Requires: pypy%{pyversion}%{?_isa} = %{version}-%{release}
 
 %if %{with main_pypy3}
@@ -316,7 +316,7 @@ Obsoletes: pypy3-devel < 7.3.4-4
 %endif
 
 %description devel
-Header files for building C extension modules against PyPy3
+Header files for building C extension modules against PyPy%{pyversion}.
 
 
 %prep