Update to 7.1.1, pypy3 is now Python 3.6
https://bugzilla.redhat.com/show_bug.cgi?id=1689198
This commit is contained in:
parent
3e4b7200d3
commit
cac755a96a
1
.gitignore
vendored
1
.gitignore
vendored
@ -7,3 +7,4 @@
|
||||
/pypy3-v5.10.1-src.tar.bz2
|
||||
/pypy3-v6.0.0-src.tar.bz2
|
||||
/pypy3.5-v7.0.0-src.tar.bz2
|
||||
/pypy3.6-v7.1.1-src.tar.bz2
|
||||
|
@ -4,60 +4,6 @@ Date: Wed Mar 29 04:31:55 2017 +0200
|
||||
|
||||
011-no-faulthandler.patch
|
||||
|
||||
diff --git a/lib-python/3/test/regrtest.py b/lib-python/3/test/regrtest.py
|
||||
index c1d85f6..3d3072c 100755
|
||||
--- a/lib-python/3/test/regrtest.py
|
||||
+++ b/lib-python/3/test/regrtest.py
|
||||
@@ -124,7 +124,6 @@ import importlib
|
||||
|
||||
import argparse
|
||||
import builtins
|
||||
-import faulthandler
|
||||
import io
|
||||
import json
|
||||
import locale
|
||||
@@ -152,7 +151,10 @@ try:
|
||||
import _multiprocessing, multiprocessing.process
|
||||
except ImportError:
|
||||
multiprocessing = None
|
||||
-
|
||||
+try:
|
||||
+ import faulthandler
|
||||
+except ImportError:
|
||||
+ faulthandler = None
|
||||
|
||||
# Some times __path__ and __file__ are not absolute (e.g. while running from
|
||||
# Lib/) and, if we change the CWD to run the tests in a temporary dir, some
|
||||
@@ -486,17 +488,18 @@ def main(tests=None, **kwargs):
|
||||
directly to set the values that would normally be set by flags
|
||||
on the command line.
|
||||
"""
|
||||
- # Display the Python traceback on fatal errors (e.g. segfault)
|
||||
- faulthandler.enable(all_threads=True)
|
||||
-
|
||||
- # Display the Python traceback on SIGALRM or SIGUSR1 signal
|
||||
- signals = []
|
||||
- if hasattr(signal, 'SIGALRM'):
|
||||
- signals.append(signal.SIGALRM)
|
||||
- if hasattr(signal, 'SIGUSR1'):
|
||||
- signals.append(signal.SIGUSR1)
|
||||
- for signum in signals:
|
||||
- faulthandler.register(signum, chain=True)
|
||||
+ if faulthandler:
|
||||
+ # Display the Python traceback on fatal errors (e.g. segfault)
|
||||
+ faulthandler.enable(all_threads=True)
|
||||
+
|
||||
+ # Display the Python traceback on SIGALRM or SIGUSR1 signal
|
||||
+ signals = []
|
||||
+ if hasattr(signal, 'SIGALRM'):
|
||||
+ signals.append(signal.SIGALRM)
|
||||
+ if hasattr(signal, 'SIGUSR1'):
|
||||
+ signals.append(signal.SIGUSR1)
|
||||
+ for signum in signals:
|
||||
+ faulthandler.register(signum, chain=True)
|
||||
|
||||
replace_stdout()
|
||||
|
||||
diff --git a/lib-python/3/test/support/__init__.py b/lib-python/3/test/support/__init__.py
|
||||
index 5d7f308..4424637 100644
|
||||
--- a/lib-python/3/test/support/__init__.py
|
||||
|
@ -1,5 +1,5 @@
|
||||
diff --git a/lib-python/3/ensurepip/__init__.py b/lib-python/3/ensurepip/__init__.py
|
||||
index 25c5567..6d8d09c 100644
|
||||
index 9f5d151..8b81155 100644
|
||||
--- a/lib-python/3/ensurepip/__init__.py
|
||||
+++ b/lib-python/3/ensurepip/__init__.py
|
||||
@@ -1,16 +1,27 @@
|
||||
@ -31,9 +31,9 @@ index 25c5567..6d8d09c 100644
|
||||
+
|
||||
+_PIP_VERSION = _get_most_recent_wheel_version("pip")
|
||||
|
||||
# pip currently requires ssl support, so we try to provide a nicer
|
||||
# error message when that is missing (http://bugs.python.org/issue19744)
|
||||
@@ -37,8 +48,13 @@ def _run_pip(args, additional_paths=None):
|
||||
_PROJECTS = [
|
||||
("setuptools", _SETUPTOOLS_VERSION),
|
||||
@@ -24,8 +35,13 @@ def _run_pip(args, additional_paths=None):
|
||||
sys.path = additional_paths + sys.path
|
||||
|
||||
# Install the bundled software
|
||||
@ -49,7 +49,7 @@ index 25c5567..6d8d09c 100644
|
||||
|
||||
|
||||
def version():
|
||||
@@ -93,12 +109,9 @@ def bootstrap(*, root=None, upgrade=False, user=False,
|
||||
@@ -79,12 +95,9 @@ def bootstrap(*, root=None, upgrade=False, user=False,
|
||||
additional_paths = []
|
||||
for project, version in _PROJECTS:
|
||||
wheel_name = "{}-{}-py2.py3-none-any.whl".format(project, version)
|
||||
|
24
pypy3.spec
24
pypy3.spec
@ -1,8 +1,8 @@
|
||||
%global basever 7.0
|
||||
%global basever 7.1
|
||||
Name: pypy3
|
||||
Version: %{basever}.0
|
||||
%global pyversion 3.5
|
||||
Release: 2%{?dist}
|
||||
Version: %{basever}.1
|
||||
%global pyversion 3.6
|
||||
Release: 1%{?dist}
|
||||
Summary: Python 3 implementation with a Just-In-Time compiler
|
||||
|
||||
# LGPL and another free license we'd need to ask spot about are present in some
|
||||
@ -134,8 +134,7 @@ ExcludeArch: aarch64 %{power64}
|
||||
|
||||
# Turn off the brp-python-bytecompile postprocessing script
|
||||
# We manually invoke it later on, using the freshly built pypy binary
|
||||
%global __os_install_post \
|
||||
%(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
|
||||
%global __brp_python_bytecompile %{nil}
|
||||
|
||||
# Source and patches:
|
||||
Source0: https://bitbucket.org/pypy/pypy/downloads/pypy%{pyversion}-v%{version}-src.tar.bz2
|
||||
@ -321,13 +320,6 @@ Build of PyPy3 with support for micro-threads for massive concurrency
|
||||
%prep
|
||||
%autosetup -n pypy%{pyversion}-v%{version}-src -p1 -S git
|
||||
|
||||
# While this is 7.0.0, it has 7.1.0-alpha0 listed inside
|
||||
# We sed it out to avoid user confusion
|
||||
sed -i 's/7\.1\.0/7.0.0/' pypy/doc/conf.py
|
||||
sed -i 's/7\.1\.0-alpha0/7.0.0/g' pypy/module/cpyext/include/patchlevel.h pypy/doc/how-to-release.rst
|
||||
sed -i 's/0x07010000/0x07000000/' pypy/module/cpyext/include/patchlevel.h
|
||||
sed -i 's/7, 1, 0, "alpha"/7, 0, 0, "final"/' pypy/module/sys/version.py
|
||||
|
||||
|
||||
%if %{with rpmwheels}
|
||||
%apply_patch -m %(basename %{SOURCE189}) %{SOURCE189}
|
||||
@ -737,7 +729,7 @@ CheckPyPy() {
|
||||
|
||||
# Use regrtest to explicitly list all tests:
|
||||
( ./$ExeName -c \
|
||||
"from test.regrtest import findtests; print('\n'.join(findtests()))"
|
||||
"from test.libregrtest.runtest import findtests; print('\n'.join(findtests()))"
|
||||
) > testnames.txt
|
||||
|
||||
# Skip some tests:
|
||||
@ -877,6 +869,10 @@ CheckPyPy %{name}-stackless
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri May 24 2019 Miro Hrončok <mhroncok@redhat.com> - 7.1.1-1
|
||||
- Update to 7.1.1 (#1689198)
|
||||
- pypy3 is now Python 3.6
|
||||
|
||||
* Thu May 16 2019 Miro Hrončok <mhroncok@redhat.com> - 7.0.0-2
|
||||
- Show the version as 7.0.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pypy3.5-v7.0.0-src.tar.bz2) = 3facac26e06e254cbf244841824b35ec211859123f6ba9f095dc980292c10d9cf1d11de62cc6372cf77e92ee1cd2358bbd794b3ff25cb7172e1b21c02c8ce6c2
|
||||
SHA512 (pypy3.6-v7.1.1-src.tar.bz2) = 17e78f9c7080d597a6283d8e8247d1ca78f09a14ff221db8c3d90d255b5befc73102b317ca34a80979e544d5ee72f3e5e649f89d185a085f4cc15012da4d0473
|
||||
|
@ -10,7 +10,7 @@
|
||||
tests:
|
||||
- smoke:
|
||||
dir: python/smoke
|
||||
run: PYTHON=pypy3 VERSION=3.5 ./venv.sh
|
||||
run: PYTHON=pypy3 VERSION=3.6 ./venv.sh
|
||||
required_packages:
|
||||
- gcc
|
||||
- python3-tox
|
||||
|
Loading…
Reference in New Issue
Block a user